Bug 70051 - htmlview doesn't allow new pages to use new windows
htmlview doesn't allow new pages to use new windows
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: htmlview (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 77106 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-29 14:24 EDT by Reuben Thomas
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Thomas 2002-07-29 14:24:01 EDT
Description of Problem:

html view is handy, but doesn't take advantage of the various browsers' ability to 
open the new URL in a new window, and so typically splats the contents of an 
existing window. Since this is easy to do in Netscape, Mozilla, Opera &c., it'd be 
nice to see it implemented.

Version-Release number of selected component (if applicable):


How Reproducible:

Every time

Steps to Reproduce:
1. Open a URL using htmlview, and configured browser e.g. opera

Actual Results:

It reuses an already open window.

Expected Results:

It should open a new one. Even better, it should be configurable.

Additional Information:
	
There's one other slight oddity:

		if exists $i; then
			exec $i $*
		fi

vs

		exists $i && exec $i $*

a few lines lower. Better to be consistent?
Comment 1 Reuben Thomas 2003-12-01 08:16:58 EST
*** Bug 77106 has been marked as a duplicate of this bug. ***
Comment 2 Chris Petersen 2004-05-22 04:08:20 EDT
htmlview now seems to be able to use gnome's configured browser
(cool).  Not so cool is that it checks to see if the browser exists,
and if it doesn't, invokes an error.  I happen to have the following
defined as my browser in gnome:

galeon --new-tab --noraise %s

htmlview has decided that there is no application on my system named
"galeon --new-tab --noraise  " and every time I run it, it brings up
the gnome-default-applications-properties program and asks me to
reconfigure (which it doesn't need to because every other app seems to
handle this just fine, as it should)

Note You need to log in before you can comment on or make changes to this bug.