Bug 70057 - a2ps exits with unknown encoding `utf-8'
Summary: a2ps exits with unknown encoding `utf-8'
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: a2ps   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 65252 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-29 19:26 UTC by Jim Wiedman
Modified: 2011-05-26 19:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 10:16:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Wiedman 2002-07-29 19:26:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020618 Netscape/7.0b1

Description of problem:
When I type a2ps and any option (but --help), the program quits with
the following error message:

a2ps: unknown encoding `utf-8'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter a2ps at the prompt.
2.
3.
	

Actual Results:  Only the error message.  No postscript is produced.

Expected Results:  I expected postscript data to be sent to the printer.

Additional info:

Comment 1 Gene Czarcinski 2002-08-01 21:52:13 UTC
verified on 7.3.93

Comment 2 Tim Waugh 2002-08-05 08:48:09 UTC
Which locale are you using?

Comment 3 Gene Czarcinski 2002-08-05 09:12:16 UTC
US, English.

I just checked and LANG=en_US.UTF-8

Comment 4 Tim Waugh 2002-08-05 09:40:39 UTC
Well, a2ps doesn't support UTF-8 yet.  Does it mostly work if you put: 
 
utf-8     iso1 
 
at the end of /usr/share/a2ps/encoding/encoding.map?

Comment 5 Gene Czarcinski 2002-08-05 09:58:59 UTC
works for me but I hope that does not screw anyone else

Comment 6 Tim Waugh 2002-08-05 10:16:35 UTC
It's the behaviour that previous versions (before the automatic-encoding 
patch) had at least. 
 
Fixed package is 4.13b-24.

Comment 7 Jay Turner 2002-08-05 15:32:08 UTC
Fix confirmed with a2ps-4.13b-24.

Comment 8 Michel Alexandre Salim 2011-05-26 12:33:29 UTC
*** Bug 706666 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.