Bug 70063 - degraded RAID 1 arrays are not detected
degraded RAID 1 arrays are not detected
Status: CLOSED DUPLICATE of bug 61844
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-07-29 16:33 EDT by Alexandre Oliva
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-07-29 16:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-07-29 16:33:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
RAID 1 devices that are missing some components (say, if I took out one of the
two replicas of my / filesystem to install the new beta on it) are not properly
detected.  The installers reports the partitions as RAID devices, but not as
members of any RAID device.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1.Create a RAID1 device out of two partitions.
2.Create a filesystem on it.
3.raidsetfaulty and raidhotremove one of the partitions
4.Create a new RAID1 device using the partition that had been removed, with the
other device marked as failed-disk.
5.Create a filesystem on it.
6.Start the installer.

Actual Results:  It reports both partitions as having type RAID type, but
they're not members of any RAID device.  I can't create a RAID device out of any
single one of them while preserving the contents either.  I can't ask the
installer to install on any of them as if it just contained an ext3 filesystem,
without formatting the entire partition and losing the RAID bits. (I can do this
by changing the partition type with fdisk, though; phew!).

Expected Results:  It should detect RAID arrays containing failed-disks.  It
would be nice to be able to create RAID devices like that too, but this is a
separate bug report.  It would be nice to be able to tell the installer to use
the existing ext3 filesystem without having to format it or tweak its RAID type.

Additional info:

This is on the second Limbo.  I haven't tried any of this with the first Limbo
Comment 1 Jeremy Katz 2002-07-30 00:41:20 EDT
Dupe of a combination of earlier bug reports about using/creation of degraded
raid sets

*** This bug has been marked as a duplicate of 61844 ***

Note You need to log in before you can comment on or make changes to this bug.