Bug 70065 - missing variable in /etc/sysconfig/squid
Summary: missing variable in /etc/sysconfig/squid
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: squid   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 70785 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-29 21:02 UTC by Tim Clymo
Modified: 2014-03-17 02:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-29 21:02:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Clymo 2002-07-29 21:02:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
Could you add something like:
SQUID_PIDFILE_TIMEOUT=20
(or whatever it should be by default) to /etc/sysconfig/squid. This will avoid
the error on line 65 of /etc/init.d/squid when it tries to do a test on the
value of this (currently unset) variable

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.service squid start
2.
3.
	

Actual Results:  Starting squid: /etc/init.d/squid: [: 0: unary operator expected

Additional info:

Comment 1 Karsten Hopp 2002-07-31 13:00:06 UTC
fixed in the initscript, not in the config file

Comment 2 Bill Nottingham 2002-08-12 19:57:56 UTC
*** Bug 70785 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.