Bug 70785 - /etc/sysconfig/squid should specify SQUID_PIDFILE_TIMEOUT
Summary: /etc/sysconfig/squid should specify SQUID_PIDFILE_TIMEOUT
Status: CLOSED DUPLICATE of bug 70065
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: squid   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-05 09:26 UTC by Need Real Name
Modified: 2014-03-17 02:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 09:26:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-08-05 09:26:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
The /etc/sysconfig/squid file does not specify the variable
SQUID_PIDFILE_TIMEOUT. This variable is expected by the /etc/rc.d/init.d/squid
startscript. The startscript does not provide any default so a shell syntax
error message occurs when the script is run with "start" as the first parameter.

Version-Release number of selected component (if applicable):
2.4.STABLE7-2

How reproducible:
Always

Steps to Reproduce:
1.Be root and RPM-install squid from the "limbo" distribution.
2.Type `/etc/rc.d/init.d/squid start'

	

Actual Results:  Error message seen, "/etc/rc.d/init.d/squid: line 65: [: 0:
unary operator expected".

Expected Results:  No such error message.

Additional info:

Workaround: Append something like "SQUID_PIDFILE_TIMEOUT=3600" to
/etc/sysconfig/squid.

To fix the bug it may be a good idea to make the /etc/rc.d/init.d/squid script
permissive so that if the variable is not specified in /etc/sysconfig/squid it
will be automatically declared and given a reasonable default value.

I am leaving the severity as "normal" since I have not investigated what the
consequences of the bug really are. Perhaps the severity could be "low"; at
least it seems that the squid process starts and can be stopped in an orderly
fashion even if the workaround is not applied.

Comment 1 Bill Nottingham 2002-08-12 19:58:01 UTC

*** This bug has been marked as a duplicate of 70065 ***


Note You need to log in before you can comment on or make changes to this bug.