Bug 700701 - Migration progress stuck with qcow2 image ENOSPAC during installation
Migration progress stuck with qcow2 image ENOSPAC during installation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
: 700706 704441 (view as bug list)
Depends On: 682653
Blocks: Rhel5KvmTier3 Rhel5KvmTier2 Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-04-29 01:08 EDT by dengmin
Modified: 2013-01-09 18:51 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 682653
Environment:
Last Closed: 2011-11-02 05:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
It is convenient for developer to catch the migration time. (104.37 KB, image/png)
2011-04-29 06:23 EDT, dengmin
no flags Details

  None (edit)
Comment 1 dengmin 2011-04-29 06:19:21 EDT
Please ignore the 'Notes' in above comments and already tried the issue with following kernel&kvm on AMD host again.
-------------------------------------------------------------
kernel&kvm version
2.6.18-256.el5&kvm-83-231.el5
-------------------------------------------------------------
Additional,
1.Use iscsi and had better have the source and destination connect to a third-party server
2.create a lvm about 156M and begin migration at a time (please see attachment)
-log info
From source host-
/usr/libexec/qemu-kvm -rtc-td-hack -usbdevice tablet -no-hpet -drive file=/dev/migrate/deng1,if=virtio,boot=on,werror=stop,cache=none,format=qcow2,media=disk -cpu qemu64,+sse2 -smp 4 -m 4G -net nic,macaddr=00:12:24:57:a8:2e,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -vnc :2 -boot dc -balloon none -monitor stdio -drive file=/opt/RHEL5.6-Server-20110106.0-x86_64-DVD.iso,if=ide,werror=stop,cache=none,format=raw,media=cdrom -notify all
QEMU 0.9.1 monitor - type 'help' for more information
(qemu) 
(qemu) 
(qemu) 
(qemu) migrate -d tcp:10.66.9.101:1234
# VM is stopped due to disk write error: virtio0: Invalid argument

(qemu) migration_notify_done
info migrate
Migration status: active
transferred ram: 162 kbytes
remaining ram: 4213732 kbytes
total ram: 4214796 kbytes
(qemu) info migrate
Migration status: active
transferred ram: 162 kbytes
remaining ram: 4213732 kbytes
total ram: 4214796 kbytes
(qemu) info migrate
Migration status: active
transferred ram: 162 kbytes
remaining ram: 4213732 kbytes
total ram: 4214796 kbytes
(qemu) info migrate
Migration status: active
transferred ram: 162 kbytes
remaining ram: 4213732 kbytes
total ram: 4214796 kbytes
(qemu) info migrate
Migration status: active
transferred ram: 162 kbytes
remaining ram: 4213732 kbytes
total ram: 4214796 kbytes
(qemu) info migrate
Migration status: active
transferred ram: 162 kbytes
remaining ram: 4213732 kbytes
total ram: 4214796 kbytes
Comment 2 dengmin 2011-04-29 06:23:29 EDT
Created attachment 495748 [details]
It is convenient for developer to catch the migration time.
Comment 3 Glauber Costa 2011-05-16 15:48:57 EDT
*** Bug 700706 has been marked as a duplicate of this bug. ***
Comment 4 Dor Laor 2011-08-07 05:47:30 EDT
*** Bug 700706 has been marked as a duplicate of this bug. ***
Comment 5 Dor Laor 2011-08-07 05:48:09 EDT
*** Bug 704441 has been marked as a duplicate of this bug. ***
Comment 6 Ronen Hod 2011-10-31 06:12:54 EDT
Min,
We did not fix it for 5.8, but now that I read it again. Line #5 in your description says that it does not exist in 5.7. If it is true, then we should have closed it already.
Comment 7 Ronen Hod 2011-11-02 05:51:12 EDT
Well, looking at its duplicates, it seems to be relevant to 5.7 too.
Anyhow, we decided to close it for the following reasons:
1. Since we didn't make it for 5.8 dev-freeze and it doesn't look like a trivial fix, we gave up on 5.8.
2. Since there is no data corruption, we decided not to drag it further to 5.9

Note You need to log in before you can comment on or make changes to this bug.