This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 700706 - Guest's installation process hung up while doing migration hit ENOSPAC
Guest's installation process hung up while doing migration hit ENOSPAC
Status: CLOSED DUPLICATE of bug 700701
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
: Reopened
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2011-04-29 01:53 EDT by dengmin
Modified: 2013-01-09 18:51 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-07 05:47:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dengmin 2011-04-29 01:53:46 EDT
Description of problem:
Guest's installation process will hang up while doing migration hit ENOSPAC
Steps to reproduce,
preparation:
please use iscsi and had better have the source and destination hosts connect to the third-party server in order to gain an accurate results.

1.a.lvcreate -L 256M  migrate -n dengminsrc
    qemu-img create -f qcow2 /dev/migrate/dengminsrcv 20G
  b.boot guest on source host
/usr/libexec/qemu-kvm -rtc-td-hack -usbdevice tablet -no-hpet -drive file=/dev/migrate/dengminsrc,if=virtio,boot=on,werror=stop,cache=none,format=qcow2,media=disk -cpu qemu64,+sse2 -smp 2 -m 1G -net nic,macaddr=00:12:24:57:a8:2e,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -vnc :2 -boot dc -balloon none -monitor stdio -drive file=/home/RHEL5.6-Server-20110106.0-x86_64-DVD.iso,if=ide,werror=stop,cache=none,format=raw,media=cdrom

2.install OS via vncviewer and check VM status in monitor 
 
3.enlarge lvm after VM is paused and then continue VM
  lvextend -L +500M /dev/migrate/dengminsrc on source 

4.boot guest on destination
/usr/libexec/qemu-kvm -rtc-td-hack -usbdevice tablet -no-hpet -drive file=/dev/migrate/dengminsrc,if=virtio,boot=on,werror=stop,cache=none,format=qcow2,media=disk -cpu qemu64,+sse2 -smp 2 -m 1G -net nic,macaddr=00:12:24:57:a8:2e,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -vnc :2 -boot dc -balloon none -monitor stdio -drive file=/home/RHEL5.6-Server-20110106.0-x86_64-DVD.iso,if=ide,werror=stop,cache=none,format=raw,media=cdrom -incoming tcp:0:1111
  
5.a.do live migration from source to destination host
  b.(qemu)info migrate on source
    Migration status: completed

6. (qemu) info status on destination
    VM status: running

7.open destination guest via vncviewer to check the installation status
  
  Expected results:
  The installation goes on or if guest stop due to ENOSPAC the monitor should provide correct message on destination host
  Actual results:
  The installation hang up and user cannot finish installation.

  Addtitional info,
  Notes,at step 3,if you enlarge 2G to the lvm user won't hit the issue.
Comment 1 dengmin 2011-04-29 02:03:48 EDT
kernel&kvm 
2.6.18-256.el5
kmod-kvm-83-231.el5
Comment 2 Glauber Costa 2011-05-16 15:48:57 EDT
Sounds exactly like the same issue in BZ700701

*** This bug has been marked as a duplicate of bug 700701 ***
Comment 3 Mike Cao 2011-07-11 02:08:14 EDT
Reopen this one ,

They're different issue I think
this bug means :migration finished ,but steps of installation  in the guest hang.
Bug 700701 means :migrate *never* finished .
Comment 4 Ludek Smid 2011-07-12 04:02:50 EDT
It's too late for RHEL 5.7, moving to RHEL 5.8.

Note You need to log in before you can comment on or make changes to this bug.