Bug 701115 - [abrt] kernel: WARNING: at arch/x86/kernel/apic/apic.c:1284 setup_local_APIC+0x15b/0x20b()
Summary: [abrt] kernel: WARNING: at arch/x86/kernel/apic/apic.c:1284 setup_local_APIC+...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1366703686
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-01 09:51 UTC by Scott Marshall
Modified: 2011-08-24 20:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-24 20:58:35 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (666 bytes, text/plain)
2011-05-01 09:51 UTC, Scott Marshall
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 27642 0 None None None Never
Red Hat Bugzilla 666358 0 low CLOSED [abrt] kernel: WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218() 2021-02-22 00:41:40 UTC

Internal Links: 666358

Description Scott Marshall 2011-05-01 09:51:06 UTC
abrt version: 1.1.18
architecture: x86_64
cmdline: not_applicable
component: kernel
executable: kernel
kernel: 2.6.38.3-18.fc14.x86_64
package: kernel
reason: WARNING: at arch/x86/kernel/apic/apic.c:1284 setup_local_APIC+0x15b/0x20b()
release: Fedora release 14 (Laughlin)
time: 1304238416
uid: 0

backtrace
-----
WARNING: at arch/x86/kernel/apic/apic.c:1284 setup_local_APIC+0x15b/0x20b()
Hardware name: VirtualBox
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.38.3-18.fc14.x86_64 #1
Call Trace:
 [<ffffffff81058f5f>] ? warn_slowpath_common+0x85/0x9d
 [<ffffffff81058f91>] ? warn_slowpath_null+0x1a/0x1c
 [<ffffffff81482318>] ? setup_local_APIC+0x15b/0x20b
 [<ffffffff812443d9>] ? __bitmap_weight+0x3e/0x8a
 [<ffffffff81b6591e>] ? native_smp_prepare_cpus+0x29b/0x34b
 [<ffffffff81b58ce1>] ? kernel_init+0x92/0x2b6
 [<ffffffff8100ba64>] ? kernel_thread_helper+0x4/0x10
 [<ffffffff81b58c4f>] ? kernel_init+0x0/0x2b6
 [<ffffffff8100ba60>] ? kernel_thread_helper+0x0/0x10

comment
-----
This occurred after upgrading to kernel 2.6.38.3-18.fc14.x86_64.
This kernel was compiled under Fedora 14 x86_64 (physical system) from the src.rpm retrieved from the Fedora 15 source packages.

How to reproduce
-----
1. Started virtual box Fedora 14 x86_64 guest (running in Windows 7 host) after kernel upgrade
2. 
3.

Comment 1 Scott Marshall 2011-05-01 09:51:10 UTC
Created attachment 496045 [details]
File: backtrace

Comment 2 Scott Marshall 2011-05-01 09:58:01 UTC
According to https://bugzilla.kernel.org/show_bug.cgi?id=27642 this bug was supposedly fixed in the 2.6.38 kernel release.

Looks like it hasn't been fixed after all.

Comment 3 Scott Marshall 2011-05-24 09:10:20 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started virtual box Fedora 14 x86_64 guest (running in Windows 7 host) after kernel upgrade
2. 
3.


Comment
-----
This occurred after upgrading to kernel 2.6.38.3-18.fc14.x86_64.
This kernel was compiled under Fedora 14 x86_64 (physical system) from the src.rpm retrieved from the Fedora 15 source packages.

Comment 4 Scott Marshall 2011-05-24 10:12:44 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started virtual box Fedora 14 x86_64 guest (running in Windows 7 host) after virtualbox upgrade (now running VirtualBox v4.0.8 r71778 on Windows 7 x86_64 host)
2. 
3.


Comment
-----
Virtualbox was upgraded to v4.0.8 r71778 (Windows 7 x86-64 host)

Comment 5 Scott Marshall 2011-05-24 10:28:38 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started virtual box Fedora 14 x86_64 guest (running in Windows 7 host) after upgrade of VirtualBoxLinuxAdditions to v4.0.8 r71778 (with post-install reboot).
2. 
3.


Comment
-----
Virtualbox was upgraded to v4.0.8 r71778 (Windows 7 x86-64 host) and this was the first reboot after upgrading the VirtualBox Additions for Linux from v4.0.6 to 4.0.8.

Comment 6 Josh Boyer 2011-08-24 20:58:35 UTC
If you can duplicate this on a stock Fedora 14 or Fedora 15 kernel without the vbox modules loaded, please reopen.  Otherwise you'll need to work with the vbox developers.


Note You need to log in before you can comment on or make changes to this bug.