Bug 666358 - [abrt] kernel: WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
[abrt] kernel: WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
Unspecified Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:1664569926
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-30 05:43 EST by Scott Marshall
Modified: 2011-08-31 17:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-24 16:58:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (648 bytes, text/plain)
2010-12-30 05:43 EST, Scott Marshall
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 27642 None None None Never

  None (edit)
Description Scott Marshall 2010-12-30 05:43:36 EST
abrt version: 1.1.14
architecture: x86_64
cmdline: not_applicable
comment: VirtualBox version is v3.2.12 r68302
component: kernel
executable: kernel
kernel: 2.6.35.9-64.fc14.x86_64
package: kernel
reason: WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
release: Fedora release 14 (Laughlin)
tainted: 5/var/spool/abrt/kerneloops-1291880511-1724-1
time: 1293705393
uid: 0

backtrace
-----
WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
Hardware name: VirtualBox
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.35.9-64.fc14.x86_64 #1
Call Trace:
 [<ffffffff8104d855>] warn_slowpath_common+0x85/0x9d
 [<ffffffff8104d887>] warn_slowpath_null+0x1a/0x1c
 [<ffffffff81462fc0>] setup_local_APIC+0x148/0x218
 [<ffffffff81021fde>] ? apic_read+0x16/0x18
 [<ffffffff81badb36>] native_smp_prepare_cpus+0x2a3/0x353
 [<ffffffff81ba1cfe>] kernel_init+0xaa/0x2c0
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff81ba1c54>] ? kernel_init+0x0/0x2c0
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10

How to reproduce
-----
1. Powered up VM under VirtualBox (Win7-x64)
2. Logged in
3. That's it - ABRT reported an "oops"
Comment 1 Scott Marshall 2010-12-30 05:43:40 EST
Created attachment 471168 [details]
File: backtrace
Comment 2 Scott Marshall 2010-12-30 15:01:44 EST
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Started F14x64 virtual machine after upgrading to VirtualBox v4.0.0 r69151 (Windows x64 host)
2.  Logged in via GUI
3.  Instant "oops" notification
Comment 3 Scott Marshall 2010-12-30 15:59:46 EST
The new comment (https://bugzilla.redhat.com/show_bug.cgi?id=666358#c2) above was generated by ABRT after the kernel had been upgraded to v2.6.35.10-74.fc14.x86_64.
Comment 4 Scott Marshall 2010-12-30 16:48:18 EST
New back-trace from the upgraded kernel:

architecture: x86_64
cmdline: not_applicable
component: kernel
executable: kernel
kernel: 2.6.35.10-74.fc14.x86_64
package: kernel
reason: WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
release: Fedora release 14 (Laughlin)
tainted: 5/var/spool/abrt/kerneloops-1293738929-1754-1
time: 1293743692
uid: 0

backtrace
-----
WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
Hardware name: VirtualBox
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.35.10-74.fc14.x86_64 #1
Call Trace:
 [<ffffffff8104d999>] warn_slowpath_common+0x85/0x9d
 [<ffffffff8104d9cb>] warn_slowpath_null+0x1a/0x1c
 [<ffffffff814632e0>] setup_local_APIC+0x148/0x218
 [<ffffffff81021fde>] ? apic_read+0x16/0x18
 [<ffffffff81badb36>] native_smp_prepare_cpus+0x2a3/0x353
 [<ffffffff81ba1cfe>] kernel_init+0xaa/0x2c0
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff81ba1c54>] ? kernel_init+0x0/0x2c0
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10
Comment 5 Scott Marshall 2010-12-30 17:05:16 EST
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.  Started F14x64 virtual machine running under VirtualBox v4.0.0 r69151 (Windows 7 x64 host)
2.  Logged in via GUI
3.  Instant "oops" notification
Comment 6 Scott Marshall 2011-02-17 05:46:13 EST
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Booted Fedora 14 with kernel 2.6.35.11-83.fc14.x86_64 under Oracle Virtualbox
2.
3.


Comment
-----
Oracle Virtualbox version 4.0.0 r69151 is running under Windoze 7 x64
Comment 7 Scott Marshall 2011-02-17 05:56:19 EST
New data from abrt, including copy of new back-trace.

architecture: x86_64
cmdline: not_applicable
comment: Oracle Virtualbox version 4.0.0 r69151 is running under Windoze 7 x64
component: kernel
executable: kernel
kernel: 2.6.35.11-83.fc14.x86_64
package: kernel
reason: WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
release: Fedora release 14 (Laughlin)
tainted: 5/var/spool/abrt/kerneloops-1297937234-1724-1
time: 1297939385
uid: 0

backtrace
-----
WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
Hardware name: VirtualBox
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.35.11-83.fc14.x86_64 #1
Call Trace:
 [<ffffffff8104d9ad>] warn_slowpath_common+0x85/0x9d
 [<ffffffff8104d9df>] warn_slowpath_null+0x1a/0x1c
 [<ffffffff81463632>] setup_local_APIC+0x148/0x218
 [<ffffffff81022092>] ? apic_read+0x16/0x18
 [<ffffffff81badb36>] native_smp_prepare_cpus+0x2a3/0x353
 [<ffffffff81ba1cfe>] kernel_init+0xaa/0x2c0
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff81ba1c54>] ? kernel_init+0x0/0x2c0
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10
Comment 8 Scott Marshall 2011-02-17 06:37:27 EST
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Booted Fedora 14 with kernel 2.6.35.11-83.fc14.x86_64 under Oracle Virtualbox
2.
3.


Comment
-----
Oracle Virtualbox version 4.0.0 r69151 is running under Windoze 7 x64
Comment 9 Scott Marshall 2011-03-02 20:59:58 EST
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Booted Fedora 14 with kernel 2.6.35.11-83.fc14.x86_64 under Oracle Virtualbox (Win7  x86_64 host)
2.
3.


Comment
-----
Oracle Virtualbox version 4.0.4 r70112 is running under Windoze 7 x64
Comment 10 Scott Marshall 2011-04-30 07:33:26 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. First boot after upgrade of VirtualBox LinuxAdditions to v4.0.6
2.
3.


Comment
-----
The v4.0.6 VirtualBox Linux Additions install process removes the old kernel modules (both DKMS and non-DKMS) before building the new version of the additions against the active kernel.
A reboot after the upgrade took some time whilst DKMS performed its own check and build.
Comment 11 Scott Marshall 2011-04-30 07:50:15 EDT
architecture: x86_64
cmdline: not_applicable
component: kernel
executable: kernel
kernel: 2.6.35.12-90.fc14.x86_64
package: kernel
reason: WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
release: Fedora release 14 (Laughlin)
time: 1304162691
uid: 0

backtrace
-----
WARNING: at arch/x86/kernel/apic/apic.c:1238 setup_local_APIC+0x148/0x218()
Hardware name: VirtualBox
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.35.12-90.fc14.x86_64 #1
Call Trace:
 [<ffffffff8104dce1>] warn_slowpath_common+0x85/0x9d
 [<ffffffff8104dd13>] warn_slowpath_null+0x1a/0x1c
 [<ffffffff8146420b>] setup_local_APIC+0x148/0x218
 [<ffffffff810220b2>] ? apic_read+0x16/0x18
 [<ffffffff81badba0>] native_smp_prepare_cpus+0x2a3/0x353
 [<ffffffff81ba1cfe>] kernel_init+0xaa/0x2c0
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff81ba1c54>] ? kernel_init+0x0/0x2c0
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10
Comment 12 Bob Babcock 2011-05-27 15:06:33 EDT
Since all the comments in this report are for the 64-bit version, I'll just say that I see the same behavior with 32-bit Fedora 14.  The line number in apic.c is the same.  Fedora continues to run after the message; there is no obvious breakage.

Virtual Box is version 4.0.8 r71778 running on Windows 2003 server.
In the VM, uname -a reports 2.6.35.13-91.fc14.i686 #1 SMP.
Comment 13 Josh Boyer 2011-08-24 16:58:05 EDT
If you can duplicate this on Fedora 14 without the vbox modules loaded, please reopen.  Otherwise you'll need to work with the vbox developers.
Comment 14 Bob Babcock 2011-08-31 17:52:06 EDT
I don't seem to be getting this error anymore.  VirtualBox is now version 4.0.10 r72479 (and it's been nagging me that a newer version is available).  Fedora is now version 2.6.35.14-95.fc13.i686.  I'm not sure when the error stopped.

Note You need to log in before you can comment on or make changes to this bug.