Bug 7012 - Problems with zgv and PNG files - src and binary RPM
Problems with zgv and PNG files - src and binary RPM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: zgv (Show other bugs)
6.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Powers
:
: 7013 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-15 10:50 EST by Henri J. Schlereth
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-06 12:05:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri J. Schlereth 1999-11-15 10:50:53 EST
I have tried to use zgv with PNG on 4 RH6.0 systems and it errors out.
I have tried re-compiling from the src.rpm and it gives me a:

zgv.c: In function `makedirxv332':
zgv.c:1711: warning: suggest explicit braces to avoid ambiguous `else'
zgv.c: In function `update_xvpics':
zgv.c:1842: `errno' undeclared (first use in this function)
zgv.c:1842: (Each undeclared identifier is reported only once
zgv.c:1842: for each function it appears in.)
zgv.c:1842: `EEXIST' undeclared (first use in this function)
zgv.c:1842: `EACCES' undeclared (first use in this function)
zgv.c:1921: warning: suggest explicit braces to avoid ambiguous `else'
make: *** [zgv.o] Error 1

And I have patched the the code with the patches that came with the src
RPM. (zgv-3.0-8). I have downloaded the 3.3 tarball and modified it
and compiled it successfully. It does give lots of explict braces warnings
but still compiles. And of course works. I understand that 3.5 will be out
in a few weeks as well. I just thought you might like to know.

The binary rpm seems to default for no PNG support and if you are working
for a GIF free environment that can be a real pain.
Comment 1 Bill Nottingham 1999-11-15 11:43:59 EST
*** Bug 7013 has been marked as a duplicate of this bug. ***
Comment 2 Tim Powers 2000-02-15 13:49:59 EST
take a look at the zgv in the 6.1 tree. It seems to work fine. Also, there was a
5.0 release (how it got to 5.0 I have no idea) that was built for Powertools for
our next release, it's located in the rawhide tree at ftp.redhat.com.

Tim
Comment 3 Tim Powers 2000-04-06 12:05:59 EDT
Haven't heard back from you in a while. Closing this bug. If you still have
problems please reopen this bug.
Comment 4 Henri J. Schlereth 2000-04-08 14:51:59 EDT
Sorry, but yes the 5.0.1 is working fine. TNX Henri

Note You need to log in before you can comment on or make changes to this bug.