Bug 70149 - Anaconda crashes when actually starting installation
Anaconda crashes when actually starting installation
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 71939 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 15:18 EDT by Bernd Bartmann
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 22:43:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash dump from limbo2 (deleted)
2002-07-30 15:19 EDT, Bernd Bartmann
no flags Details
Anaconda crash dump from limbo2 (deleted)
2002-07-30 15:23 EDT, Bernd Bartmann
no flags Details
Anaconda crash dump from limbo2, 3rd try (69.18 KB, text/plain)
2002-07-31 14:22 EDT, Bernd Bartmann
no flags Details
Anaconda crash dump after fresh limbo2 installation (117.06 KB, text/plain)
2002-08-16 06:33 EDT, Bernd Bartmann
no flags Details

  None (edit)
Description Bernd Bartmann 2002-07-30 15:18:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
After answering all setup questions anaconda crashes on the package install
screen. Strange enough this only happens the first time when trying to install
limbo2. The second time (with exactly the same setup) anaconda runs without any
problem. I noticed this behaviour on two different systems. Crash dump attached.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Install limbo2 with my setup (see anaconda crash dump)
2. Anaconda crashes on the package install screen
3.
	

Additional info:
Comment 1 Michael Fulbright 2002-07-30 15:31:55 EDT
Have you run the mediacheck if you are installing from CD?
Comment 2 Bernd Bartmann 2002-07-30 15:39:16 EDT
Yes I did run the mediacheck. All 3 install discs PASSed. I'm having problems
attaching the crashdump to this bug. I already sent the error message to
bugzilla@redhat.com. Should I send you the crash dump via email?
Comment 3 Bernd Bartmann 2002-07-31 14:22:23 EDT
Created attachment 68025 [details]
Anaconda crash dump from limbo2, 3rd try
Comment 4 Need Real Name 2002-08-06 23:35:50 EDT
Anaconda crashed at the same point for me - I was attempting an upgrade.

I have an anacdump.txt file to include - can you please let me know if I should 
attach it?
Comment 5 Jeremy Katz 2002-08-15 14:11:47 EDT
If this is reproducible, can you go to tty2 when it crashes and look in
/tmp/lvmout and see if it has any indication as why the vgchange failed?
Comment 6 Bernd Bartmann 2002-08-16 04:45:21 EDT
Just tried to reproduce the problem. Here are the steps I did:
1. Delete all partitions from the hard disk using fdisk --> reboot
2. Start Limbo2 installation ...
3. Manually create swap and root partition using fdisk. When writing the
partition table I see a short message telling me that the kernel could not
re-read the partition table (never had a similar problem on any of the last
official Red Hat releases)
4. Select ext3 for / (the two partitions are shown correct without a reboot)
5. On the screen which shows the actual packet installation I get a dialog box:
The kernel was unable to re-read partition table on /dev/hda.
This message appears twice and after that I get another windows telling me that
I have to reboot.
6. After the reboot I checked the partitions using fdisk --> the two partitions
are correctly setup so I did not change them again
7. Repeat all the steps in anaconda until package installation starts
8. Like during the first installation attempt I get these two dialog boxes:
The kernel was unable to re-read partition table on /dev/hda
9. After clicking Ok on both dialogs boxes the installation starts.

Right now the installation is still going on. I will enter additional
information when the install is finished.
Comment 7 Bernd Bartmann 2002-08-16 06:33:07 EDT
Same crash happened again after the installation has fineshed. Here is the
output of /tmp/lvmout that you requested:
vgchange --  no volume groups found

 "/etc/lvmtab.d"
vgscan -- creating empty "/etc/lvmtab" and "/etc/lvmtab.d"
vgscan -- reading all physical volumes (this may take a while...)
vgscan -- "/etc/lvmtab" and "/etc/lvmtab.d" successfully created
vgscan -- WARNING: This program does not do a VGDA backup of your volume group

Anaconda crash dump will be attached.
Comment 8 Bernd Bartmann 2002-08-16 06:33:53 EDT
Created attachment 71044 [details]
Anaconda crash dump after fresh limbo2 installation
Comment 9 Jeremy Katz 2002-08-19 14:54:45 EDT
Should be fixed in our current codebases
Comment 10 Bernd Bartmann 2002-08-20 08:35:08 EDT
The same thing happens with the (Null) Beta.
Comment 11 Bill Nottingham 2002-08-20 22:41:52 EDT
*** Bug 71939 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2002-08-20 22:43:00 EDT
Jeremy, was this fixed after Null was cut?
Comment 13 Jeremy Katz 2002-09-20 16:36:58 EDT
Yes
Comment 14 Bernd Bartmann 2002-10-07 06:40:20 EDT
Under Red Hat 8.0 I still get errors that anaconda can't re-read the partition
tables of my hard drives, but the install works without a problem. Should I
report this as a new bug against Red Hat 8.0?

Note You need to log in before you can comment on or make changes to this bug.