Bug 70160 - various problems with UTF-8
various problems with UTF-8
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: jed (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 70124 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 16:30 EDT by Michael Schwendt
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 15:36:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-07-30 16:30:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Probably related to bug #70124 or slang.

Open a new file and type a text which contains several German umlaut characters.
With each umlaut the cursor advances a second column.

Upper-case umlaut characters yield an even more weird behaviour and cause lines
to disappear or the cursor to be moved to line 1 column 1.

Whether in virtual console or in an xterm, doesn't make a difference. Different
language setting didn't change a thing either.

$ cat /etc/sysconfig/i18n 
LANG="de_DE.UTF-8@euro"
SUPPORTED="en_GB.UTF-8:en_GB:en:en_US.UTF-8:en_US:en:de_DE.UTF-8:de_DE:de"
SYSFONT="LatArCyrHeb-16"


Version-Release number of selected component (if applicable):
0.99.15-3

How reproducible:
Always

Steps to Reproduce:
Since bugzilla is plain ASCII, it wouldn't accept 8-bit ISO Latin-1 (or ISO
Latin-0) characters. Proceed as described above.
Comment 1 Michael Schwendt 2002-08-20 05:42:30 EDT
Reproducible with (null).
Comment 2 Michael Schwendt 2004-07-28 08:34:42 EDT
No progress in Fedora Core.

$ rpm -q jed slang
jed-0.99.16-5
slang-1.4.9-4

Does Jed still have followers at Red Hat? If not, why not drop it from
Core?
Comment 3 Michael Schwendt 2004-07-28 08:35:06 EDT
*** Bug 70124 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2005-01-21 15:36:24 EST
jed doesn't really support UTF-8 cleanly, and won't until slang-2.0.

Note You need to log in before you can comment on or make changes to this bug.