Bug 701780 - Fedora 15 release notes - minimum memory requires need to be updated
Summary: Fedora 15 release notes - minimum memory requires need to be updated
Keywords:
Status: CLOSED DUPLICATE of bug 699770
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes
Version: devel
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Release Notes Tracker
QA Contact: Karsten Wade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-03 20:16 UTC by James Laska
Modified: 2013-09-02 06:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-04 00:43:52 UTC


Attachments (Terms of Use)

Description James Laska 2011-05-03 20:16:05 UTC
Description of problem:

The minimum system memory requirements listed in the Fedora 15 release notes are far too low.  After some testing, Dave Lehman (of the anaconda-devel@ fame), discovered that the limits need to be adjusted according to his patch against Fedora 15 anaconda (see https://www.redhat.com/archives/anaconda-devel-list/2011-May/msg00012.html).

http://docs.fedoraproject.org/en-US/Fedora/15/html/Release_Notes/sect-Release_Notes-Welcome_to_Fedora_15.html#sect-Release_Notes-Hardware_Overview

To summarize ...
 * the absolute minimum amount of memory needed for an installation on i386 or x86_64 is 640 MiB.
 * 1152 MiB is the minimum required to install *without* a swap partition

Version-Release number of selected component (if applicable):
 * Revision 14.98	Fri Apr 15 2011
  
Actual results:

   1.3.1. Processor and memory requirements for x86 Architectures
       <snip>
       Recommended for text-mode: 200 MHz Pentium Pro or better
       Recommended for graphical: 400 MHz Pentium Pro or better
       Minimum RAM for text-mode: 256 MiB
       Minimum RAM for graphical: 384 MiB
       Recommended RAM for graphical: 512 MiB 

   1.3.2. Processor and memory requirements for x86_64 architectures 
       Minimum RAM for text-mode: 256 MiB
       Minimum RAM for graphical: 384 MiB
       Recommended RAM for graphical: 512 MiB 

Expected results:

   1.3.1. Processor and memory requirements for x86 Architectures
       <snip>
       Recommended for text-mode: 200 MHz Pentium Pro or better
       Recommended for graphical: 400 MHz Pentium Pro or better
       Minimum RAM for graphical: 640 MiB
       Recommended RAM for graphical: 1152 MiB 

   1.3.2. Processor and memory requirements for x86_64 architectures 
       Minimum RAM for graphical: 640 MiB
       Recommended RAM for graphical: 1152 MiB 

Additional info:

 * cmdline installations may be able to proceed with less than 640Mib, but that isn't exhaustively tested and cmdline mode in not an interactive installation method.
 * 1152 MiB is the new recommended size since that is the minimum memory size where you are able to install *without* requiring a swap partition.

Comment 1 Zach Oglesby 2011-05-04 00:21:50 UTC
I have changed the requirements in the git repo (under the f15 branch) and pushed the changes to transifex as well. 

Please let me know if anything else is needed.

Comment 2 Zach Oglesby 2011-05-04 00:43:52 UTC

*** This bug has been marked as a duplicate of bug 699770 ***

Comment 3 Steve Tyler 2011-05-04 01:10:43 UTC
(In reply to comment #0)
> Description of problem:

To put it bluntly
Anaconda is a very fat snake

Comment 4 James Laska 2011-05-04 12:13:50 UTC
(In reply to comment #1)
> I have changed the requirements in the git repo (under the f15 branch) and
> pushed the changes to transifex as well. 
> 
> Please let me know if anything else is needed.

Excellent, thanks Zach

(In reply to comment #3)
> (In reply to comment #0)
> > Description of problem:
> 
> To put it bluntly
> Anaconda is a very fat snake

Heh, if only it was the sole component involved.  I think the trouble is there are so many components, and different combinations of how/when they are used together.  Such as X, lvm, gtk, device-mapper etc...

Comment 5 Steve Tyler 2011-05-04 13:12:16 UTC
(In reply to comment #4)
...
> > To put it bluntly
> > Anaconda is a very fat snake
> 
> Heh, if only it was the sole component involved.  I think the trouble is there
> are so many components, and different combinations of how/when they are used
> together.  Such as X, lvm, gtk, device-mapper etc...

You are right. I was using "anaconda" generically. If you run "top" from the installer shell console during package installation, you will see that "anaconda", the process, swaps itself out very nicely. Then along comes selinux-policy-targeted:

Bug 633807 - semodule memory usage causes install failures on minimally configured VMs

time series plot of memory and swap usage during minimal install
https://bugzilla.redhat.com/attachment.cgi?id=448057


Note You need to log in before you can comment on or make changes to this bug.