Bug 701827 - [abrt] xchm-1.17-3.fc14: length: Process /usr/bin/xchm was killed by signal 11 (SIGSEGV)
[abrt] xchm-1.17-3.fc14: length: Process /usr/bin/xchm was killed by signal 1...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xchm (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: manuel wolfshant
Fedora Extras Quality Assurance
abrt_hash:ffc1d30be6ba75ba621b2a561f8...
:
Depends On: 702583
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-03 21:06 EDT by igor.redhat@gmail.com
Modified: 2011-05-25 12:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: xchm-1.20-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 00:50:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (58.04 KB, text/plain)
2011-05-03 21:06 EDT, igor.redhat@gmail.com
no flags Details

  None (edit)
Description igor.redhat@gmail.com 2011-05-03 21:06:30 EDT
abrt version: 1.1.18
architecture: x86_64
Attached file: backtrace, 59437 bytes
cmdline: xchm spring-net-reference.chm
component: xchm
Attached file: coredump, 47030272 bytes
crash_function: length
executable: /usr/bin/xchm
kernel: 2.6.35.11-83.fc14.x86_64
package: xchm-1.17-3.fc14
rating: 4
reason: Process /usr/bin/xchm was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
How to reproduce: This happens every time I try to open the following doc: http://www.springframework.net/doc-latest/reference/htmlhelp/spring-net-reference.chm
time: 1304461195
uid: 500
Comment 1 igor.redhat@gmail.com 2011-05-03 21:06:37 EDT
Created attachment 496675 [details]
File: backtrace
Comment 2 manuel wolfshant 2011-05-03 23:23:29 EDT
I did reproduce the bug, even with the latest (1.19.1) release. However I think that the problem lies in the chmlib helper libs, because kchmviewer which uses the same lib as xchm also dies with a Segmentation fault while opening the same file supplied as reproducer

Test buils of xchm-1.19.1 are available at http://koji.fedoraproject.org/koji/taskinfo?taskID=3048897 ( RHEL6 ) and http://koji.fedoraproject.org/koji/taskinfo?taskID=3048888 ( F14 ).

I've filed a bug against xchm: https://sourceforge.net/tracker/?func=detail&aid=3297271&group_id=87007&atid=581688
Comment 3 Fedora Update System 2011-05-06 09:34:41 EDT
xchm-1.20-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/xchm-1.20-1.el6
Comment 4 Fedora Update System 2011-05-06 09:34:49 EDT
xchm-1.20-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/xchm-1.20-1.el5
Comment 5 Fedora Update System 2011-05-06 09:34:57 EDT
xchm-1.20-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xchm-1.20-1.fc15
Comment 6 Fedora Update System 2011-05-06 09:35:04 EDT
xchm-1.20-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/xchm-1.20-1.fc13
Comment 7 Fedora Update System 2011-05-06 09:35:11 EDT
xchm-1.20-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xchm-1.20-1.fc14
Comment 8 Fedora Update System 2011-05-06 21:32:37 EDT
Package xchm-1.20-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing xchm-1.20-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xchm-1.20-1.el5
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-05-19 00:50:11 EDT
xchm-1.20-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-05-19 17:57:40 EDT
xchm-1.20-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-05-19 18:03:42 EDT
xchm-1.20-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2011-05-25 12:06:05 EDT
xchm-1.20-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2011-05-25 12:08:19 EDT
xchm-1.20-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.