Bug 70240 - Gnome 2.0 menues seems messy
Gnome 2.0 menues seems messy
Status: CLOSED DUPLICATE of bug 68843
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-desktop (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 05:27 EDT by Andy
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 05:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy 2002-07-31 05:27:05 EDT
Don't know if this is a Gnome problem originally, or if it's RedHat's
customization, but the menues in Gnome 2.0 appears very messy.

(1) First of all, many items for already installed apps are missing, such as:
-- GIMP
-- GnomeMeeting
-- Nautilus

(2) There are some duplicate entries, which seems unnecessary.
 a) Most of the items in "All Applications" already exist in the root menu.
Why not just move the remainder from "All Applications" and give them their own
menu entry in the root menu? 
 b) "Control Center" should move to be at the top of the "Preferences" sub-menu,
with a <HR> beenath.

(3) And couldn't "All Apps -> Other -> Eye of Gnome" go to "Graphics"?
And "All Apps -> Other -> Audio Player" go to "Sound & Video"?

(4) Further on, I can't find the capplet for editing the Gnome menu, but maybe
that's not available any more.
Comment 1 Havoc Pennington 2002-07-31 09:19:17 EDT
It's best to file specific bugs against specific apps in the wrong place, e.g. 
if GIMP is in the wrong place, file a bug against GIMP. There are already 100+
bugs like that in here, but maybe not the exact ones you are interested in.

It's useful to add Cc: hp@redhat.com to any such bugs.

GIMP should be in Graphics, GnomeMeeting should be in Internet, 
Nautilus is represented as simply "Home directory" in the toplevel.

"all applications" is quite full if you do an everything install, it's just sort
of the same as the main menus if you only install defaults. May be renaming this
item "Extras" and perhaps stripping dups out of it.

Eye of GNOME isn't really useful enough to go in toplevel IMO. gqview, kuickshow
are better options. There should be one app of each type in the toplevel.

Audio Player - I think there's already a bug on this.

Menu editing - there is none at the moment, other than editing 
/etc/X11/desktop-menus/applications.menu with a text editor.

*** This bug has been marked as a duplicate of 68843 ***

Note You need to log in before you can comment on or make changes to this bug.