Bug 70255 - rhn_register does not work.
Summary: rhn_register does not work.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: limbo
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-31 11:02 UTC by Ivo Sarak
Modified: 2015-01-07 23:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-04 06:34:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivo Sarak 2002-07-31 11:02:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
rhn_register will terminate on error "ImportError: No module named cgiwrap".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
run rhn_register

Actual Results:  
[root@machine root]# rhn_register
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 14, in ?
    import rhnreg
  File "/usr/share/rhn/register/rhnreg.py", line 8, in ?
    import xmlrpclib, cgiwrap
ImportError: No module named cgiwrap
[root@machine root]#

Expected Results:  Registration form and all the rest.

Additional info:

Comment 1 Jeremy Katz 2002-08-02 05:27:22 UTC
Which limbo is this with?  I thought rhn_register was sucked into up2date now

Comment 2 Ivo Sarak 2002-08-02 07:21:14 UTC
Limbo I: (Red Hat Linux release 7.3.92 (Limbo) Kernel 2.4.18-5.58 on an i686).

up2date will give the same error:

[root@machine root]# up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 15, in ?
    from up2date_client import up2date
  File "/usr/share/rhn/up2date_client/up2date.py", line 20, in ?
    import cgiwrap
ImportError: No module named cgiwrap
[root@machine root]#

Comment 3 Michael Young 2002-08-02 08:51:51 UTC
The up2date etc. packages could still be from 7.3 due to limbo1 failing to
upgrade many packages (bug 68255). My suggestion would be to upgrade to limbo2,
or install more recent up2date packages, eg. from
ftp://people.redhat.com/misa/fixes/
though the latter may not work if other key packages haven't been upgraded. Note
the later versions of up2date incorporate the functionality of rhn_register.

Comment 4 Ivo Sarak 2002-08-02 09:31:33 UTC
Unfortunately these files do not resolve the issue as package
pyOpenSSL-0.5pre-1.i386.rpm is still needed and it will require
libstdc++-3.2-0.1.i386.rpm which will break dependency for libstdc++.so.4 and so on.

Is it possible to make update with rpm over ftp not locally as usual?


Comment 5 Ivo Sarak 2002-08-02 09:38:17 UTC
I managed to update these files by 'rpm -e rhn-applet-1.0.6-11' but now I get:
[root@machine root]# up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 45, in ?
    from up2date_client import clap
ImportError: cannot import name clap
[root@machine root]#

Comment 6 Michael Young 2002-08-02 10:22:58 UTC
My guess is python-clap didn't get updated. I think you are going to find it
easier to upgrade to limbo2 from the isos.

Comment 7 Ivo Sarak 2002-08-04 06:34:50 UTC
Yes, update of python-clap fixed the issue.

Comment 8 Adrian Likins 2002-08-08 20:52:44 UTC
looks to be closed


Note You need to log in before you can comment on or make changes to this bug.