Bug 702654 - [abrt] parted-2.3-4.fc14: ped_assert: Process /sbin/parted was killed by signal 6 (SIGABRT)
[abrt] parted-2.3-4.fc14: ped_assert: Process /sbin/parted was killed by sign...
Status: CLOSED DUPLICATE of bug 585468
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
14
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:6b30ee868ede806c6713a4c2e39...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-06 09:46 EDT by Mads Kiilerich
Modified: 2011-07-11 10:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-14 19:25:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (5.89 KB, text/plain)
2011-05-06 09:46 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2011-05-06 09:46:52 EDT
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 6036 bytes
cmdline: /sbin/parted --script /dev/sdb mklabel gpt
component: parted
Attached file: coredump, 528384 bytes
crash_function: ped_assert
executable: /sbin/parted
kernel: 2.6.35.12-90.fc14.i686.PAE
package: parted-2.3-4.fc14
rating: 4
reason: Process /sbin/parted was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1304689253
uid: 0

How to reproduce
-----
I ran 
  livecd-iso-to-disk --format --efi my.iso /dev/sdb1
and it called
  /sbin/parted --script /dev/sdb mklabel gpt
Comment 1 Mads Kiilerich 2011-05-06 09:46:54 EDT
Created attachment 497360 [details]
File: backtrace
Comment 2 Mads Kiilerich 2011-05-06 09:59:54 EDT
# fdisk -l /dev/sdb

Disk /dev/sdb: 4003 MB, 4003463168 bytes
84 heads, 20 sectors/track, 4654 cylinders, total 7819264 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        8064     7819263     3905600    c  W95 FAT32 (LBA)


It could perhaps be caused by incorrect old partitioning, but I would expect livecd-iso-to-disk to do what was needed to make it work - and parted shouldn't coredump no matter what.


Can also be reproduced with just
 
# /sbin/parted /dev/sdb
GNU Parted 2.3
Using /dev/sdb
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) mklabel gpt                                                      
Backtrace has 14 calls on stack:
  14: /lib/libparted.so.0(ped_assert+0x2b) [0x4adbbb]
  13: /lib/libparted.so.0() [0x4e491f]
  12: /lib/libparted.so.0() [0x4e5607]
  11: /lib/libparted.so.0() [0x4e7fe7]
  10: /lib/libparted.so.0() [0x4b22f2]
  9: /lib/libparted.so.0(ped_disk_add_partition+0x25b) [0x4b57cb]
  8: /lib/libparted.so.0() [0x4e6f31]
  7: /lib/libparted.so.0() [0x4e7540]
  6: /lib/libparted.so.0(ped_disk_new+0x75) [0x4b5c95]
  5: /sbin/parted() [0x804dae3]
  4: /sbin/parted(interactive_mode+0x11a) [0x805599a]
  3: /sbin/parted(main+0x190c) [0x805280c]
  2: /lib/libc.so.6(__libc_start_main+0xe6) [0x5a0e36]
  1: /sbin/parted() [0x804bb91]
Aborted (core dumped)
Comment 3 Brian Lane 2011-05-06 11:42:23 EDT
This happened because parted was trying to guess the CHS values for the USB stick. You can fix this by using dd to wipe out the existing parition table and re-partitioning it. I have a patch for this that I need to back-port to F14 soon.

The key is this line from the abrt report:

ped_assert (cond_text=0x504986 "head_size <= 63", file=0x50493e "dos.c", line=661, function=0x504cc9 "probe_partition_for_geom") at debug.c:112
Comment 4 Mads Kiilerich 2011-05-06 12:08:23 EDT
Package: parted-2.3-7.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)


Comment
-----
f15 duplicate of 702654
Comment 5 Mads Kiilerich 2011-05-06 12:11:27 EDT
I see the same crash on f15, so I guess the fix will be backported from somewhere else - and hopefully also to f15 ;-)
Comment 6 Brian Lane 2011-05-06 13:46:19 EDT
Yes, it is in rawhide right now. After F15 release I'll back-port it.
Comment 7 Brian Lane 2011-06-14 19:25:10 EDT

*** This bug has been marked as a duplicate of bug 585468 ***
Comment 8 Mads Kiilerich 2011-07-11 10:11:27 EDT
Just stumbled upon this one again. A back-port to F14 would be nice ;-)

Note You need to log in before you can comment on or make changes to this bug.