Bug 702671 - ntfs-3g fails to update in EL-5 when libguestfs is present
ntfs-3g fails to update in EL-5 when libguestfs is present
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ntfs-3g (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-06 10:35 EDT by Todd Zullinger
Modified: 2011-05-28 17:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: ntfs-3g-2011.4.12-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 703290 (view as bug list)
Environment:
Last Closed: 2011-05-14 00:06:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Todd Zullinger 2011-05-06 10:35:08 EDT
Attempting to update an EL-5 system using epel-testing fails:

# yum -d5 update 
Loaded plugins: downloadonly, fastestmirror, kmdl, kmod, priorities
Config time: 0.167
Loading Fedora Extras kernel module support.
Loading mirror speeds from cached hostfile
 * addons: centos.mirror.nac.net
 * base: centos.mirror.nac.net
 * epel: mirror.cogentco.com
 * epel-testing: mirror.cogentco.com
 * extras: updates.interworx.info
 * updates: mirror.ash.fastserv.com
repo time: 0.213
Yum Version: 3.2.22
Setting up Package Sacks
pkgsack time: 0.099
rpmdb time: 0.000
Setting up Update Process
Updating Everything
Building updates object
up:Obs Init time: 0.689
up:simple updates time: 0.149
up:obs time: 0.007
up:condense time: 0.000
updates time: 2.600
Resolving Dependencies
--> Running transaction check
Checking deps for ntfs-3g.x86_64 2-2011.1.15-1.el5 - None
---> Package ntfs-3g.x86_64 2:2011.4.12-2.el5 set to be updated
Checking deps for ntfs-3g.x86_64 2-2011.4.12-2.el5 - u
Checking deps for ntfsprogs.x86_64 0-1.13.1-6.el5 - None
---> Package ntfsprogs.x86_64 2:2011.4.12-2.el5 set to be updated
Checking deps for ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
looking for ('libpthread.so.0(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
looking for ('libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
looking for ('libntfs-3g.so.81()(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
Checking deps for tzdata.x86_64 0-2011d-3.el5 - None
---> Package tzdata.x86_64 0:2011g-1.el5 set to be updated
Checking deps for tzdata.x86_64 0-2011g-1.el5 - u
1:libguestfs-1.2.14-1.el5.x86_64 requires: /usr/lib64/libntfs.so.9
--> Processing Dependency: /usr/lib64/libntfs.so.9 for package: libguestfs
Needed Require is not a package name. Looking up: /usr/lib64/libntfs.so.9
Potential Provider: ntfsprogs.x86_64 0:1.13.1-6.el5
Mode is u for provider of /usr/lib64/libntfs.so.9: ntfsprogs.x86_64 0:1.13.1-6.el5
Mode for pkg providing /usr/lib64/libntfs.so.9: u
Cannot find an update path for dep for: /usr/lib64/libntfs.so.9
Searching pkgSack for dep: /usr/lib64/libntfs.so.9
Potential match for /usr/lib64/libntfs.so.9 from ntfsprogs-1.13.1-6.el5.x86_64
ntfsprogs-1.13.1-6.el5.x86_64 is in providing packages but it is already installed, removing.
--> Finished Dependency Resolution
Dependency Process ending
1:libguestfs-1.2.14-1.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: /usr/lib64/libntfs.so.9 is needed by package 1:libguestfs-1.2.14-1.el5.x86_64 (installed)
Depsolve time: 5.230
Error: Missing Dependency: /usr/lib64/libntfs.so.9 is needed by package 1:libguestfs-1.2.14-1.el5.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

It looks like ntfsprogs-1.13.1-6.el5.i386 is still in epel, with no  ntfsprogs-2011.4.12-2.el5.i386.rpm update in epel-testing.  Does the old package need to be handled specially by rel-eng for multilib or something?

# yum list ntfsprogs
Loaded plugins: downloadonly, fastestmirror, kmdl, kmod, priorities
Loading mirror speeds from cached hostfile
 * addons: mirror.rackspace.com
 * base: centos.mirror.nac.net
 * epel: mirror.cogentco.com
 * epel-testing: mirror.cogentco.com
 * extras: updates.interworx.info
 * updates: mirror.ash.fastserv.com
epel                                                     | 3.7 kB     00:00     
epel-testing                                             | 3.7 kB     00:00     
Finished
Installed Packages
ntfsprogs.x86_64                 1.13.1-6.el5                       installed   
Available Packages
ntfsprogs.i386                   1.13.1-6.el5                       epel        
ntfsprogs.x86_64                 2:2011.4.12-2.el5                  epel-testing
Comment 1 Richard W.M. Jones 2011-05-06 10:45:24 EDT
I'm guessing this is more likely to be a libguestfs thing
(ie. needs a rebuild), so changing the component accordingly.
Comment 2 Todd Zullinger 2011-05-06 10:50:58 EDT
I'm not sure that it is a libguestfs issue.  I was going to assign it to libguestfs originally, but then I looked closer at the yum output.  Notice that there is no ntfsprogs-2011.4.12-2.el5.i386 in the x86_64 repos.  I believe there should be.
Comment 3 Rex Dieter 2011-05-09 14:36:01 EDT
re-assigning to ntfs-3g as an multilib upgrade path issue.  See also,
https://fedorahosted.org/rel-eng/ticket/4728
Comment 4 Richard W.M. Jones 2011-05-09 15:10:40 EDT
I don't think I understand that ... does libguestfs need
a rebuild or not?
Comment 5 Fedora Update System 2011-05-09 16:01:50 EDT
ntfs-3g-2011.4.12-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc14
Comment 6 Fedora Update System 2011-05-09 16:02:13 EDT
ntfs-3g-2011.4.12-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.el5
Comment 7 Fedora Update System 2011-05-09 16:02:38 EDT
ntfs-3g-2011.4.12-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc15
Comment 8 Fedora Update System 2011-05-09 16:03:00 EDT
ntfs-3g-2011.4.12-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.el6
Comment 9 Fedora Update System 2011-05-09 16:03:22 EDT
ntfs-3g-2011.4.12-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc13
Comment 10 Fedora Update System 2011-05-09 18:38:45 EDT
Package ntfs-3g-2011.4.12-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ntfs-3g-2011.4.12-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc15
then log in and leave karma (feedback).
Comment 11 Todd Zullinger 2011-05-11 11:19:49 EDT
Trying to update to ntfs-3g-2011.4.12-3.el5 it still fails because nothing seems to provide /usr/lib64/libntfs.so.9 anymore.  Is that intended?  (If so, then libguestfs may need a rebuild?)

# yum -d5 update
Loaded plugins: downloadonly, fastestmirror
Config time: 0.169
Loading Fedora Extras kernel module support.
Loading mirror speeds from cached hostfile
 * addons: mirror.rackspace.com
 * base: mirror.trouble-free.net
 * epel: mirror.cogentco.com
 * epel-testing: mirror.cogentco.com
 * extras: centos.mirror.nac.net
 * updates: updates.interworx.info
repo time: 0.379
Yum Version: 3.2.22
Setting up Package Sacks
pkgsack time: 0.091
rpmdb time: 0.000
Setting up Update Process
Updating Everything
Building updates object
up:Obs Init time: 0.516
up:simple updates time: 0.116
up:obs time: 0.004
up:condense time: 0.000
updates time: 2.806
Resolving Dependencies
--> Running transaction check
Checking deps for ntfs-3g.x86_64 2-2011.1.15-1.el5 - None
---> Package ntfs-3g.x86_64 2:2011.4.12-3.el5 set to be updated
Checking deps for ntfs-3g.x86_64 2-2011.4.12-3.el5 - u
Checking deps for ntfsprogs.x86_64 0-1.13.1-6.el5 - None
---> Package ntfsprogs.x86_64 2:2011.4.12-3.el5 set to be updated
Checking deps for ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('libc.so.6(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('libpthread.so.0(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('rtld(GNU_HASH)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('libc.so.6(GLIBC_2.3.4)(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('libc.so.6(GLIBC_2.4)(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('libc.so.6()(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
looking for ('libntfs-3g.so.81()(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-3.el5 - u
1:libguestfs-1.2.14-1.el5.x86_64 requires: /usr/lib64/libntfs.so.9
--> Processing Dependency: /usr/lib64/libntfs.so.9 for package: libguestfs
Needed Require is not a package name. Looking up: /usr/lib64/libntfs.so.9
Potential Provider: ntfsprogs.x86_64 0:1.13.1-6.el5
Mode is u for provider of /usr/lib64/libntfs.so.9: ntfsprogs.x86_64 0:1.13.1-6.el5
Mode for pkg providing /usr/lib64/libntfs.so.9: u
Cannot find an update path for dep for: /usr/lib64/libntfs.so.9
Searching pkgSack for dep: /usr/lib64/libntfs.so.9
Potential match for /usr/lib64/libntfs.so.9 from ntfsprogs-1.13.1-6.el5.x86_64
ntfsprogs-1.13.1-6.el5.x86_64 is in providing packages but it is already installed, removing.
--> Finished Dependency Resolution
Dependency Process ending
1:libguestfs-1.2.14-1.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: /usr/lib64/libntfs.so.9 is needed by package 1:libguestfs-1.2.14-1.el5.x86_64 (installed)
Depsolve time: 6.753
Error: Missing Dependency: /usr/lib64/libntfs.so.9 is needed by package 1:libguestfs-1.2.14-1.el5.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 12 Tom "spot" Callaway 2011-05-11 12:42:17 EDT
Yes, libguestfs needs a rebuild in EPEL too.
Comment 13 Todd Zullinger 2011-05-12 11:36:57 EDT
Should the libguestfs update¹ be included in the same update as ntfs-3g, to
ensure that they both go to stable at the same time?  If not, some care will be
needed to prevent breakage if one goes stable before the other, no?

¹ https://admin.fedoraproject.org/updates/libguestfs-1.2.14-3.el5
Comment 14 Richard W.M. Jones 2011-05-12 12:14:18 EDT
I gathered from comment 6 that ntfs-3g is already in EPEL 5.

If not, then I probably built libguestfs against the wrong
version of ntfs-3g (ie. it would have the old deps):

http://koji.fedoraproject.org/koji/rpminfo?rpmID=2544868
Comment 15 Todd Zullinger 2011-05-12 12:44:50 EDT
It's only in epel-testing.  I don't believe that updates from epel-testing are present in the buildroot, so this libguestfs build was using the older packages.  It still has the now-bogus /usr/lib/libntfs.so.9 dep.
Comment 16 Richard W.M. Jones 2011-05-12 12:53:44 EDT
It's so stupid we still don't have a way to build against
packages without having to ask someone to do it and affecting
all other builds at the same time.

https://fedorahosted.org/rel-eng/ticket/4738
Comment 17 Richard W.M. Jones 2011-05-12 15:18:40 EDT
Apparently I cannot edit the update.  But someone
who is able to could try adding this

http://koji.fedoraproject.org/koji/taskinfo?taskID=3068421

to

https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.el5
Comment 18 Fedora Update System 2011-05-14 00:05:35 EDT
ntfs-3g-2011.4.12-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2011-05-19 00:46:12 EDT
ntfs-3g-2011.4.12-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2011-05-19 00:49:10 EDT
ntfs-3g-2011.4.12-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2011-05-25 12:06:58 EDT
ntfs-3g-2011.4.12-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2011-05-28 17:34:17 EDT
ntfs-3g-2011.4.12-3.el5, libguestfs-1.2.14-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.