Bug 703290 - ntfs-3g causes upgrades to fail due to file-conflicts
ntfs-3g causes upgrades to fail due to file-conflicts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
AcceptedNTH
:
: 704435 (view as bug list)
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-05-09 16:45 EDT by James Laska
Modified: 2013-09-02 02:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: ntfs-3g-2011.4.12-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 702671
Environment:
Last Closed: 2011-05-14 00:06:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2011-05-09 16:45:11 EDT
Already filed against EPEL-5 ... I'm cloning this issue as it also impacts Fedora 15 release.

+++ This bug was initially created as a clone of Bug #702671 +++

Attempting to update an EL-5 system using epel-testing fails:

# yum -d5 update 
Loaded plugins: downloadonly, fastestmirror, kmdl, kmod, priorities
Config time: 0.167
Loading Fedora Extras kernel module support.
Loading mirror speeds from cached hostfile
 * addons: centos.mirror.nac.net
 * base: centos.mirror.nac.net
 * epel: mirror.cogentco.com
 * epel-testing: mirror.cogentco.com
 * extras: updates.interworx.info
 * updates: mirror.ash.fastserv.com
repo time: 0.213
Yum Version: 3.2.22
Setting up Package Sacks
pkgsack time: 0.099
rpmdb time: 0.000
Setting up Update Process
Updating Everything
Building updates object
up:Obs Init time: 0.689
up:simple updates time: 0.149
up:obs time: 0.007
up:condense time: 0.000
updates time: 2.600
Resolving Dependencies
--> Running transaction check
Checking deps for ntfs-3g.x86_64 2-2011.1.15-1.el5 - None
---> Package ntfs-3g.x86_64 2:2011.4.12-2.el5 set to be updated
Checking deps for ntfs-3g.x86_64 2-2011.4.12-2.el5 - u
Checking deps for ntfsprogs.x86_64 0-1.13.1-6.el5 - None
---> Package ntfsprogs.x86_64 2:2011.4.12-2.el5 set to be updated
Checking deps for ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
looking for ('libpthread.so.0(GLIBC_2.2.5)(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
looking for ('libpthread.so.0()(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
looking for ('libntfs-3g.so.81()(64bit)', None, (None, None, None)) as a requirement of ntfsprogs.x86_64 2-2011.4.12-2.el5 - u
Checking deps for tzdata.x86_64 0-2011d-3.el5 - None
---> Package tzdata.x86_64 0:2011g-1.el5 set to be updated
Checking deps for tzdata.x86_64 0-2011g-1.el5 - u
1:libguestfs-1.2.14-1.el5.x86_64 requires: /usr/lib64/libntfs.so.9
--> Processing Dependency: /usr/lib64/libntfs.so.9 for package: libguestfs
Needed Require is not a package name. Looking up: /usr/lib64/libntfs.so.9
Potential Provider: ntfsprogs.x86_64 0:1.13.1-6.el5
Mode is u for provider of /usr/lib64/libntfs.so.9: ntfsprogs.x86_64 0:1.13.1-6.el5
Mode for pkg providing /usr/lib64/libntfs.so.9: u
Cannot find an update path for dep for: /usr/lib64/libntfs.so.9
Searching pkgSack for dep: /usr/lib64/libntfs.so.9
Potential match for /usr/lib64/libntfs.so.9 from ntfsprogs-1.13.1-6.el5.x86_64
ntfsprogs-1.13.1-6.el5.x86_64 is in providing packages but it is already installed, removing.
--> Finished Dependency Resolution
Dependency Process ending
1:libguestfs-1.2.14-1.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: /usr/lib64/libntfs.so.9 is needed by package 1:libguestfs-1.2.14-1.el5.x86_64 (installed)
Depsolve time: 5.230
Error: Missing Dependency: /usr/lib64/libntfs.so.9 is needed by package 1:libguestfs-1.2.14-1.el5.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

It looks like ntfsprogs-1.13.1-6.el5.i386 is still in epel, with no  ntfsprogs-2011.4.12-2.el5.i386.rpm update in epel-testing.  Does the old package need to be handled specially by rel-eng for multilib or something?

# yum list ntfsprogs
Loaded plugins: downloadonly, fastestmirror, kmdl, kmod, priorities
Loading mirror speeds from cached hostfile
 * addons: mirror.rackspace.com
 * base: centos.mirror.nac.net
 * epel: mirror.cogentco.com
 * epel-testing: mirror.cogentco.com
 * extras: updates.interworx.info
 * updates: mirror.ash.fastserv.com
epel                                                     | 3.7 kB     00:00     
epel-testing                                             | 3.7 kB     00:00     
Finished
Installed Packages
ntfsprogs.x86_64                 1.13.1-6.el5                       installed   
Available Packages
ntfsprogs.i386                   1.13.1-6.el5                       epel        
ntfsprogs.x86_64                 2:2011.4.12-2.el5                  epel-testing

<snip>

--- Additional comment from updates@fedoraproject.org on 2011-05-09 16:02:38 EDT ---

ntfs-3g-2011.4.12-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc15


This impacts Alpha release criteria [1] ...

  "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (CD/DVD) install"

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 1 James Laska 2011-05-09 16:45:43 EDT
An update is available that resolves this issue, see https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc15
Comment 2 Fedora Update System 2011-05-09 16:47:37 EDT
ntfs-3g-2011.4.12-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc15
Comment 3 Fedora Update System 2011-05-09 18:39:02 EDT
Package ntfs-3g-2011.4.12-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ntfs-3g-2011.4.12-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ntfs-3g-2011.4.12-3.fc15
then log in and leave karma (feedback).
Comment 4 James Laska 2011-05-10 19:06:44 EDT
I wasn't able to reproduce this failure by doing a F14->F15 upgrade (minus the 'updates-testing' repo).  Prior to upgrade, I had the following packages installed ...

 2:ntfs-3g-2011.4.12-2.fc14.i686 (from /var/log/yum.log)
 ntfs-3g-2011.4.12-2.fc14.x86_64 (from install.log)
 1:libguestfs-1.8.6-1.fc14.x86_64 (from /var/log/yum.log)
 ntfsprogs-2011.4.12-2.fc14.x86_64 (from install.log)

After upgrade, I had ...

 Upgrading ntfs-3g-2011.4.12-2.fc15.x86_64
 Upgrading ntfsprogs-2011.4.12-2.fc15.x86_64
 Upgrading libguestfs-1.10.2-1.fc15.x86_64
 Upgrading ntfs-3g-2011.4.12-2.fc15.i686

I'll retest tomorrow with updates-testing enabled (not that I'd expect that to change the outcome).  Am I attempting to reproduce this issue improperly?
Comment 5 James Laska 2011-05-11 14:31:44 EDT
(In reply to comment #4)
> I'll retest tomorrow with updates-testing enabled (not that I'd expect that to
> change the outcome).  Am I attempting to reproduce this issue improperly?

I've attempted to reproduce the failure again using the following packages prior to upgrade:

 * ntfsprogs-2011.4.12-2.fc14.x86_64
 * ntfsprogs-2011.4.12-2.fc14.i686
 * ntfs-3g-2011.4.12-2.fc14.x86_64
 * ntfs-3g-2011.4.12-2.fc14.i686
 * libguestfs-1.8.6-1.fc14.x86_64

After upgrade, the following packages were installed (note ntfsprogs.i686 was not updated):

                         vvvvvvvvv
 * ntfsprogs-2011.4.12-2.fc14.i686
 * ntfsprogs-2011.4.12-2.fc15.x86_64
 * ntfs-3g-2011.4.12-2.fc15.x86_64
 * ntfs-3g-2011.4.12-2.fc15.i686
 * libguestfs-1.10.2-1.fc15.x86_64

After enabling 'updates-testing', and pulling down the proposed update:

===========================================================================================
Installing:
 ntfsprogs         x86_64         2:2011.4.12-3.fc15         updates-testing         220 k
     replacing  ntfsprogs.i686 2:2011.4.12-2.fc14
     replacing  ntfsprogs.x86_64 2:2011.4.12-2.fc15
Updating:
 ntfs-3g         i686           2:2011.4.12-3.fc15           updates-testing         267 k
 ntfs-3g         x86_64         2:2011.4.12-3.fc15           updates-testing         245 k
===========================================================================================

                         vvvvvvvvv
 * ntfsprogs-2011.4.12-2.fc14.i686
 * ntfsprogs-2011.4.12-3.fc15.x86_64
 * ntfs-3g-2011.4.12-3.fc15.x86_64
 * ntfs-3g-2011.4.12-3.fc15.i686
 * libguestfs-1.10.2-1.fc15.x86_64

# yum list extras
Extra Packages
kernel.x86_64     2.6.35.13-91.fc14       @updates/14                         
ntfsprogs.i686    2:2011.4.12-2.fc14      @/ntfsprogs-2011.4.12-2.fc14.i686/14

So ntfsprogs.i686 is left orphaned on the system.  Perhaps this is a remnant of how I artificially attempted to replicate this failure.  Either way ... I'm no longer convinced this is a release blocker since anaconda clearly has no problems updating using the package sets noted above.  Either I'm still not instrumenting this test properly, or anaconda ignores deps on upgrade (which I believe is the case ... otherwise users would never be able to upgrade).

I propose we continue with this update as planned, but I will lower this to a nice-to-have (NTH), not a blocker, considering I'm unable to confirm that it prevents upgrades.  Either way, it will be in F15.
Comment 6 Richard W.M. Jones 2011-05-11 14:53:37 EDT
So ....... this should be reassigned to libguestfs?

I tried to kick off a build of libguestfs in EL5, but the
branch naming thing is broken and running fixbranches
says:

$ fedpkg-fixbranches.py 
Checking status of upstream branch conversion
Fedora repos have not yet been converted.

whatever that means.
Comment 7 Richard W.M. Jones 2011-05-11 14:55:35 EDT
rm -rf'ing the old repository and cloning it again
allowed me to start a build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3066677
Comment 8 Tom "spot" Callaway 2011-05-11 15:01:28 EDT
I think there is still some sort of upgrade issue here.(In reply to comment #5)
> (In reply to comment #4)
> > I'll retest tomorrow with updates-testing enabled (not that I'd expect that to
> > change the outcome).  Am I attempting to reproduce this issue improperly?
> 
> I've attempted to reproduce the failure again using the following packages
> prior to upgrade:
> 
>  * ntfsprogs-2011.4.12-2.fc14.x86_64
>  * ntfsprogs-2011.4.12-2.fc14.i686
>  * ntfs-3g-2011.4.12-2.fc14.x86_64
>  * ntfs-3g-2011.4.12-2.fc14.i686
>  * libguestfs-1.8.6-1.fc14.x86_64

James, the problem is not between ntfsprogs-2011.4.12-2 and ntfsprogs-2011.4.12-3, the problem is between ntfsprogs-2.0.0-15.fc14 and ntfsprogs-2011.4.12-2.

It is expected that if the following packages are installed...

ntfsprogs-2.0.0-15.fc14.i686
ntfsprogs-2.0.0-15.fc14.x86_64

... and you try to upgrade to ...

ntfsprogs-2011.4.12-2.fc15.x86_64
(Note that the .i686 revision should not be in the x86_64 repo)

... then you get the original failure. But, if you upgrade to ...

ntfsprogs-2011.4.12-3.fc15.x86_64

then ntfsprogs-2.0.0-15.fc14.i686 should be removed/obsoleted.
Comment 9 James Laska 2011-05-11 20:42:01 EDT
Retesting while starting with the following F14 packages installed...
 * ntfsprogs-.0.0-15.fc14.x86_64
 * ntfsprogs-.0.0-15.fc14.i686

Anaconda update to f15 (with 'updates' and 'updates-testing' *disabled*) results in no stoppage or failures during upgrade and installs

 * ntfs-3g-2011.4.12-2.fc15.x86_64
 * ntfsprogs-2.0.0-15.fc14.i686
 * ntfsprogs-2011.4.12-2.fc15.x86_64

When I attempt to update the system to 'updates-testing', I get...

(full output at http://fpaste.org/Z37g/)

Transaction Check Error:
file /sbin/mkfs.ntfs from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/mkntfs.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfscat.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfsclone.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfscluster.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfscmp.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfscp.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfsfix.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfsinfo.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfslabel.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfsls.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfsprogs.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfsresize.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
file /usr/share/man/man8/ntfsundelete.8.gz from install of ntfsprogs-2:2011.4.12-3.fc15.x86_64 conflicts with file from package ntfsprogs-2.0.0-15.fc14.i686
Comment 10 Fedora Update System 2011-05-12 05:46:40 EDT
libguestfs-1.2.14-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libguestfs-1.2.14-3.el5
Comment 11 Rex Dieter 2011-05-13 08:50:24 EDT
*** Bug 704435 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2011-05-14 00:05:55 EDT
ntfs-3g-2011.4.12-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2011-05-31 06:08:22 EDT
libguestfs-1.2.14-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/libguestfs-1.2.14-5.el5
Comment 14 Richard W.M. Jones 2011-05-31 06:32:30 EDT
(In reply to comment #13)
> libguestfs-1.2.14-5.el5 has been submitted as an update for Fedora EPEL 5.
> https://admin.fedoraproject.org/updates/libguestfs-1.2.14-5.el5

Sorry, auto-obsoleting of an old package made it inherit
this bug by accident.  I've removed this bug from the update.

Note You need to log in before you can comment on or make changes to this bug.