Bug 703233 - syslog-ng not enabled after F14->F15 upgrade
syslog-ng not enabled after F14->F15 upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: syslog-ng (Show other bugs)
15
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jose Pedro Oliveira
Fedora Extras Quality Assurance
RejectedNTH https://fedoraproject.org...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-09 13:14 EDT by James Laska
Modified: 2013-09-02 02:56 EDT (History)
8 users (show)

See Also:
Fixed In Version: syslog-ng-3.2.3-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 08:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2011-05-09 13:14:24 EDT
As the  states, syslog-ng is enabled and starts on boot in Fedora 14.  After upgrading to Fedora 15, syslog-ng is no longer enabled by default, and does not start on boot.  \n\nWhile the workaround is straight forward, I am proposing this as a NTH fix for F15 since this will likely impact F14->F15 users, and it's not obvious that the service isn't running.
Comment 1 James Laska 2011-05-09 13:27:53 EDT
An updated package that resolves this issue is available for testing at https://admin.fedoraproject.org/updates/syslog-ng-3.2.3-2.fc15
Comment 2 Jose Pedro Oliveira 2011-05-09 13:32:21 EDT
[after collision]

James,

Which version of syslog-ng did you have on the system after the upgrade?

I think the problem should be solved by the trigger script included in Bill 
Nottingham's patch send last week (see https://bugzilla.redhat.com/show_bug.cgi?id=651823#c39).

This patch is already included in syslog-ng-3.2.3-2.fc15 that is already available in Fedora's 15 updates testing repo (example: http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/15/x86_64/syslog-ng-3.2.3-2.fc15.x86_64.rpm).

This syslog-ng build - syslog-ng-3.2.3-2.fc15 - needs to be pushed to stable with 
eventlog-0.2.12-1.fc15 (also in updates testing).  

/jpo
Comment 3 Jose Pedro Oliveira 2011-05-09 13:35:49 EDT
James,

This package is also needed
  https://admin.fedoraproject.org/updates/eventlog-0.2.12-1.fc15
for 
  https://admin.fedoraproject.org/updates/syslog-ng-3.2.3-2.fc15

/jpo
Comment 4 Adam Williamson 2011-05-09 15:20:57 EDT
not on the DVD, so nothing to be gained by making this NTH. -1



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Matthias Runge 2011-05-09 15:35:50 EDT
I'm pretty sure, the fix is already in updates-testing and needs some positive karma. I would like to push it. It provides an update to the latest stable syslog-ng version.
Comment 6 James Laska 2011-05-09 15:56:50 EDT
(In reply to comment #5)
> I'm pretty sure, the fix is already in updates-testing and needs some positive
> karma. I would like to push it. It provides an update to the latest stable
> syslog-ng version.

Correct, this fix *is* in updates-testing, but it is *not* in 'stable' and F15 is currently frozen for the Final release.  Therefore it will not be included on F15 media.  However, adamw pointed out that systelog-ng is not included on the media anyway, so this is a moot point when it comes to tracking this as a release blocker.

Once syslog-ng-3.2.3-2.fc15 moves into 'updates', we can close this issue out.

(In reply to comment #4)
> not on the DVD, so nothing to be gained by making this NTH. -1

I wasn't able to cross-reference the bugs with what packages are available on
the DVD.  Given that this isn't provided on the DVD, I'm in perfect agreement
that this can easily be addressed by a post-release update and does not affect
the installation media in any way.

Adding whiteboard:RejectedNTH
Comment 7 Adam Williamson 2011-05-10 14:58:00 EDT
you also have to drop the blocks: f15-accepted when rejecting.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Jose Pedro Oliveira 2011-05-19 10:28:24 EDT
Current status as of 2011-05-19:

 * syslog-ng-3.2.3-2.fc15 and eventlog-0.2.12-1.fc15 are already available in the updates repositories.

 * syslog-ng-3.2.4-3.fc15 (also an security update) is available in the updates testing repositories. Feedback is welcome at
   https://admin.fedoraproject.org/updates/syslog-ng-3.2.4-3.fc15

/jpo
Comment 9 James Laska 2011-05-24 09:26:15 EDT
I documented this issue as a CommonBug.  Please feel free to adjust/patch as needed.

https://fedoraproject.org/wiki/Common_F15_bugs#upgrade-disabled-services
Comment 10 Jose Pedro Oliveira 2011-08-01 08:15:02 EDT
Closing ticket (trigger script included since syslog-ng-3.2.3-2.fc15).

Note You need to log in before you can comment on or make changes to this bug.