This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 703272 - subscription-manager-gui is still displaying unlimited pools as -1
subscription-manager-gui is still displaying unlimited pools as -1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Michael Stead
John Sefler
:
: 701374 (view as bug list)
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-09 15:49 EDT by John Sefler
Modified: 2011-12-06 12:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:14:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
now renderring "unlimited" instead of -1 (68.52 KB, image/png)
2011-07-12 13:15 EDT, John Sefler
no flags Details
"unlimited" fix for Subscription Assistant (68.52 KB, image/png)
2011-07-12 13:17 EDT, John Sefler
no flags Details
"unlimited" fix for Contract Selection (24.51 KB, image/png)
2011-07-12 13:20 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2011-05-09 15:49:30 EDT
Description of problem:
subscription-manager-gui is rendering pool unlimited pool quantities as -1 instead of "unlimited"

Three cases:
0. the All Available Subscriptions tab (ALREADY FIXED BY Bug 702029) 
1. the Become Compliant window under the "Available Subscription" column
2. the Contract Selection dialog


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-6server ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.95.14-1.el6_1.x86_64
subscription-manager-gnome-0.95.14-1.el6_1.x86_64
subscription-manager-0.95.14-1.el6_1.x86_64


How reproducible:


Steps to Reproduce:
1. See https://bugzilla.redhat.com/show_bug.cgi?id=683553#c10
2. See https://bugzilla.redhat.com/show_bug.cgi?id=683553#c11

Actual results:
-1 is rendered in the gui

Expected results:
"unlimited" should be rendered

Additional info:
Comment 2 RHEL Product and Program Management 2011-05-10 02:00:28 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 John Sefler 2011-05-10 12:51:44 EDT
Although detected in rhel61, I am changing its version to rhel62 since it is not a rhel61 blocker to insure it gets fixed in rhel62.
Comment 4 Michael Stead 2011-06-21 14:05:23 EDT
All 3 cases appear to be fixed in master. Please verify.
Comment 5 John Sefler 2011-07-12 13:15:06 EDT
Created attachment 512477 [details]
now renderring "unlimited" instead of -1

Re-verification of case...
0. the All Available Subscriptions tab (ALREADY FIXED BY Bug 702029) 


Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.3-1.git.33.8f93d7f.el6.x86_64
Comment 6 John Sefler 2011-07-12 13:17:53 EDT
Created attachment 512479 [details]
"unlimited" fix for Subscription Assistant

Verification of case...
1. the Become Compliant window (renamed to Subscription Assistant) under the "Available Subscription" column


Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.3-1.git.33.8f93d7f.el6.x86_64
Comment 7 John Sefler 2011-07-12 13:20:13 EDT
Created attachment 512481 [details]
"unlimited" fix for Contract Selection

Verification of case...
2. the Contract Selection dialog

Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.3-1.git.33.8f93d7f.el6.x86_64
Comment 8 John Sefler 2011-07-12 13:58:33 EDT
*** Bug 701374 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2011-12-06 12:14:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.