Bug 70349 - Certain text cannot be seen, but it seems to be rendered
Certain text cannot be seen, but it seems to be rendered
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gaim (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
: 68496 72008 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-31 14:49 EDT by David Coulthart
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-03 00:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Coulthart 2002-07-31 14:49:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
When certain people send IMs or when checking their away message/info, the text
of their IM or away message doesn't display.  The proper spacing seems to be
taken up for where the text should be displayed, but it is all white, like the
background.  Highlighting the text area doesn't show the text in reversed colors
either.  While plain text can't be seen, emoticons are displayed properly.  It
seems to happen most notably when the other person is using AIM on Mac OS X, but
it has also happened when the other person is using AIM on Windows.  I have had
the problem with both limbo betas 1 & 2, which were installed using a default
install (laptop with beta 1, workstation with beta 2).  The machine is an
Inspiron 2500, with X configured during install to use the 815e display driver &
Dell 1024x Laptop Display @ 1024x768x24b.  The problem does not happen with all
conversations or away messages/profiles, but I can't identify a particularly
distinct feature of the conversations/profiles that do break.  But if the
problem happens with a particular person, it seems to always be that way.  Using
ethereal, I found that the text the other person sends is being sent across the
wire.  Checking the debug window in gaim, there don't seem to be any error messages.

Version-Release number of selected component (if applicable):
Version included with limbo beta (also tried 0.59 vanilla from gaim.sf.net with
same results).

How reproducible:
Always

Steps to Reproduce:
1.Login to AIM service with gaim.
2.Begin conversation with person or check their profile.
3.
	

Actual Results:  The text from the other person does not display except for
emoticons.

Expected Results:  All text should be seen.

Additional info:
Comment 1 Hakon 2002-08-01 10:24:33 EDT
Confirming. It happens to me always. Maybe because practically ever message I
receive is likely to contain at least one exotic character?
Comment 2 Warren Togami 2002-08-11 04:27:21 EDT
Confirmed, I have this exact same problem too after a custom install of Limbo2.
 It appears that gaim is unable to display text from certain people but it works
fine from other people.  If you save the chat logs from these sessions you can
see that the text did come in properly, and you can read the HTML font face that
causes the problem.  In some quick tests just now "Arial" "Verdana" "Times New
Roman" and "Tehoma" all caused this same problem for gaim.

I didn't have this problem earlier today with my Limbo2 system upgraded from
7.3.  I think this may be related to my custom re-install today, very minimal on
category selections.  I highly suspect that it is missing some necessary font
packages.

I will do some testing now...
Comment 3 Warren Togami 2002-08-11 05:18:37 EDT
Okay this isn't good.  I just installed all font packages and those Windows
fonts mentioned above still show up as blank.

Now that I think about this, I have seen this problem on a fresh install of 7.3
on my friend's system too. =(
Comment 4 Christopher Blizzard 2002-08-11 12:14:31 EDT
*** Bug 68496 has been marked as a duplicate of this bug. ***
Comment 5 Christopher Blizzard 2002-08-11 12:54:35 EDT
Strange, I'm having trouble reproducing this.  I know that I saw it earlier.  I
can specify all kinds of fonts on a windows system and gaim seems to be
defaulting to the default font as it should.
Comment 6 Warren Togami 2002-08-11 19:45:08 EDT
It seems to happen often with a minimal custom install where I chose only Gnome
desktop.

If we can't solve this, would it be acceptable to insert a workaround patch to
gaimrc.c to enable "Ignore font faces" by default?
Comment 7 Warren Togami 2002-08-11 20:10:05 EDT
Found a related bug in Evolution where certain text fails to appear.  Check out
this screenshot below where every instance of "gaim" disappears from the message
preview pane when it is in the folder search filter.

http://www.mplug.org/archive/2002/evolution-search-blank-bug.php

The interesting thing is that if I select the text around the affected area,
then middle-click in another application, the text is properly pasted including
the word "gaim".

After I discovered this, I tried the same thing in gaim.  Disabled "Ignore font
faces", then asked my Windows AIM friend to send me some messages.  They
appeared as blank in the gaim chat window, but select highlight and middle-click
revealed the proper words.

Could this possibly be a more general font system problem, failing to display
text in certain circumstances?
Comment 8 Christopher Blizzard 2002-08-20 15:01:07 EDT
*** Bug 72008 has been marked as a duplicate of this bug. ***
Comment 9 Warren Togami 2002-08-21 00:55:54 EDT
Shouldn't component of this be "distribution" because it is some rare
installation bug that causes this and Evolution fonts to behave improperly?
Comment 10 J Mora 2002-08-30 14:47:32 EDT
Confirming bug on a fresh install of null. All symptoms exactly like those of
warren@togami.com.
Comment 11 Warren Togami 2002-08-30 15:21:20 EDT
redhat.com@ragweed.net,

1) What video card do you have?   (Try "lspci -n" and please post the line
containing "Class 0300".)

2) Was your install a default install (Personal Desktop, Workstation, Server,
etc.) or some type of custom?
Comment 12 J Mora 2002-08-30 15:24:02 EDT
1) 01:00.0 Class 0300: 1002:4c4d (rev 64)

For those curious -
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x
(rev 64)

2) Personal Desktop install, GNOME.
Comment 13 Warren Togami 2002-08-31 02:37:57 EDT
Interesting, you have the exact same video card as me, exactly the same PCI ID.

However, I only seen this bug when I have done Custom installs of Valhalla,
Limbo2 and Null.  Although I haven't tried Personal Desktop on this machine... I
will test this next.
Comment 14 Warren Togami 2002-08-31 02:42:16 EDT
If you have the time, can you try a "Workstation" default install.  I *think*
that wont exhibit this font behavior.  It may have some package that is missing
from "Personal Desktop" that is causing our problems.
Comment 15 J Mora 2002-09-01 22:00:25 EDT
Same problem with Desktop GNOME install on,

01:00.0 Class 0300: 10de:0110 (rev b2)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX] (rev b2)

I'll be reinstalling null on my laptop (Rage Mobility) as workstation. I'll let
you know.
Comment 16 J Mora 2002-09-03 00:58:23 EDT
Reinstalled null on the above mentioned Rage Mobility laptop with a workstation
install, and still no text is displayed. (The 'conversation' occurred between my
null laptop and  my RH7.2 desktop, each with different oscar accounts).

I also tried compiling gaim from cvs (and enabled gnome2) and it works well
enough, albeit with some font sizing issues.
Comment 17 Matt Wilson 2002-09-05 16:26:01 EDT
If the user you're communicating with had a font set that you don't have, it
wouldn't display.  This should be fixed in RAWHIDE, 0.59.1-1 or later.

Note You need to log in before you can comment on or make changes to this bug.