Bug 70350 - anaconda crashed after starting X Server
anaconda crashed after starting X Server
Status: CLOSED DUPLICATE of bug 70842
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
Blocks: 67217
  Show dependency treegraph
Reported: 2002-07-31 14:52 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-16 06:20:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
isys.py with debugging info (11.17 KB, text/plain)
2002-08-15 22:48 EDT, Michael Fulbright
no flags Details

  None (edit)
Description Need Real Name 2002-07-31 14:52:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611

Description of problem:
After deteting Graphics Card and mouse Type the X server starts. I get to see
the Red hat Logo. After a few seconds the installer drops back to Console with a
system Error 2 No such File or directory.
Anaconda gives some error messages about make Device Inode, iutil.py and isys.py

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.insert Boot Disk
2.start installation

Actual Results:  installation crashes

Expected Results:  installation should continue

Additional info:

I got theses Errors on the first release of Limbo. Error continues on Limbo 2.
Console Fallback gives these errors:

File "usr/bin/anaconda", line 625, in ? 
iutil.makeDriveDeviceNodes ()
File "usr/lib/anaconda/iutil.py", line 420, in makeDriveDeviceNodes
isys.makeDevInode(drive, "/dev/%s" % 
File "usr/lib/anaconda/isys.py", line 257, in makeDeviceInode
_isys.mkdevinode (name,fn)

System Error: (2, 4No such File or directory `)

I boot with Limbo provided boot disk image from LS-120 Drive.
System is Running RH 7.3 already.
System contains Scsi and IDE HDDs
Comment 1 Michael Fulbright 2002-08-02 12:07:40 EDT
Does the installer work if you run it with 'linux text'?
Comment 2 Need Real Name 2002-08-02 12:23:35 EDT
No ! Text installer gives the same error message after Probing Gfx Card, Monitor
and Mouse.
Comment 3 Michael Fulbright 2002-08-13 11:07:34 EDT
Jeremy you've booted from the ls-120 with no problems right?
Comment 4 Jeremy Katz 2002-08-13 11:46:10 EDT
Yes.  What specific scsi controller do you use and exactly which drive device
nodes do you have?
Comment 5 Need Real Name 2002-08-13 14:33:12 EDT
The SCSI Card is an adaptec 2940 (the old one) PCI. The following drives are
Toshiba XM-6401TA CDRom Drive
Yamaha CDR8824S CD/RW Drive
Pioneer DVD305S DVD-ROM (no patched Firmware or anything like that; RPC-2 if
that info is important)

The installtion is done from the Toshiba drive as it is the first one on the
SCSI-BUS and i can4t make the installer use another Drive.

by the way i use an ordinary hd Floppy Disk not LS-120 Media for installation.
Dunno if that was clear. 
But the Disk is in the LS-120 as there are no Floppy Disk Drives installed on my
Comment 6 Michael Fulbright 2002-08-15 22:47:20 EDT
Please put the attached isys.py file onto a ext2 formatted floppy and boot with
the command line

linux updates

when it dies please switch to VC3 (cntl-alt-f3) and let me know what the last 10
lines on that screen are. It should be something in the form of:

* In makeDevInode -> hdd /dev/hdd

except the devices will probably be different.
Comment 7 Michael Fulbright 2002-08-15 22:48:31 EDT
Created attachment 71024 [details]
isys.py with debugging info
Comment 8 Need Real Name 2002-08-16 06:20:26 EDT
Problem is that the installer doesn4t identify my ls 120 as fd0 
so .. unable to mount floppy

Floppy Timeout
end_request I/O Error , dev 02:00 (floppy) , sector 0

Floppy0: Sensei repl[0]=70 repl[1]=0 

I tried to mount the drive manually but there is no /dev/hdd 
also i dont know where to mount it ;) 

Tell me how to mount the drive or tell me how to make the installer mount it
Comment 9 Michael Fulbright 2002-08-23 12:02:32 EDT
Ok this is probably a dupe of bug 70842.

*** This bug has been marked as a duplicate of 70842 ***
Comment 10 Need Real Name 2002-08-23 17:45:12 EDT
This Bug is imho not a dupe of 70842

I replaced the LS-120 with an ordinary Floppy drive and removed all cables from
the LS-120 

Still anaconda crashes with the same error.
Comment 11 Need Real Name 2002-08-23 17:52:47 EDT
I forgot to mention that i am running 2 systems. 
Both of them with LS-120.
One System has no SCSI devices or controllers. Limbo installs fine from the LS-120
The other System has as mentioned SCSI devices and Controller. Ananconda crashes. 
Comment 12 Jeremy Katz 2002-08-29 01:54:41 EDT
If you put the isys.py added as an attachment here on an ext2 formatted floppy
and boot with 'linux updates' what inode is it trying to make right before it
Comment 13 Need Real Name 2002-09-05 08:58:12 EDT
ok here we go .. 

Actually there was no evidence of making any inodes. There was no output
concerning any inodes. 
The only thing that changed was the error message:

File "/usr/bin/anaconda", line 70, in ? 
import signal, traceback, string, isys, iutil, time

File "/tmp/updates/isys.py", line 508, in ?
bind_textdomain_codeset =_isys.bind_textdomain_codeset
Attribute error: `module` object has no attribute `bind_textdomain_codeset`

To clarify: At this point no LS 120 was installed on this system
neither were any error messages concerning any inodes displayed on any Consoles.

Note You need to log in before you can comment on or make changes to this bug.