Bug 70842 - Anaconda doesn't recognise Gateway Solo 9150's LS-120
Anaconda doesn't recognise Gateway Solo 9150's LS-120
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 70350 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-05 20:27 EDT by Scott Schmit
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 15:28:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Schmit 2002-08-05 20:27:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
When anaconda prompts me for a floppy, it is unable to read my floppy because it
thinks it's in /dev/fd0. Unfortunately, I have an LS-120, so /dev/fd0 is
disabled after boot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a Gateway solo 9150 (laptop) with a combined LS120/DVD-ROM module.
Alternatively, ask me to test the image.
2. Boot anaconda, have it ask you for a floppy to read.

	

Actual Results:  It attempts to read device 02:00 (/dev/fd0) and fails because
that was disabled after boot. The image is now at /dev/hdd (my LS120 drive)

Expected Results:  It should have noticed at boot time that I had an LS120 and
known to look there.

Additional info:

This has happened once before, and as I understand from Jeremy it's because the
LS120 on my machine is identified by the kernel with a different string than the
(normal) LS120 drives Red Hat tests on (and than it used to when he last fixed
this problem).

Since it has broken again, Jeremy's guess was that it's a matter of the kernel
changing how it identifies the drive.

So here's what the kernel says about the drive at bootup:
...
    ide1: BM-DMA at 0xfcd8-0xfcdf, BIOS settings: hdc:pio, hdd:pio
...
hdd: LS-120 S200 01 UHD Floppy, ATAPI FLOPPY drive
...
hdd: No disk in drive
hdd: 123264kB, 963/8/32 CHS, 533 kBps, 512 sector size, 720 rpm

if there's anything else you need, please let me know.

Unfortunately, I can no longer work around the problem, so I need this to be
fixed :-/
Comment 1 Jeremy Katz 2002-08-06 03:51:34 EDT
What is the output of

python -c "from kudzu import * ; print probe (CLASS_FLOPPY, BUS_IDE | BUS_MISC |
BUS_SCSI, PROBE_ALL)"

Also, what's in /proc/ide/hdd/*?
Comment 2 Scott Schmit 2002-08-06 06:59:30 EDT
[Desc:           3.5" 1.44MB floppy drive
Driver:         unknown
Device:         fd0
, Desc:           LS-120 S200 01 UHD Floppy
Driver:         ignore
Device:         hdd
]
Comment 3 Scott Schmit 2002-08-06 07:07:07 EDT
Oops, missed the /proc info:

/proc/ide/hdd/capacity:
0
/proc/ide/hdd/driver:
ide-floppy version 0.99.newide
/proc/ide/hdd/geometry:
physical     0/0/0
logical      963/8/32
/proc/ide/hdd/identify:
8080 0000 0000 0000 0000 0000 0000 0000
0000 0000 3959 4531 3635 3739 3020 2020
2020 2020 2020 2020 0000 0000 0000 3031
3133 4c30 3132 4c53 2d31 3230 2053 3230
3020 2020 3031 2020 2020 2020 2020 2020
2020 2020 5548 4420 466c 6f70 7079 0000
0000 0a00 0000 0200 0000 0003 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 00f0 00f0 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0101
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
/proc/ide/hdd/media:
floppy
/proc/ide/hdd/model:
LS-120 S200 01 UHD Floppy
/proc/ide/hdd/settings:
name
		value		min		max		mode
----
		-----		---		---		----
bios_cyl                963             0               1023            rw
bios_head               8               0               255             rw
bios_sect               32              0               63              rw
breada_readahead        4               0               127             rw
current_speed           0               0               69              rw
file_readahead          0               0               2097151         rw
ide_scsi                0               0               1               rw
init_speed              0               0               69              rw
io_32bit                0               0               3               rw
keepsettings            0               0               1               rw
max_kb_per_request      64              1               127             rw
nice1                   1               0               1               rw
number                  3               0               3               rw
pio_mode                write-only      0               255             w
slow                    0               0               1               rw
ticks                   0               0               255             rw
unmaskirq               0               0               1               rw
using_dma               0               0               1               rw
Comment 4 Michael Fulbright 2002-08-14 12:42:35 EDT
Could you look on VC3 after you are in the loader and see if there is a line like:

system floppy device is xxxx

where xxx would be /dev/fd0 or something similar?

Why does there appear to be a fd0 controller but no actual drive?  Is the fd0
disabled in BIOS?
Comment 5 Scott Schmit 2002-08-14 18:46:19 EDT
There is such a line. It says:
* system floppy device is fd0

Not that that means anything. From what I've been told/I understand, LS-120
drives work like this:
At boot time, the LS-120 drive emulates/enables a floppy disk controller so that
the system BIOS can use it to boot. Thus you can pop a floppy into the LS-120
drive and boot off the floppy as if the drive were a normal floppy drive. I've
never tried it, but I wouldn't be suprised if you can't use an LS-120 disk to
boot simply because the floppy disk controller/BIOS doesn't support LS-120
disks. So, yes, the system floppy device *WAS* fd0.

However:
Once bootup is complete, the floppy controller is disabled/ignored (by the
drive, I would imagine, since I'm guessing it's purely a compatibility measure).
At this point, any attempts to read/write disks via the floppy controller (fd0)
will always fail because the drive has simply stopped listening. Instead,
requests must go to the IDE chain (hdd). So, no, the system floppy device
*ISN'T* fd0 any more.

The bug, to reiterate, is that the installer/loader doesn't recognise my LS120
drive as such and realize that it needs to invoke the (already coded) LS120
workaround to get to the floppy it's requesting.
Comment 6 Michael Fulbright 2002-08-23 12:02:26 EDT
*** Bug 70350 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2002-08-23 15:28:47 EDT
Should be fixed now
Comment 8 Jay Turner 2002-09-05 16:49:59 EDT
We are able to make use of an LS120 drive here at the office, so we think this
is resolved.  Unless you have something "special" going on, in which case,
please reopen and we will research more and attempt to obtain the hardware in
question.
Comment 9 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.