Bug 703511 - intel_ips ips-monitor in D state, laptop fan runs continuously
intel_ips ips-monitor in D state, laptop fan runs continuously
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 702775 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 10:49 EDT by Richard W.M. Jones
Modified: 2011-08-03 14:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-2.6.38.6-27.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 01:11:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-05-10 10:49:25 EDT
Description of problem:

This seems to be the same as this Ubuntu bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765082

With all up to date Fedora 15, ips-monitor kernel thread is
constantly in D state, resulting in the load avg always being
over 1.0, resulting in the laptop fan running continuously.

Version-Release number of selected component (if applicable):

Linux spin.home.annexia.org 2.6.38.5-22.fc15.x86_64 #1 SMP Mon May 2 19:28:55 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Always.

Steps to Reproduce:
1. Nothing, just boot the machine.
2.
3.

Additional info:

$ ps ax | grep ' D '
  723 ?        D      0:04 [ips-monitor]
 3477 pts/0    S+     0:00 grep --color=auto  D 

According to the Ubuntu bug, it is fixed by this patch:
https://lkml.org/lkml/2011/3/19/37
Comment 1 Richard W.M. Jones 2011-05-10 10:51:27 EDT
I mean, this patch:
https://lkml.org/lkml/2011/3/22/345
Comment 3 Chuck Ebbert 2011-05-11 09:28:33 EDT
Patch will be in kernel-2.6.38.6-27.fc15
Comment 4 Fedora Update System 2011-05-16 00:46:17 EDT
kernel-2.6.38.6-27.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.6-27.fc15
Comment 5 Fedora Update System 2011-05-17 01:37:00 EDT
Package kernel-2.6.38.6-27.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.38.6-27.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-2.6.38.6-27.fc15
then log in and leave karma (feedback).
Comment 6 Adam Williamson 2011-05-17 14:48:04 EDT
probably worth a commonbugs note; do we know what systems this will affect?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Richard W.M. Jones 2011-05-17 14:56:50 EDT
I've installed the update but not booted to test it yet.

Mine is a Thinkpad T510W.

I'm not sure this is common .. I seem to be the only one
that has noticed :-)
Comment 8 Chuck Ebbert 2011-05-18 14:09:41 EDT
*** Bug 702775 has been marked as a duplicate of this bug. ***
Comment 9 Chuck Ebbert 2011-05-18 14:19:41 EDT
(In reply to comment #6)
> probably worth a commonbugs note; do we know what systems this will affect?
> 

Intel systems with integrated i915 graphics.
IPS controls power sharing between the CPU and the GPU.
Comment 10 Fedora Update System 2011-05-19 01:10:51 EDT
kernel-2.6.38.6-27.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Jeff Sheltren 2011-05-19 09:54:58 EDT
(In reply to comment #10)
> kernel-2.6.38.6-27.fc15 has been pushed to the Fedora 15 stable repository.  If
> problems still persist, please make note of it in this bug report.

I can confirm this fixes it for me.  Load is down to near 0, and ips-monitor is no longer in D state.
Comment 12 Adam Williamson 2011-05-24 10:18:37 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Fedora Update System 2011-06-02 10:42:26 EDT
kernel-2.6.38.7-30.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.7-30.fc15

Note You need to log in before you can comment on or make changes to this bug.