Bug 703565 - [abrt] Zim-0.52-1.fc14: pageindex.py:133:on_changed:ValueError: invalid tree path
[abrt] Zim-0.52-1.fc14: pageindex.py:133:on_changed:ValueError: invalid tree ...
Status: CLOSED DUPLICATE of bug 802750
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
14
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:f8be94d8
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 13:20 EDT by Giuseppe Fiorentino
Modified: 2012-08-13 08:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 08:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (513 bytes, text/plain)
2011-05-10 13:20 EDT, Giuseppe Fiorentino
no flags Details

  None (edit)
Description Giuseppe Fiorentino 2011-05-10 13:20:55 EDT
abrt version: 1.1.18
architecture: i686
cmdline: /usr/bin/python /usr/bin/zim
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.13-91.fc14.i686
package: Zim-0.52-1.fc14
reason: pageindex.py:133:on_changed:ValueError: invalid tree path
release: Fedora release 14 (Laughlin)
time: 1305047680
uid: 500

backtrace
-----
pageindex.py:133:on_changed:ValueError: invalid tree path

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 133, in on_changed
    treeiter = self.get_iter(treepath)
ValueError: invalid tree path

Local variables in innermost frame:
path: <IndexPath: interventi:147>
signal: 'row-inserted'
treepath: (6, 0)
o: <Index object at 0xa2e87fc (zim+index+Index at 0xa379190)>
self: <PageTreeStore object at 0xa2f4144 (zim+gui+pageindex+PageTreeStore at 0xa32b660)>

How to reproduce
-----
1. i started zim
2. the index column is empty
3. i rebuild index (tools -> rebuild index)
Comment 1 Giuseppe Fiorentino 2011-05-10 13:20:58 EDT
Created attachment 498107 [details]
File: backtrace
Comment 2 Robin Lee 2011-05-15 03:49:47 EDT
I can't reproduce this issue with your steps. Any detailed steps?
Comment 3 Robin Lee 2012-08-13 08:34:05 EDT

*** This bug has been marked as a duplicate of bug 802750 ***

Note You need to log in before you can comment on or make changes to this bug.