This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 802750 - [abrt] Zim-0.55-1.fc16: pageindex.py:207:select_page:ValueError: invalid tree path
[abrt] Zim-0.55-1.fc16: pageindex.py:207:select_page:ValueError: invalid tree...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
https://bugs.launchpad.net/fedora/+bu...
abrt_hash:c549d5bf02dd6f5170cf2f18bc1...
:
: 703565 753356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 08:39 EDT by David Kovalsky
Modified: 2014-03-31 19:46 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 22:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-03-13 08:39:29 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/zim
comment:        I've moved a page from one subtree to another, just like I've done hundreds of times in the past. Not sure why this time it blew up and I'm not any smarter from the traceback. 
executable:     /usr/bin/zim
kernel:         3.2.9-2.fc16.x86_64
reason:         pageindex.py:207:select_page:ValueError: invalid tree path
time:           Tue 13 Mar 2012 01:34:35 PM CET
uid:            10625
username:       dkovalsk

backtrace:
:pageindex.py:207:select_page:ValueError: invalid tree path
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 744, in on_open_page
:    self.treeview.select_page(path, vivificate=True)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 671, in select_page
:    model.select_page(path) # highlight in model
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 207, in select_page
:    treeiter = self.get_iter(treepath)
:ValueError: invalid tree path
:
:Local variables in innermost frame:
:self: <PageTreeStore object at 0x7f9faa4e0f50 (zim+gui+pageindex+PageTreeStore at 0x234d0c0)>
:path: <Path: X-RH archive:update-qa-contact>
:oldpath: <IndexPath: X-Red Hat:update-qa-contact>
:treepath: (11, 0)
:mypath: <IndexPath: X-Red Hat:update-qa-contact>
Comment 1 jan.basko 2012-03-21 08:22:06 EDT
delete page

Package: Zim-0.55-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)
Comment 2 Peter Portante 2012-04-02 10:31:24 EDT
I was moving existing pages to be sub pages of a new page.

Package: Zim-0.55-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 3 Peter Portante 2012-04-11 14:48:25 EDT
Moved a sub page from its current parent page to its current parent's parent page (from root->page->subpage0->subpage1 to root->page->subpage1).

Package: Zim-0.55-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 4 David Kovalsky 2012-04-15 07:41:48 EDT
Rename a subpage

Package: Zim-0.55-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 5 Peter Portante 2012-04-16 09:36:35 EDT
Moved a sub page up to another parent page.

Package: Zim-0.55-1.fc16
OS Release: Fedora release 16 (Verne)
Comment 6 gnemas 2012-04-30 23:12:43 EDT
Typed [[where does this go]] , Ctrl+R, and then clicked on the link.

Package: Zim-0.56-1.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)
Comment 7 nomnex 2012-05-15 12:05:32 EDT
Package: Zim-0.56-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
anytime I move or delete a page, in the latest zim update (v. 0.56), I get abrt crash report messages
Comment 8 Fabian Stanke 2012-05-18 06:44:56 EDT
This bug corresponds to https://bugs.launchpad.net/fedora/+bug/915037
I pushed a fix to launchpad yesterday that has already been merged. Backporting should be trivial.
Comment 9 David Kovalsky 2012-05-25 11:12:26 EDT
Remove a subpage (actually a couple of subpages on the same level)

Package: Zim-0.56-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 10 Robin Lee 2012-05-27 04:02:52 EDT
*** Bug 753356 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2012-05-27 04:58:32 EDT
Zim-0.56-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/Zim-0.56-3.fc16
Comment 12 Fedora Update System 2012-05-27 21:18:53 EDT
Package Zim-0.56-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.56-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8505/Zim-0.56-3.fc16
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-06-06 22:53:28 EDT
Zim-0.56-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Robin Lee 2012-08-13 08:34:05 EDT
*** Bug 703565 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.