Bug 70373 - Something wrong with fonts in OpenOffice GUI
Something wrong with fonts in OpenOffice GUI
Status: CLOSED DUPLICATE of bug 68953
Product: Red Hat Public Beta
Classification: Retired
Component: openoffice.org (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-31 17:37 EDT by Marc Deslauriers
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 06:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Deslauriers 2002-07-31 17:37:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
The fonts used in the OpenOffice GUI are really ugly. It looks like they aren't
hinted or something. 

Version-Release number of selected component (if applicable):
openoffice-1.0.1-2

How reproducible:
Always

Steps to Reproduce:
1.Start OpenOffice writer
2.Look at the font used for the menu
3.
	

Actual Results:  The font is barely legible. Looks like the hinting is disabled.

Expected Results:  Something looking better!

Additional info:

OpenOffice must include it's own renderer as the same fonts display ok
non-anti-alised in gtk 1.4 applications. Was an option left out by mistake?
Comment 1 Marc Deslauriers 2002-07-31 18:15:58 EDT
By default, OpenOffice looks for a font called "Andale Sans UI". When the font's
not there, as is the case in limbo, it chooses something else which happens to
be unreadable.

Here is how to fix the UI font problem:

1- Go to Tools/Options/Font Replacement
2- Check the "Apply replacement table" box
3- Replace "Andale Sans UI" with "Helvetica" and check "Always" and "Screen".
  (the font names have to be typed in, as they won't appear in the list)

Can this be integrated already set up in the rpm?

Comment 2 Geert Noel 2002-08-02 15:32:57 EDT
I've replaced the font with Nimbus Sans L, which makes it look like the Gnome2
apps. It's even anti-aliased. Helvetica didn't look very good on my pc (but
Helvetic did).
Comment 3 Marc Deslauriers 2002-08-02 16:40:50 EDT
I'm not talking about the default font used in the document window (although
that needs fixing too...). I'm talking about the font that is used in the UI
(the menus, dialog boxes, etc.). It doesn't antialias fonts used in the UI, so
Nimbus Sans L doesn't look good there. For the document font, Nimbus Sans L is
great, but for the UI, helvetica gives it the same look as the gtk 1 apps.
Comment 4 Geert Noel 2002-08-05 14:49:03 EDT
I'm talking about the UI fonts too. They're certainly anti-aliased here. I
haven't done anything special, so I don't know why it's different for you.
Comment 5 Jakub Jelinek 2002-08-06 06:37:07 EDT
openoffice-1.0.1-4 will have this fixed.
Now, what are the preferences for the default document font (for various
locales, the UI font needs to be different for different localizations too).
Comment 6 Preston Brown 2002-08-21 23:36:04 EDT

*** This bug has been marked as a duplicate of 68953 ***

Note You need to log in before you can comment on or make changes to this bug.