Bug 703809 - Export as PO/XML/HTML feature
Export as PO/XML/HTML feature
Status: CLOSED DUPLICATE of bug 725319
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-11 06:12 EDT by Yuko Katabami
Modified: 2013-03-03 21:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-08 08:59:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuko Katabami 2011-05-11 06:12:43 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.2.11) Gecko/20101026 Red Hat/3.6-2.el5 Firefox/3.6.11

When I need to convert the working data into PO/XML/HTML files, I need to aske either administrator or maintainer, which is not very convenient. It would be great if Zanata has "Export as" feature.

Reproducible: Always
Comment 1 James Ni 2011-05-11 21:31:13 EDT
Hi Yuko,

We provide python client and maven client for export/pull data from Zanata server. For current version, we only support export data to PO, but we may support XML/HTML format later. 

You can install zanata-python-client with yum install, current version for zanata-python-client is 1.2.3, then you can use zanata publican pull command to retrieve the data.

You could also take a reference from:
http://code.google.com/p/flies/wiki/FliesPythonClient

Best Regards
Comment 2 Yuko Katabami 2011-05-30 20:34:52 EDT
Hi James,

Thank you very much for your reply.

For some reason, I was not able to install zanata-python-client with yum install.
It returned a message "No package zanata-python-client available".
What did I do wrong? 

This is a basic question, but is this a command line tool?

What I wanted was a GUI botton or menu that allows you to export file as xml or po from WebUI, without being maintainer or administrator.
Is it possible?

Sorry for asking you such basic questions without technical knowledge.
It would be very much appreciated if you could help me understand.

Kind regards,

Yuko
Comment 3 Ding-Yi Chen 2011-05-30 21:39:00 EDT
Hi Yuko,

I guess you are using RHEL, which does not have this package by default.

It's in EPEL, but I am not quite sure about the package management policy of your team, so ask your manager about it.
Comment 4 Yuko Katabami 2011-05-30 21:59:17 EDT
Hi James,

Thank you very much for your prompt reply.
Yes, I do use RHEL 5 on my real machine and RHEL 6 on virtual machine.
I might try to install Fedora on my VMware then.

So my understanding is that you may not be able to implement file export feature into GUI because the package managers/mainteners may not want to allow users to do that depending on their policy. Is it right?

Would it be possible to implement this feature into GUI, with options that each manager can choose whether to allow users to export or not...?

This is only my wish....as it will save time and inconvenience.
For example, when we translate newsletters, we have to send it to proofreader as xml file. This can happen a several times in one job. It is a little inconvenient to ask manager each time. 
Also when he is not available, no one else is able to do that and it results in delay.


Kind regards,

Yuko
Comment 5 James Ni 2011-05-30 22:35:36 EDT
Hi Yuko, 

Actually we have a plan to provide export feature into GUI in the near future, but we don't have a detail time schedule for that, we will try our best. 

For currently implementation, we don't have a restriction for po pull, everyone can pull the content from server. You can use Maven/Python client to export the PO files to locale machine. I remember that you could use 'publican build --formats=html --langs' to convert PO files back to XML format. And using 'publican package' to build a package for a language. Could this workaround solve your problem temporarily? 

We also have a plan to support XML format directly, for importing and exporting, we will try to implement these features soon.    

Best Regards
Comment 6 Sean Flanigan 2011-09-07 00:33:18 EDT
Assigning to Scrum product owner for prioritisation.
Comment 7 Runa Bhattacharjee 2011-09-08 08:59:02 EDT

*** This bug has been marked as a duplicate of bug 725319 ***

Note You need to log in before you can comment on or make changes to this bug.