Bug 725319 - RFE - Offline translation feature via web UI
RFE - Offline translation feature via web UI
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 1.6-beta-1
Assigned To: Carlos Munoz
Joyce Chang
:
: 703809 (view as bug list)
Depends On: 749439
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-25 01:30 EDT by Noriko Mizumoto
Modified: 2013-03-03 22:19 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause Translators can download translation work but not being able to upload their offline work to Zanata via web UI. Consequence Translators offline workflow is affected. Change Implemented PO file upload functionality under the "Files" section for each language. Result Translators should be able to download PO files and work on it offline and then upload the work afterwards all via Zanata web UI.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2011-07-25 01:30:09 EDT
It is not uncommon condition where translator work offline. Some simply prefer working offline, others have the situation that an internet connection is unavailable. For those, current online only translation feature limits the posibility of translation work. 

For example, many community translators work on translation outside of their working hours such as during travel (by bus or train) to or from work. Since usually there is no internet connection available during travel, they will no longer be able to contribute these particular time.
Another example, some inhouse translators may work fulltime on translation via vpn to access internal reporitory. Those translators need both the internet connection and vpn to work in stable manner. When some problem happens the provider side, they have nothing to do on translation but complete on hold. 

It is higly appriciated to have the offline translation feature, which allows translator to translate conitunously in offline mode wherever a connetion is not available.
Comment 1 Michelle Kim 2011-07-28 21:27:56 EDT
Thanks Noriko

I will add this feature request to our Product Backlog. 
This feature is great, but may not be high priority for next coming months but we will make sure that we work towards supporting offline translation in the future.

Cheers
Michelle
Comment 2 Sean Flanigan 2011-09-07 00:33:26 EDT
Assigning to Scrum product owner for prioritisation.
Comment 3 Runa Bhattacharjee 2011-09-08 08:59:02 EDT
*** Bug 703809 has been marked as a duplicate of this bug. ***
Comment 4 Sean Flanigan 2011-09-08 22:46:59 EDT
See also bug 736898 for pushing offline translations via the command line.
Comment 5 Carlos Munoz 2011-10-27 00:04:54 EDT
Se also bug 749439 for downloading PO files. 

Reassigning to Runa for re-prioritization.
Comment 7 Joyce Chang 2012-05-03 01:18:39 EDT
verified in Zanata version 1.6.0-alpha-3-SNAPSHOT (20120430-0019).
Comment 8 Patrick Huang 2012-06-05 21:34:38 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Translators can upload their offline work to Zanata via web UI at a later stage.


Consequence
Translators can not upload their offline work to Zanata.


Change
Implemented PO file upload functionality under the "Files" section for each language.


Result
Translators should be able to download PO files and work on it offline and then upload the work afterwards all via Zanata web UI.
Comment 9 Patrick Huang 2012-06-05 21:51:58 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,9 +1,9 @@
 Cause
-Translators can upload their offline work to Zanata via web UI at a later stage.
+Translators can download translation work but not being able to upload their offline work to Zanata via web UI.
 
 
 Consequence
-Translators can not upload their offline work to Zanata.
+Translators offline workflow is affected.
 
 
 Change

Note You need to log in before you can comment on or make changes to this bug.