Bug 704064 - F15 final RC1 desktop live fails to boot in KVM: umount /squashfs: not found , unknown filesystem type 'DM_snapshot_cow'
Summary: F15 final RC1 desktop live fails to boot in KVM: umount /squashfs: not found ...
Keywords:
Status: CLOSED DUPLICATE of bug 699113
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F15Blocker, F15FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-05-12 02:37 UTC by Adam Williamson
Modified: 2013-01-10 06:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-12 18:24:07 UTC
Type: ---


Attachments (Terms of Use)

Description Adam Williamson 2011-05-12 02:37:53 UTC
See summary. The F15 final RC1 live image - as downloaded at http://koji.fedoraproject.org/koji/taskinfo?taskID=3063933 - fails to boot with those two errors:

umount: /squashfs: not found
mount: unknown filesystem type 'DM_snapshot_cow'
(the mount error is repeated several times)

Nominating as release blocker.

Comment 1 Adam Williamson 2011-05-12 03:04:44 UTC
that's actually a test build we fired off yesterday, not rc1, but yup, fails. ditto in spice vm and on a real machine. (i suppose the new kernel that's really in the real rc1 may help with this, when it comes).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2011-05-12 16:56:44 UTC
confirmed same error with the RC1 package set test build - http://koji.fedoraproject.org/koji/taskinfo?taskID=3068113 .

http://fpaste.org/xkvd/ is a diff between a working image I have locally, based on the 2011-05-09 f15 'stable' package set and composed on an f14 host, and the failing RC1 image. But the issue could be a host-side one too, it may be to do with the new livecd-tools build; it would be good to try a compose with rc1 package set but an older livecd-tools on the build host.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Adam Williamson 2011-05-12 17:04:10 UTC
the changes in the diff that look to be early enough in boot to be possibly related are:

dracut (009-6 on the working image, 009-9 on the broken)
kernel (2.6.38.6-25.rc1 on the working image, 2.6.38.6-26.rc1 on the broken)
util-linux (2.19-4 on the working image, 2.19.1-1 on the broken)
plymouth? (0.8.4-0.20110427.1 on the working image, 0.8.4-0.20110510.2 on the broken)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Adam Williamson 2011-05-12 17:56:27 UTC
so, happily, i can reproduce this locally now by building an lxde image. So far I've tested that downgrading livecd-tools and python-imgcreate on the buildhost to 15.5-1.fc15 does not help.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Adam Williamson 2011-05-12 18:21:33 UTC
aha - I think this is dracut.

I rebuilt dracut 009-6 with epoch of 1, and did an LXDE live compose with a side repo containing that dracut (and no other changes). That live image boots. So something between dracut 009-6 and 009-9 causes this problem.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Adam Williamson 2011-05-12 18:22:05 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Adam Williamson 2011-05-12 18:24:07 UTC
looks like this is 699113.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 699113 ***


Note You need to log in before you can comment on or make changes to this bug.