Bug 699113 - During boot, message 'mkdir: cannot create directory /run, file exists' appears on virt. console 1
During boot, message 'mkdir: cannot create directory /run, file exists' appea...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
15
x86_64 Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 701749 704064 (view as bug list)
Depends On:
Blocks: F15Blocker/F15FinalBlocker
  Show dependency treegraph
 
Reported: 2011-04-23 03:54 EDT by Jirka Daněk
Modified: 2013-03-24 16:03 EDT (History)
23 users (show)

See Also:
Fixed In Version: dracut-009-10.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-14 00:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jirka Daněk 2011-04-23 03:54:40 EDT
Description of problem:
During boot, message 'mkdir: cannot create directory /run, file exists' appears on virt. console 1. The system behaves as it should afterwards, though.

I havent tried booting after updating to current versions of packages, so I'll do it in a minute. But I haven't seen this reported when I searched the Bugzilla (even closed bugs), so here I am.

I have no idea if this really realtes to systemd, but it is a required field and it looked sensibly at first glance.

How reproducible:
Get a Fedora 15 Beta, put it on a USB stick and boot it. Shows even in emulators

Additional info:
Happens to a lot of people: http://www.google.cz/search?q=fedora+15+cannot+create+directory+/run
Comment 1 Lennart Poettering 2011-04-24 08:21:24 EDT
No such message is generated by systemd. I wonder if this is Dracut.

Harald, do you use a "mkdir" where you should be using "mkdir -p" somewhere?
Comment 2 Jason 2011-04-27 01:35:03 EDT
I was able to bypass this error by commenting out the mounting of a usb2 drive in my /etc/fstab. I had incorrectly set the device to /dev/sdc1. I've reproduced this 5 times by enabling/disabling the mount in the fstab.
Comment 3 Harald Hoyer 2011-04-27 05:52:40 EDT
yes, sorry..

/usr/share/modules.d/99base/init:
- mkdir -m 0755 /dev/shm /dev/pts /run 
+ mkdir -p -m 0755 /dev/shm /dev/pts /run
Comment 4 Jirka Daněk 2011-04-28 14:01:17 EDT
I shall probably also say, that this message appears in booting the Fedora 15 Beta Desktop image. So also live images have to be fixed.

My (default) fstab on the live image is pretty short, so I'll post it right here

[liveuser@private ~]$ cat /etc/fstab
/dev/root  /         ext4    defaults,noatime 0 0
devpts     /dev/pts  devpts  gid=5,mode=620   0 0
tmpfs      /dev/shm  tmpfs   defaults         0 0
proc       /proc     proc    defaults         0 0
sysfs      /sys      sysfs   defaults         0 0

There is not mentioned any usb drive. None the less, the error keeps showing.
Comment 5 Bruce Pieterse 2011-04-29 05:38:20 EDT
I have the same problem with a fresh install of Fedora 15 Beta.
Comment 6 Jirka Daněk 2011-04-29 07:00:15 EDT
Harald, I do not have the directory /usr/share/modules.d on my system. But you've probably ment /usr/share/dracut/modules.d/99base/init which contains exactly the line you mentioned.

So if I add the -p option in 99base/init on that line and do
- cd /boot
- [root@private boot]# mv initramfs-2.6.38.3-18.fc15.x86_64.img initramfs-2.6.38.3-18.fc15.x86_64.img_bck
- [root@private boot]# dracut initramfs-2.6.38.3-18.fc15.x86_64.img 2.6.38.3-18.fc15.x86_64

it should just fix itself after reboot?
Comment 7 Jirka Daněk 2011-04-29 07:18:44 EDT
I just couldn't wait and tried it. It worked! So hopefully no /run error any more. Thanks.

Now there is remaining only Bug 698674, Bug 700633 and bug XXXX which I am about to fill, in which my Fedora hungs up in one moment of the boot process, but it carries on when I hit a key or push ACPI button. Then it will boot all right
Comment 8 Harald Hoyer 2011-04-29 08:23:25 EDT
This message is a harmless error message.
Comment 9 Bruce Pieterse 2011-04-29 11:01:12 EDT
Confirmed. Line 109 of /usr/share/dracut/modules.d/99base/init is the only line that needs to be changed.

Tested and works! :)
Comment 10 jayce 2011-05-01 08:19:55 EDT
I have the same bug at boot
Comment 11 Michal Schmidt 2011-05-03 14:48:03 EDT
*** Bug 701749 has been marked as a duplicate of this bug. ***
Comment 12 Bruce Pieterse 2011-05-03 16:26:09 EDT
(In reply to comment #9)
> Confirmed. Line 109 of /usr/share/dracut/modules.d/99base/init is the only line
> that needs to be changed.
> 
> Tested and works! :)

After numerous reboots and adding -p to all instances in init that have /run (even one by one) this error still persists. I have checked all other files in that directory and no luck.

Like Harald said, it's harmless, so I'm leaving it for now. :)
Comment 13 Fedora Update System 2011-05-04 08:20:43 EDT
dracut-009-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dracut-009-7.fc15
Comment 14 NickG 2011-05-04 08:40:47 EDT
(In reply to comment #12)
> (In reply to comment #9)
> > Confirmed. Line 109 of /usr/share/dracut/modules.d/99base/init is the only line
> > that needs to be changed.
> > 
> > Tested and works! :)
> 
> After numerous reboots and adding -p to all instances in init that have /run
> (even one by one) this error still persists. I have checked all other files in
> that directory and no luck.
> 
> Like Harald said, it's harmless, so I'm leaving it for now. :)

After making the change mentioned, you need to regenerate the initramfs using dracut as root:

cd /boot
dracut initramfs-<your kernel here>.img

Apologies if you've already done that and it still failed but this worked for me.
Comment 15 Fedora Update System 2011-05-04 10:17:47 EDT
dracut-009-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dracut-009-8.fc15
Comment 16 Fedora Update System 2011-05-04 10:17:59 EDT
dracut-009-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dracut-009-8.fc15
Comment 17 David Timms 2011-05-04 17:32:55 EDT
F15 TC1 includes the dir exists warning.

dracut-009-8.fc15 from builder resolves the issue after running dracut ....img from comment 14.
Comment 18 Fedora Update System 2011-05-05 00:44:39 EDT
Package dracut-009-8.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-009-8.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/dracut-009-8.fc15
then log in and leave karma (feedback).
Comment 19 David Timms 2011-05-05 06:29:09 EDT
Setting: nice-to-have since it seems to be an easy fix, that takes away the release spit, and leaves the polish we want ;-)
Comment 20 Fedora Update System 2011-05-05 07:30:26 EDT
dracut-009-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dracut-009-9.fc15
Comment 21 Tim Flink 2011-05-06 15:09:49 EDT
Discussed in the 2011-05-06 blocker review meeting. Accepted as NTH since a fix is available and even though it is a cosmetic issue, it affects all installs and confuses people.
Comment 22 Fedora Update System 2011-05-08 23:57:50 EDT
dracut-009-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Alan Pevec 2011-05-12 08:09:34 EDT
This chunk breaks livecd boot
http://pkgs.fedoraproject.org/gitweb/?p=dracut.git;a=blob;f=0020-mkdir-always-with-m-0755.patch;h=771f02655bf1bc39f457001b30f1f470e28e3112;hb=ecc2cf73d14ddc121c3dd8381d290ff1421feb6b#l169



Change to /runt/initramfs/squashfs/ was not complete, here is the missing patch:

--- dracut-009/modules.d/90dmsquash-live/dmsquash-live-root.orig	2011-05-12 14:06:34.539096372 +0200
+++ dracut-009/modules.d/90dmsquash-live/dmsquash-live-root	2011-05-12 14:08:09.308061958 +0200
@@ -168,13 +168,13 @@
     mount -n -t squashfs -o ro $SQUASHED_LOOPDEV /run/initramfs/squashfs
 
     BASE_LOOPDEV=$( losetup -f )
-    if [ -f /squashfs/LiveOS/ext3fs.img ]; then
-        losetup -r $BASE_LOOPDEV /squashfs/LiveOS/ext3fs.img
-    elif [ -f /squashfs/LiveOS/rootfs.img ]; then
-        losetup -r $BASE_LOOPDEV /squashfs/LiveOS/rootfs.img
+    if [ -f /run/initramfs/squashfs/LiveOS/ext3fs.img ]; then
+        losetup -r $BASE_LOOPDEV /run/initramfs/squashfs/LiveOS/ext3fs.img
+    elif [ -f /run/initramfs/squashfs/LiveOS/rootfs.img ]; then
+        losetup -r $BASE_LOOPDEV /run/initramfs/squashfs/LiveOS/rootfs.img
     fi
 
-    umount -l /squashfs
+    umount -l /run/initramfs/squashfs
 
     do_live_from_base_loop
 fi
Comment 24 James Laska 2011-05-12 08:14:29 EDT
Clearing AcceptedNTH so this can be re-evaluated.
Comment 26 Fedora Update System 2011-05-12 08:30:59 EDT
dracut-009-10.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dracut-009-10.fc15
Comment 27 Adam Williamson 2011-05-12 14:24:07 EDT
*** Bug 704064 has been marked as a duplicate of this bug. ***
Comment 28 Adam Williamson 2011-05-12 14:25:01 EDT
proposing as F15 blocker due to the live boot breakage. I confirmed that a build with dracut 009-6 boots, one with 009-9 fails; I'll test one with 009-10 now.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Adam Williamson 2011-05-12 14:47:28 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 30 Adam Williamson 2011-05-12 14:47:52 EDT
verified that an image built with -10 boots, while one built with -9 failed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 31 James Laska 2011-05-13 16:11:19 EDT
Not having live images certainly impacts many F15 release criteria, +1 blocker.
Comment 32 Fedora Update System 2011-05-14 00:06:28 EDT
dracut-009-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 David Tonhofer 2011-08-13 19:13:45 EDT
I just now tried the Fedora 15 XFCE 32-bit LiveCD spin in a VMWare Workstation VM (7.1.4 build-385536) on Vista.

No joy!

During boot from CD: 


mount: unknown filesystem type 'DM_snapshot_cow'
mount: unknown filesystem type 'DM_snapshot_cow'
mount: unknown filesystem type 'DM_snapshot_cow'
mount: unknown filesystem type 'DM_snapshot_cow'
Dropping to debug shell
sh: Can't access tty; job control turned off
dracut:/#


But I suppose updates have not yet been pushed out? The files on the CD are dated 2011-05-13 22:XX

Note You need to log in before you can comment on or make changes to this bug.