Bug 704188 - TypeError: 'NoneType' object is not subscriptable
TypeError: 'NoneType' object is not subscriptable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
anaconda_trace_hash:53800f09dbb4e854b...
: CommonBugs
: 718163 (view as bug list)
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-05-12 07:50 EDT by James Laska
Modified: 2013-09-02 02:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-30 07:22:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (217.28 KB, text/plain)
2011-05-12 07:50 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2011-05-12 07:50:09 EDT
The following was filed automatically by anaconda:
anaconda 15.30 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 395, in update
    bootif_mac = flags.cmdline.get("BOOTIF")[3:].replace("-", ":").upper()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 352, in __init__
    self.update()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/__init__.py", line 154, in network
    self._network = network.Network()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 805, in newVG
    name = self.createSuggestedVGName(self.anaconda.network)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 135, in _scheduleLVs
    vg = anaconda.storage.newVG(pvs=pvs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 225, in doAutoPartition
    _scheduleLVs(anaconda, devs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 234, in currentStep
    self.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/text.py", line 529, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/sbin/anaconda", line 932, in <module>
    anaconda.intf.run(anaconda)
TypeError: 'NoneType' object is not subscriptable
Comment 1 James Laska 2011-05-12 07:50:14 EDT
Created attachment 498517 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2011-05-12 07:52:35 EDT
The reproducer here was pxebooting into the default cobbler kickstart install.  I believe cobbler is adding BOOTIF= and doing a text-mode kickstart install.  Looks like it is trying to get the LVM VG name from the system hostname, but that data may not yet be available?
Comment 3 Radek Vykydal 2011-05-12 08:08:53 EDT
The cause is having ksdevice=bootif without BOOTIF= provided (by pxe). This patch on master would fix it:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=6125a408d65eaf18ed19e9f31f850b4f6
Comment 4 James Laska 2011-05-12 08:25:25 EDT
Ah, thanks Radek.  This seems like a straightforward fix, I'd like to propose this for F15.  

Since there is a workaround present (provide BOOTIF=), I don't believe this is a MUSTHAVE blocker fix for F15.  However, it seems perfectly sensible to include if anaconda should be rebuilt.  And considering this can't be fixed post-release, and is of limited scope, I'm all for it :)

+0 Blocker, +1 NTH

Any other votes?
Comment 5 Radek Vykydal 2011-05-12 09:00:07 EDT
(In reply to comment #4)
> Ah, thanks Radek.  This seems like a straightforward fix, I'd like to propose
> this for F15.  
> 

Yes, seems safe, it is in master and rhel6.1 so it is also quite tested.

> 
> +0 Blocker, +1 NTH
> 

+1 NTH
Comment 6 James Laska 2011-05-16 12:20:04 EDT
Discussed during 2011-05-16 Fedora QA blocker review meeting [1].  Accepted as NTH for F15.  Should an anaconda respin be required, this bug can be included in an updated anaconda package.  Otherwise, no action is required.

[1] http://meetbot.fedoraproject.org/fedora-meeting/2011-05-16/fedora-qa.2011-05-16-15.00.html
Comment 7 Radek Vykydal 2011-07-01 07:07:50 EDT
*** Bug 718163 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.