This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 718163 - TypeError: 'NoneType' object is not subscriptable
TypeError: 'NoneType' object is not subscriptable
Status: CLOSED DUPLICATE of bug 704188
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:4101e8430195ceb23...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-01 04:52 EDT by Kir Kolyshkin
Modified: 2011-07-01 07:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-01 07:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (170.53 KB, text/plain)
2011-07-01 04:52 EDT, Kir Kolyshkin
no flags Details

  None (edit)
Description Kir Kolyshkin 2011-07-01 04:52:13 EDT
The following was filed automatically by anaconda:
anaconda 15.31 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 395, in update
    bootif_mac = flags.cmdline.get("BOOTIF")[3:].replace("-", ":").upper()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/network.py", line 352, in __init__
    self.update()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/__init__.py", line 154, in network
    self._network = network.Network()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/network_gui.py", line 54, in getScreen
    if len(self.anaconda.network.netdevices) == 0 or flags.imageInstall:
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1338, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1350, in setScreen
    return self.setScreen()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1258, in nextClicked
    self.setScreen ()
TypeError: 'NoneType' object is not subscriptable
Comment 1 Kir Kolyshkin 2011-07-01 04:52:18 EDT
Created attachment 510821 [details]
Attached traceback automatically from anaconda.
Comment 2 Radek Vykydal 2011-07-01 07:07:50 EDT
Please see https://bugzilla.redhat.com/show_bug.cgi?id=704188#c3 ("ipappend 2" should make pxe provide the BOOTIF= value).

*** This bug has been marked as a duplicate of bug 704188 ***

Note You need to log in before you can comment on or make changes to this bug.