Bug 704288 - [abrt] java-1.6.0-openjdk-1:1.6.0.0-52.1.9.7.fc14: os::abort: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.6.0-openjdk-1:1.6.0.0-52.1.9.7.fc14: os::abort: Process /usr/li...
Status: CLOSED DUPLICATE of bug 665249
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:cece7bb02d92ca1976d30573e4c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-12 13:05 EDT by kbzd76
Modified: 2011-05-13 19:32 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-13 12:43:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (81.78 KB, text/plain)
2011-05-12 13:05 EDT, kbzd76
no flags Details

  None (edit)
Description kbzd76 2011-05-12 13:05:55 EDT
abrt version: 1.1.18
architecture: x86_64
Attached file: backtrace, 83739 bytes
cmdline: /usr/bin/java -Xms128m -Xmx384m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -Dhttp.proxyHost=proxy.bercy.cp -Dhttp.proxyPort=3128 -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar -exitdata 8800a -vm /usr/bin/java -vmargs -Xms128m -Xmx384m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -Dhttp.proxyHost=proxy.bercy.cp -Dhttp.proxyPort=3128 -XX:MaxPermSize=256m -jar /usr
component: java-1.6.0-openjdk
Attached file: coredump, 457449472 bytes
crash_function: os::abort
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
kernel: 2.6.35.12-88.fc14.x86_64
package: java-1.6.0-openjdk-1:1.6.0.0-52.1.9.7.fc14
rating: 3
reason: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1302780963
uid: 500

How to reproduce
-----
1.Start Eclipse "Helios"
2.Import Project from directory
3.Annuler Import
Comment 1 kbzd76 2011-05-12 13:05:59 EDT
Created attachment 498590 [details]
File: backtrace
Comment 2 Deepak Bhole 2011-05-12 13:20:34 EDT
Error happened from Java_org_eclipse_swt_internal_gtk_OS__1g_1object_1get_1qdata(). Reassigning.
Comment 3 Severin Gehwolf 2011-05-12 17:35:11 EDT
What eclipse where you using? Could you provide output of the following commands:

http://fedoraproject.org/wiki/DebuggingEclipseProblems

Also output of:

$ rpm -qa | grep eclipse

Thanks!
Comment 4 kbzd76 2011-05-13 08:16:55 EDT
[root@localhost ~]# for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done
S.5....T.  c /etc/eclipse.ini
[root@localhost ~]# which java
/usr/bin/java
[root@localhost ~]# readlink -f `which java`
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
[root@localhost ~]# which javac
/usr/bin/javac
[root@localhost ~]# readlink -f `which javac`
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/bin/javac
[root@localhost ~]# java -version
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.7) (fedora-52.1.9.7.fc14-x86_64)
OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)
[root@localhost ~]# 



Output of : "rpm -qa | grep eclipse"

[root@localhost ~]# rpm -qa | grep eclipse
eclipse-platform-3.6.1-6.2.fc14.x86_64
eclipse-swt-3.6.1-6.2.fc14.x86_64
eclipse-jdt-3.6.1-6.2.fc14.x86_64
eclipse-rcp-3.6.1-6.2.fc14.x86_64
eclipse-nls-3.6.0.v20100814043401-2.fc14.noarch
eclipse-pde-3.6.1-6.2.fc14.x86_64
icu4j-eclipse-4.2.1-1.fc14.x86_64
tomcat5-jasper-eclipse-5.5.27-7.4.fc12.noarch
eclipse-nls-fr-3.6.0.v20100814043401-2.fc14.noarch
[root@localhost ~]#
Comment 5 Andrew Overholt 2011-05-13 08:46:05 EDT
(In reply to comment #4)
> [root@localhost ~]# for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f;
> done
> S.5....T.  c /etc/eclipse.ini

Do you know what's changed in this file?
Comment 6 kbzd76 2011-05-13 08:53:31 EDT
May be the proxy :

this the content of this file 

[root@localhost ~]# cat /etc/eclipse.ini
-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins

-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles

-Dhttp.proxyHost=proxy.bercy.cp
-Dhttp.proxyPort=3128

[root@localhost ~]# ll /etc/eclipse.ini

-rw-r--r-- 1 root root 1040 13 mai   14:44 /etc/eclipse.ini

[root@localhost ~]#
Comment 7 Andrew Overholt 2011-05-13 10:13:41 EDT
So you start Eclipse in Fedora 14, go to File->Import->(something) and it crashes?  Does it happen every time?  Can you provide more details about exactly what steps caused the crash?  Thanks.
Comment 8 kbzd76 2011-05-13 10:37:10 EDT
I can not start eclipse on my Laptop (Compacq 6510b) from that crash.
I have the splash screen that is displayed all the time and I am forced to kill -9 the process.

Maybe I need to remove and reinstall the product from the repo?
Comment 9 Chris Aniszczyk 2011-05-13 11:39:06 EDT
Can you launch ./eclipse with -debug? The log isn't giving us enough information to diagnose the problem :/
Comment 10 kbzd76 2011-05-13 12:20:11 EDT
Good eclipse work !!


this is the log after lunching "eclipse -debug" command



[MyUser@localhost ~]$ eclipse -debug
Start VM: /usr/bin/java
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-Dhttp.proxyHost=proxy.bercy.cp
-Dhttp.proxyPort=3128
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata d000f
-debug
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-Dhttp.proxyHost=proxy.bercy.cp
-Dhttp.proxyPort=3128
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar 
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/MyUser/.eclipse/793567567/configuration/
Configuration file:
    file:/home/MyUser/.eclipse/793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Loading extension: reference:file:../../../share/eclipse/dropins/babel/eclipse/plugins/org.eclipse.osgi.nl_fr_3.6.0.v20100814043401.jar
        eclipse.properties not found
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
    file:/usr/lib64/eclipse/plugins/
    file:/usr/lib64/eclipse/plugins/../../../share/eclipse/dropins/babel/eclipse/plugins/org.eclipse.osgi.nl_fr_3.6.0.v20100814043401.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/home/MyUser/.options not found
Time to load bundles: 61
Starting application: 3997
Application Started: 22279
[MyUser@localhost ~]$
Comment 11 Chris Aniszczyk 2011-05-13 12:43:12 EDT
Ok, how about adding a .options file in /usr/lib64/eclipse with this:
org.eclipse.equinox.p2.core/debug=true
org.eclipse.equinox.p2.core/reconciler=true

Then run with -debug, let's see if we can get some more information here.

Although I'm pretty sure you need to upgrade to F15 soon. I think you're bit by bug 665249
Comment 12 Chris Aniszczyk 2011-05-13 12:43:44 EDT
Actually I'm positive it's bug 665249 now looking at your versions of eclipse RPMs.

*** This bug has been marked as a duplicate of bug 665249 ***
Comment 13 kbzd76 2011-05-13 19:32:34 EDT
Test with .option and the two lines indicated bu Chris.




[MyUser@localhost eclipse]$ eclipse -debug
Start VM: /usr/bin/java
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata 50008
-debug
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar 
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/MyUser/.eclipse/793567567/configuration/
Configuration file:
    file:/home/MyUser/.eclipse/793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Loading extension: reference:file:../../../share/eclipse/dropins/babel/eclipse/plugins/org.eclipse.osgi.nl_fr_3.6.0.v20100814043401.jar
        eclipse.properties not found
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
    file:/usr/lib64/eclipse/plugins/
    file:/usr/lib64/eclipse/plugins/../../../share/eclipse/dropins/babel/eclipse/plugins/org.eclipse.osgi.nl_fr_3.6.0.v20100814043401.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/usr/lib64/eclipse/.options loaded
Time to load bundles: 60
Starting application: 4605
Application Started: 24668
[MyUser@localhost eclipse]$

Note You need to log in before you can comment on or make changes to this bug.