Bug 665249 - Eclipse won't load other plugins
Eclipse won't load other plugins
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Chris Aniszczyk
Fedora Extras Quality Assurance
: Reopened
: 683277 684472 704288 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-23 00:12 EST by Nathaniel McCallum
Modified: 2014-07-25 01:53 EDT (History)
18 users (show)

See Also:
Fixed In Version: eclipse-3.6.1-6.2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-31 15:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Eclipse debug info (5.65 KB, text/plain)
2011-02-21 07:24 EST, Tim Lauridsen
no flags Details
debug log from eclipse when pydev doesn't work (100.20 KB, text/x-log)
2011-05-19 21:16 EDT, Nathaniel McCallum
no flags Details
debug log (1.43 MB, text/x-log)
2011-05-20 16:22 EDT, Thomas Meyer
no flags Details
eclipse debug log from a F15 system (685.15 KB, application/octet-stream)
2011-05-20 19:06 EDT, Nathanael Noblet
no flags Details

  None (edit)
Description Nathaniel McCallum 2010-12-23 00:12:10 EST
Eclipse in rawhide doesn't seem to like plugins.  At the very least, CDT and pydev don't work.  I also get this in the log:

!ENTRY org.eclipse.equinox.p2.engine 4 4 2010-12-22 23:54:25.964
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2010-12-22 23:54:25.964
!MESSAGE session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null -->[R]org.eclipse.equinox.initializer 1.0.0.v20100503, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2010-12-22 23:54:25.964
!MESSAGE The artifact file for osgi.bundle,org.eclipse.equinox.initializer,1.0.0.v20100503 was not found.

Removing/reinstalling and clearing my ~/.eclipse and ~/workspace/.metadata didn't help, so this seems to be an issue in a clean install.
Comment 1 Alexander Kurtakov 2010-12-27 11:49:15 EST
Can you remove ~/.eclipse again and post the output of eclipse -clean -debug -consolelog here?
Comment 2 Alexander Kurtakov 2011-01-03 08:08:06 EST
Can you try eclipse-3.6.1-4.fc15 ?
Comment 3 Steven Hadfield 2011-01-10 10:58:55 EST
I was having the same problem of not all my plugins not showing up when installed from the repository. I tried the steps you described with the latest (3.6.1-4.fc15) and I receive the same message as he did before:


Start VM: /usr/bin/java
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata 4da0019
-clean
-debug
-consolelog
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar 
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/LETNET/stevenhadfield/.eclipse/org.eclipse.platform_3.6.1_793567567/configuration
Configuration file:
    file:/home/LETNET/stevenhadfield/.eclipse/org.eclipse.platform_3.6.1_793567567/config.ini not found or not read
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/home/LETNET/stevenhadfield/.options not found
Time to load bundles: 4
!SESSION 2011-01-10 09:53:41.311 -----------------------------------------------
eclipse.buildId=M20100909-0800
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -clean -debug -consolelog

!ENTRY org.eclipse.equinox.p2.engine 4 4 2011-01-10 09:54:05.612
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2011-01-10 09:54:05.612
!MESSAGE session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.equinox.initializer 1.0.0.v20100503, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2011-01-10 09:54:05.613
!MESSAGE The artifact file for osgi.bundle,org.eclipse.equinox.initializer,1.0.0.v20100503 was not found.
Starting application: 24325
Application Started: 32284
Comment 4 Steven Hadfield 2011-01-10 11:05:19 EST
Hm. When I ran eclipse again with the same parameters after doing that, many of the plugins show up (including PyDev as the original requester mentioned), but not all of them are showing up for me: specifically maven-eclipse-plugin which I was looking for.
Comment 5 Andrew Overholt 2011-01-10 11:08:36 EST
User-installed (ie. installed via the Eclipse update manager) plugins will go into ~/.eclipse so if that's how you installed maven-eclipse-plugin, it'll need to be re-installed.

If you installed maven-eclipse-plugin with an RPM that's still installed, I'd be curious to know if it works with a clean installation.

Have you looked at the rpm -qV output of the Eclipse RPMs?  Something like the first section here:

http://fedoraproject.org/wiki/DebuggingEclipseProblems
Comment 6 Tim Lauridsen 2011-02-21 07:24:44 EST
Created attachment 479883 [details]
Eclipse debug info

I have the same problem in a fresh installed F15 Alpha TC2 with all updates.

The extra plugins like pydev, cdt etc don't turn up inside eclipse.

Check attachment for more info
Comment 7 Alexander Kurtakov 2011-02-23 04:53:23 EST
(In reply to comment #4)
> Hm. When I ran eclipse again with the same parameters after doing that, many of
> the plugins show up (including PyDev as the original requester mentioned), but
> not all of them are showing up for me: specifically maven-eclipse-plugin which
> I was looking for.

Wait, wait, wait - maven-eclipse-plugin is Maven plugin not Eclipse plugin that's why it is not going to show in Eclipse ever. See http://maven.apache.org/plugins/maven-eclipse-plugin/ for details. The Eclipse plugin for Maven is called http://m2eclipse.sonatype.org/ m2eclipse but it is not packaged, feel free to do so.
Comment 8 Orion Poplawski 2011-03-09 11:02:28 EST
Same here.  Seems to pick up cvs and team from eclipse-platform, but not anything else (CDT, subclipse, ptp, etc).
Comment 9 Andrew Overholt 2011-03-09 11:06:48 EST
I saw something in a local eclipse-build build where o.e.ant.source ended up in dropins/sdk and not dropins/jdt ... Alex, do you think this is the cause?
Comment 10 Orion Poplawski 2011-03-09 11:07:40 EST
I get:

!SESSION 2011-03-09 09:06:09.882 -----------------------------------------------
eclipse.buildId=M20100909-0800
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -clean -debug -consolelog

!ENTRY org.eclipse.equinox.p2.engine 4 4 2011-03-09 09:06:24.226
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.engine 4 0 2011-03-09 09:06:24.226
!MESSAGE session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.ant.core.source 3.2.200.v20100427, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.AddSourceBundleAction).
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2011-03-09 09:06:24.230
!MESSAGE The artifact file for osgi.bundle,org.eclipse.ant.core.source,3.2.200.v20100427 was not found.
Starting application: 14389
Comment 11 Orion Poplawski 2011-03-09 11:28:44 EST
If I install eclipse-pde (which has org.eclipse.ant.core.source) everything works.
Comment 12 Orion Poplawski 2011-03-09 11:30:03 EST
*** Bug 683277 has been marked as a duplicate of this bug. ***
Comment 13 Alexander Kurtakov 2011-03-09 11:30:55 EST
Hmm, I can't believe that source bundle can be the problem.
Comment 14 Orion Poplawski 2011-03-09 11:47:03 EST
It may not be the only thing I suppose.  But removing eclipse-pde, eclipse-jdt and the other deps they brought in and cleaning out .eclipse got me back to a non-working state.
Comment 15 Orion Poplawski 2011-03-09 11:50:37 EST
Moving ant.core.source to /usr/lib64/eclipse/plugins to keep it around, not gets me:

!MESSAGE The artifact file for osgi.bundle,org.eclipse.ant.launching,1.0.0.v20100427 was not found.

so it's not the only thing.  Are these supposed to be loaded by default?  Can we figure out what is trying to load them and add proper deps?
Comment 16 tuxor 2011-03-16 07:55:50 EDT
Go to Help->Install New Software and click on the "already installed" hyperlink. You will get a list of the installed plugins including C/C++, Android or whatever you installed.

It must have something to do with these error messages, don't you agree?

CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Comment 17 tuxor 2011-03-16 09:18:58 EDT
I installed upstream package from eclipse.org and it works just fine without any further configuration. So why doesn't this package work as well? 
(btw in the upstream package, I'm not suffering from the quoted errors when starting eclipse from a terminal)
Comment 18 Andrew Overholt 2011-03-16 09:56:09 EDT
(In reply to comment #16)
> It must have something to do with these error messages, don't you agree?
> 
> CompilerOracle: exclude

No, those are just coming from the JIT excludes we have in eclipse.ini.  They are workarounds for OpenJDK bugs.

(In reply to comment #17)
> I installed upstream package from eclipse.org and it works just fine without
> any further configuration. So why doesn't this package work as well? 

:)  It's an entirely different situation.

> (btw in the upstream package, I'm not suffering from the quoted errors when
> starting eclipse from a terminal)

You'll notice that eclipse.ini is different in this case.
Comment 19 Aidan Delaney 2011-03-16 11:26:02 EDT
*** Bug 684472 has been marked as a duplicate of this bug. ***
Comment 20 Aidan Delaney 2011-03-16 13:52:30 EDT
Running eclipse-platform-3.6.1-5.fc15.x86_64 and deleting the ~/.eclipse directory does not fix this issue.  No PyDev, CDT, egit etc... plugins work.

eclipse -consoleout -debug > eclipse.log gives the following

CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/aidan/.eclipse/org.eclipse.platform_3.6.1_793567567/configuration/
Configuration file:
    file:/home/aidan/.eclipse/org.eclipse.platform_3.6.1_793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/home/aidan/.options not found
Time to load bundles: 6
Starting application: 6281
Application Started: 11598
Start VM: /usr/bin/java
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata 570013
-consoleout
-debug
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
Comment 21 Andrew Overholt 2011-03-16 14:42:27 EDT
Adrian, do things show up if you install eclipse-pde?
Comment 22 Andrew Overholt 2011-03-16 14:42:43 EDT
Sorry, s/Adrian/Aidan/ :)
Comment 23 Aidan Delaney 2011-03-16 16:02:48 EDT
Bingo.  Installing eclipse-pde works.  Looks like there's something in the -pde package that should be in -platform.
Comment 24 Aidan Delaney 2011-03-16 16:23:14 EDT
And for comparison
 eclipse -consoleout -debug
Start VM: /usr/bin/java
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata 560012
-consoleout
-debug
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar 
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/aidan/.eclipse/org.eclipse.platform_3.6.1_793567567/configuration/
Configuration file:
    file:/home/aidan/.eclipse/org.eclipse.platform_3.6.1_793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/home/aidan/.options not found
Time to load bundles: 5
^C
[aidan@SillyFace ~]$ eclipse -consoleout -debug > eclipse.log
[aidan@SillyFace ~]$ gedit eclipse.log 
Gtk-Message: Failed to load module "pk-gtk-module"
^C
[aidan@SillyFace ~]$ eclipse -consoleout -debug
Start VM: /usr/bin/java
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata 660013
-consoleout
-debug
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx512m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar 
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/aidan/.eclipse/org.eclipse.platform_3.6.1_793567567/configuration/
Configuration file:
    file:/home/aidan/.eclipse/org.eclipse.platform_3.6.1_793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/home/aidan/.options not found
Time to load bundles: 4
Starting application: 1859
Application Started: 10155
Comment 25 Fabian Deutsch 2011-03-17 03:43:25 EDT
Adding -pde also helped. pydev was found again.
Comment 26 Fabian Deutsch 2011-03-17 05:18:20 EDT
I also noticed that the plugins are just loaded on the second loading of eclipse after.
So:
1. Remove workspace and ~/.eclipse
2. Install eclipse, -pydev and -pde
3. Start eclipse - no (pydev) plugins
4. close eclipse
5. start eclipse - pydev plugin available
Comment 27 Andrew Overholt 2011-03-17 09:20:53 EDT
(In reply to comment #26)
> I also noticed that the plugins are just loaded on the second loading of
> eclipse after.

Yes, I've noticed this as well.  It seems to be some issue with the dropins reconciler in 3.6.x but I haven't had time to track it down yet.
Comment 28 tuxor 2011-03-21 17:34:16 EDT
I can confirm this for the cdt-plugin: It won't show up until the second start after the install via yum! And it requires eclipse-pde.
Comment 29 Dominick Grift 2011-03-22 07:41:40 EDT
I can also confirm that eclipse-pde is required for the plugins. I cannot confirm that a "second start" is required. It worked for me right after i installed eclipse-pde. But i installed pde right after i rebooted so eclipse had not been used yet in this session.
Comment 30 Andrew Overholt 2011-03-22 14:46:47 EDT
Can those people with the "second start" problem specify their architecture, please?
Comment 31 tuxor 2011-03-22 14:51:41 EDT
x86_64
Comment 32 Fabian Deutsch 2011-03-22 16:12:53 EDT
same for me, x86_64
Comment 33 Alexander Kurtakov 2011-03-30 09:30:01 EDT
Reassigning to Chris.
Comment 34 Chris Aniszczyk 2011-03-31 18:24:21 EDT
I investigated this a bit... with CDT at least... getting some strange errors while watching the dropins reconciler...


!ENTRY org.eclipse.equinox.p2.director 2 0 2011-03-31 17:22:55.928
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-03-31 17:22:55.929
!MESSAGE Unable to satisfy dependency from org.eclipse.cdt.launch.remote.feature.group 6.0.0.201009241320 to org.eclipse.cdt.launch.remote.source [2.2.0.201009241320].

!ENTRY org.eclipse.equinox.p2.director 2 0 2011-03-31 17:22:56.233
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-03-31 17:22:56.233
!MESSAGE Unable to satisfy dependency from org.eclipse.cdt.launch.remote.feature.group 6.0.0.201009241320 to org.eclipse.cdt.launch.remote.source [2.2.0.201009241320].

!ENTRY org.eclipse.equinox.p2.director 2 0 2011-03-31 17:22:56.346
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-03-31 17:22:56.346
!MESSAGE Unable to satisfy dependency from org.eclipse.cdt.launch.remote.feature.group 6.0.0.201009241320 to org.eclipse.cdt.launch.remote.source [2.2.0.201009241320].
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-03-31 17:22:56.346
!MESSAGE Unable to satisfy dependency from org.eclipse.cdt.launch.remote.feature.group 6.0.0.201009241320 to org.eclipse.cdt.launch.remote.source [2.2.0.201009241320].
Comment 35 Chris Aniszczyk 2011-04-04 10:19:28 EDT
Ok, the previous issues I had were from a bad local profile. In essence, my fedora Eclipse install was hosed from messing with it earlier with the p2 director.

I'm having issues reproducing this with a vanilla Eclipse setup.

This means, nothing in ~/.eclipse and /usr/lib/eclipse

yum install eclipse-pydev

PyDev is there, some things aren't working.

yum install eclipse-cdt

CDT is there, things aren't working.

Looks to stem from a missing 'org.eclipse.ant.launching'

!ENTRY org.eclipse.equinox.p2.director 2 0 2011-04-04 09:14:06.943
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-04-04 09:14:06.943
!MESSAGE Unable to satisfy dependency from org.eclipse.cdt.launch.remote.feature.group 6.0.0.201009241320 to org.eclipse.cdt.launch.remote.source [2.2.0.201009241320].
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-04-04 09:14:06.943
!MESSAGE Unable to satisfy dependency from org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX to org.eclipse.ant.launching [1.0.0.v20100427].
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2011-04-04 09:14:06.943
!MESSAGE Unable to satisfy dependency from org.eclipse.ant.ui 3.5.0.v20100427 to bundle org.eclipse.ant.launching [1.0.0,2.0.0).

org.eclipse.ant.launching should ship with JDT... which I guess we're simply just missing it from the list?
Comment 36 Chris Aniszczyk 2011-04-04 12:58:03 EDT
This doesn't happen with the 3.6.2 version of eclipse which will ship with F15 eventually...

http://koji.fedoraproject.org/koji/buildinfo?buildID=233336

I'll spin a small fix for F14 for now.
Comment 37 Chris Aniszczyk 2011-04-04 14:03:30 EDT
It's fixed in RAWHIDE and also in f14 now.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2972519
Comment 38 Orion Poplawski 2011-04-04 14:07:52 EDT
ETA on F15 fix?
Comment 39 Andrew Overholt 2011-04-04 14:15:55 EDT
Chris, an update may be required at this point in the F15 cycle:

http://fedoraproject.org/wiki/PackageMaintainers/Join#Submit_Package_as_Update_in_Bodhi
Comment 40 Orion Poplawski 2011-04-04 14:23:01 EDT
Yes, you will need to build for F15 and push an update.
Comment 41 Fedora Update System 2011-04-04 14:44:25 EDT
eclipse-3.6.1-6.2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/eclipse-3.6.1-6.2.fc14
Comment 42 Fedora Update System 2011-04-12 17:29:26 EDT
eclipse-3.6.1-6.2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 43 Nathanael Noblet 2011-04-14 11:31:38 EDT
Well this broke all my plugins!... usually I can get it back with eclipse -clean from the command line. I've lost all plugins.

CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
Install location:
    file:/usr/lib64/eclipse/
Configuration file:
    file:/usr/lib64/eclipse/configuration/config.ini loaded
Configuration location:
    file:/home/gnat/.eclipse/793567567/configuration/
Configuration file:
    file:/home/gnat/.eclipse/793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.6.1.R36x_v20100806.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.6.1.r361_v20100714-0800/splash.bmp
Debug options:
    file:/home/gnat/.options not found
Time to load bundles: 3
Starting application: 7499
Application Started: 10181
Start VM: /usr/bin/java
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-exitdata 1138020
-clean
-consoleout
-debug
-vm /usr/bin/java
-vmargs
-Xms128m
-Xmx384m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles
-XX:MaxPermSize=256m
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
Comment 44 Nathanael Noblet 2011-04-14 11:37:50 EDT
most annoyingly - downgrading eclipse doesn't fix the issues!!! :(
Comment 45 Chris Aniszczyk 2011-04-14 11:48:23 EDT
Can you post some log information?

Also, can you ensure ~/.eclipse is deleted when you re-install?

It would help if you have created a '.options' file on /usr/lib/eclipse with this in it...

org.eclipse.equinox.p2.core/debug=true
org.eclipse.equinox.p2.core/reconciler=true

When you launch Eclipse, you can pass ./eclipse -debug -console -consoleLog

You should get log information that would be useful to us!

Sorry for the trouble.
Comment 46 Nathanael Noblet 2011-04-14 13:56:47 EDT
If I remove .eclipse what settings do I lose? just where my workspace is? I hope I'm not going to lose editor settings and such, they're a huge pain to setup all the time. Any ideas?
Comment 47 tuxor 2011-04-14 14:04:03 EDT
How about not deleting it but renaming or moving it? So you will be able to restore it after testing, if it didn't work out well anyway.
Comment 48 Nathanael Noblet 2011-04-14 14:10:55 EDT
So I've removed it, and any fedora installed plugins are working - however eclipse installed ones namely pdt, an xml editor orange something or other, and a yaml plugin all fail or don't even show up now (I presume that .eclipse holds the repositories since they aren't in the list anymore either).

I'll just re-install them. Sometimes eclipse really drives me nuts
Comment 49 Severin Gehwolf 2011-04-14 14:52:27 EDT
(In reply to comment #48)
> So I've removed it, and any fedora installed plugins are working - however
> eclipse installed ones namely pdt, an xml editor orange something or other, and
> a yaml plugin all fail or don't even show up now (I presume that .eclipse holds
> the repositories since they aren't in the list anymore either).

Since the installation directory of eclipse in Fedora is read-only for the Eclipse installer (p2), it resorts to installing plug-ins into your home directory under ~/.eclipse. Since you just removed/renamed it, you unfortunately lose plug-ins which you installed via p2. Sorry, there is no real good way around this.

FWIW, upstream eclipse does not support platform upgrades either.

> I'll just re-install them. Sometimes eclipse really drives me nuts

It's less frustrating once you know better what's going on. Sorry about this. We are trying hard to improve this experience. Sometimes seemingly trivial things aren't that easy to solve though...
Comment 50 Chris Aniszczyk 2011-05-13 12:43:44 EDT
*** Bug 704288 has been marked as a duplicate of this bug. ***
Comment 51 Dominick Grift 2011-05-14 09:00:09 EDT
Is this "fix" applied to rawhide (f16) as well? I am asking because i am not able to use plugins in eclipse on rawhide even if i install eclipse-pde.
Comment 52 Dominick Grift 2011-05-15 14:36:50 EDT
Never mind downgrading lucene fixed it for me: #702161
Comment 53 Nathaniel McCallum 2011-05-19 20:58:47 EDT
So this seems to be broken still.  I am on a clean install of f15. I see this problem with all plugins, but I'll stick to pydev right now since it seems to be the easiest to reproduce.

I did: sudo yum install eclipse-pydev.

$ sudo yum -q list installed '*eclipse*'
Installed Packages
eclipse-platform.x86_64       1:3.6.2-5.fc15  @fedora
eclipse-pydev.x86_64          1:1.6.5-1.fc15  @fedora
eclipse-rcp.x86_64            1:3.6.2-5.fc15  @fedora
eclipse-swt.x86_64            1:3.6.2-5.fc15  @fedora
icu4j-eclipse.x86_64          1:4.2.1-2.fc15  @fedora
tomcat5-jasper-eclipse.noarch 5.5.31-3.fc15   @fedora

pydev is listed in Help->About Eclipse Platform->Installation Details->Installed Software.  But the Python perspective is missing.  I will attach the output of eclipse -clean -debug -consolelog.
Comment 54 Nathaniel McCallum 2011-05-19 21:16:17 EDT
Created attachment 499970 [details]
debug log from eclipse when pydev doesn't work
Comment 55 Andrew Overholt 2011-05-20 08:18:30 EDT
Please paste the output of:

rpm -q tomcat6-\* lucene

Thanks.
Comment 56 Nathaniel McCallum 2011-05-20 08:33:19 EDT
$ rpm -q tomcat6-\* lucene
package tomcat6-* is not installed
lucene-2.9.4-4.fc15.noarch
Comment 57 Nathaniel McCallum 2011-05-20 08:41:11 EDT
$ rpm -qa tomcat6-*
tomcat6-servlet-2.5-api-6.0.32-1.fc15.noarch
tomcat6-jsp-2.1-api-6.0.32-1.fc15.noarch
Comment 58 Nathaniel McCallum 2011-05-20 08:45:53 EDT
downgrading those packages to the versions from updates (not updates-testing) does fix the problem (at least for pydev, I'm testing cdt now).

tomcat6-servlet-2.5-api-6.0.30-6.fc15.noarch
tomcat6-jsp-2.1-api-6.0.30-6.fc15.noarch
Comment 59 Nathaniel McCallum 2011-05-20 09:12:13 EDT
CDT works too.  Is there some way to make this less fragile?
Comment 60 Andrew Overholt 2011-05-20 09:29:58 EDT
The only way I can think of that will make this less fragile is to have hard-coded version-release #s in our Requires in eclipse*.spec.  The problem in this case was that tomcat6 went out with updated OSGi metadata and the maintainer forgot to inform us to rebuild Eclipse with it and against it.

FWIW, that tomcat6 update that you saw in updates-testing got enough negative karma to be stopped from being pushed to updates.  I don't know how to get it out of updates-testing.
Comment 61 Thomas Meyer 2011-05-20 16:22:45 EDT
Created attachment 500136 [details]
debug log

My Java perspective is gone! Debug log attached. Seems to be some DE translation thing?
Comment 62 Andrew Overholt 2011-05-20 17:06:23 EDT
Chris, any idea what's up with Thomas' problem?
Comment 63 Nathanael Noblet 2011-05-20 17:49:59 EDT
I've just upgraded from F14 to F15... No plugins are loaded. I have these installed


eclipse-jgit-0.11.3-1.fc15.noarch
eclipse-gef-3.6.2-1.fc15.noarch
eclipse-subclipse-1.6.17-1.fc15.noarch
eclipse-emf-2.6.0-2.fc14.noarch
eclipse-rpm-editor-0.6.0-2.fc15.x86_64
eclipse-pydev-1.6.5-1.fc15.x86_64
eclipse-jdt-3.6.2-5.fc15.x86_64
eclipse-platform-3.6.2-5.fc15.x86_64
eclipse-changelog-2.6.7-7.fc15.x86_64
eclipse-cdt-7.0.2-1.fc15.x86_64
eclipse-rse-3.2-3.fc15.noarch
eclipse-egit-0.11.3-2.fc15.noarch
eclipse-svnkit-1.3.4-2.fc15.noarch
eclipse-fedorapackager-0.1.12-1.fc15.noarch
eclipse-swt-3.6.2-5.fc15.x86_64
eclipse-rcp-3.6.2-5.fc15.x86_64

File -> New -> Project lists cvs and one other. eclipse --clean does nothing. Also when it first started it asked for where my workspace was again even though previously it would not as I had set the 'use as default' checkbox
Comment 64 Nathanael Noblet 2011-05-20 18:40:36 EDT
Also in re-reading the thread, installing eclipse-pde doesn't help.

Finally, I have these tomcat packages installed:

tomcat6-jsp-2.1-api-6.0.32-2.fc15.noarch
tomcat6-servlet-2.5-api-6.0.32-2.fc15.noarch

No previous version is available
Comment 65 Nathanael Noblet 2011-05-20 19:04:31 EDT
One final note before I'm done for the day.

I did yum remove tomcat6* which removed all tomcat, eclipse etc packages.

rm -rf .eclipse

yum --enablerepo=updates-testing install eclipse-pydev eclipse-subclipse eclipse-egit eclipse-fedorapackager

started eclipse, chose a clean unused workspace. Tried to create a project, and could only pick CVS and General.

yum installed the following:

May 20 17:00:32 Installed: tomcat6-servlet-2.5-api-6.0.32-2.fc15.noarch
May 20 17:00:33 Installed: tomcat6-jsp-2.1-api-6.0.32-2.fc15.noarch
May 20 17:00:33 Installed: javamail-1.4.3-6.fc15.noarch
May 20 17:00:34 Installed: ant-javamail-1.8.2-3.fc15.noarch
May 20 17:00:35 Installed: axis-1.4-8.fc15.noarch
May 20 17:00:36 Installed: 1:mx4j-3.0.1-12.fc15.noarch
May 20 17:00:37 Installed: jetty-6.1.26-5.fc15.noarch
May 20 17:00:38 Installed: bsf-2.4.0-9.fc15.noarch
May 20 17:00:38 Installed: ant-apache-bsf-1.8.2-3.fc15.noarch
May 20 17:00:40 Installed: 1:hsqldb-1.8.1.3-3.fc15.noarch
May 20 17:00:40 Installed: ws-jaxme-0.5.1-7.fc15.noarch
May 20 17:00:41 Installed: xmlrpc3-common-3.1.3-5.fc15.noarch
May 20 17:00:41 Installed: xmlrpc3-client-3.1.3-5.fc15.noarch
May 20 17:00:42 Installed: xmlrpc3-server-3.1.3-5.fc15.noarch
May 20 17:00:44 Installed: jython-2.2.1-5.7.fc15.noarch
May 20 17:00:45 Installed: tomcat5-jasper-eclipse-5.5.31-3.fc15.noarch
May 20 17:00:50 Installed: 1:eclipse-platform-3.6.2-5.fc15.x86_64
May 20 17:00:51 Installed: 1:eclipse-changelog-2.6.7-7.fc15.x86_64
May 20 17:00:52 Installed: eclipse-rpm-editor-0.6.0-2.fc15.x86_64
May 20 17:00:53 Installed: eclipse-jgit-0.11.3-1.fc15.noarch
May 20 17:00:54 Installed: eclipse-egit-0.11.3-2.fc15.noarch
May 20 17:00:54 Installed: eclipse-svnkit-1.3.4-2.fc15.noarch
May 20 17:00:55 Installed: eclipse-subclipse-1.6.17-1.fc15.noarch
May 20 17:00:56 Installed: eclipse-fedorapackager-0.1.12-1.fc15.noarch
May 20 17:00:59 Installed: 1:eclipse-pydev-1.6.5-1.fc15.x86_64

I will attach a debug log as well
Comment 66 Nathanael Noblet 2011-05-20 19:06:06 EDT
Created attachment 500150 [details]
eclipse debug log from a F15 system
Comment 67 Chris Aniszczyk 2011-05-23 15:21:55 EDT
Please don't enable --enablerepo=updates-testing

May 20 17:00:32 Installed: tomcat6-servlet-2.5-api-6.0.32-2.fc15.noarch
May 20 17:00:33 Installed: tomcat6-jsp-2.1-api-6.0.32-2.fc15.noarch

We don't want those to ship.

You should get this...


[zx@lightning jgit]$ koji latest-pkg dist-f15 tomcat6
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
tomcat6-6.0.30-6.fc15                     dist-f15              dknox

Don't enable updates-testing as tomcat6-servlet-2.5-api-6.0.32-2 isn't part of F15 officially and was a mistake.
Comment 68 Nathanael Noblet 2011-05-23 16:13:10 EDT
Makes no difference. I've installed the 6.0.30-6 and nothing has changed. rm -rf .eclipse && eclipse -clean
Comment 69 Chris Aniszczyk 2011-05-23 16:25:22 EDT
Can you do this command and paste the results?

 diff -u `find /usr/lib/eclipse -name bundles.info` `find ~/.eclipse -name bundles.info` | grep ^-
Comment 70 Nathanael Noblet 2011-05-23 16:51:05 EDT
find ~/.eclipse -name bundles.info returns nothing
find /usr/lib64/eclipse -name bundles.info has only
/usr/lib64/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
Comment 71 Chris Aniszczyk 2011-05-23 17:13:41 EDT
Ahhh, you're on x86_64, so do this instead (after Eclipse is installed and launched)

diff -u `find /usr/lib64/eclipse -name bundles.info` `find ~/.eclipse -name
bundles.info` | grep ^-
Comment 72 Nathanael Noblet 2011-05-23 17:36:51 EDT
No change. If you re-read my previous comment its still the same. Meaning that

find ~/.eclipse -name bundles.info returns nothing (just back to a prompt no files)

find /usr/lib64/eclipse has only that one file

/usr/lib64/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info

This is before, during, and after eclipse runs
Comment 73 Andrew Overholt 2011-05-24 10:54:12 EDT
Eclipse will create a bundles.info file in ~/.eclipse on the first launch.  Are you sure you ran that find command after launching Eclipse at least once (and noticing that no plugins other than a basic set are loaded)?
Comment 74 Nathanael Noblet 2011-05-24 12:15:36 EDT
Unfortunately 100% positive. Unless the following is wrong. This was generated by running 'script' which logs everything.

Script started on Tue 24 May 2011 10:13:31 AM MDT
[gnat@iridium ~]$ find ~/.eclipse -name bundles.info
[gnat@iridium ~]$ eclipse --clean &
[1] 22889
[gnat@iridium ~]$ CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles

[gnat@iridium ~]$ find ~/.eclipse -name bundles.info
[gnat@iridium ~]$ 
[1]+  Done                    eclipse --clean
[gnat@iridium ~]$ find ~/.eclipse -name bundles.info
[gnat@iridium ~]$ exit
exit

Script done on Tue 24 May 2011 10:14:25 AM MDT
Comment 75 Nathanael Noblet 2011-05-24 12:18:31 EDT
also - since I couldn't get eclipse working, and need it working, I've downloaded the 3.6.2 tarball available from eclipse, and have been using that with that same .eclipse directory. All the plugins work fine that way (though they aren't using the system versions obviously). 

Once I can get this working I'll remove my local user copy. Unfortunately I need it for work so its a touch urgent (which also means that I'm available to do whatever you want for the next 5 hours). Just so you know I'm a motivated bug reporter is all. :)
Comment 76 Andrew Overholt 2011-05-24 13:32:51 EDT
Thanks for all the help, Nathanael :)  When you have time, can you paste the output of rpm -qaV eclipse-* here?
Comment 77 Alexander Kurtakov 2011-05-24 13:37:49 EDT
and also your icu4j, jetty, sat4j and objectweb-asm versions?
Btw, do you have any third party repo enabled? (e.g. jpackage)
Comment 78 Nathanael Noblet 2011-05-24 13:44:55 EDT
Script started on Tue 24 May 2011 11:43:17 AM MDT
[gnat@iridium ~]$ rpm -qa eclipse-*
eclipse-jgit-0.11.3-1.fc15.noarch
eclipse-rpm-editor-0.6.0-2.fc15.x86_64
eclipse-pydev-1.6.5-1.fc15.x86_64
eclipse-egit-0.11.3-2.fc15.noarch
eclipse-changelog-2.6.7-7.fc15.x86_64
eclipse-fedorapackager-0.1.12-1.fc15.noarch
eclipse-platform-3.6.2-5.fc15.x86_64
eclipse-subclipse-1.6.17-1.fc15.noarch
eclipse-swt-3.6.2-5.fc15.x86_64
eclipse-rcp-3.6.2-5.fc15.x86_64
eclipse-svnkit-1.3.4-2.fc15.noarch
[gnat@iridium ~]$ rpm -qaV eclipse-*
[gnat@iridium ~]$ rpm -V eclipse-platform
[gnat@iridium ~]$ rpm -q icu4j jetty sat4j objectweb-asm
package icu4j is not installed
jetty-6.1.26-5.fc15.noarch
sat4j-2.3.0-2.fc15.noarch
objectweb-asm-3.2-3.fc15.noarch
[gnat@iridium ~]$ rpm -qa icu*
icu4j-eclipse-4.2.1-2.fc15.x86_64
[gnat@iridium ~]$ exit


Script done on Tue 24 May 2011 11:44:09 AM MDT
Comment 79 Nathanael Noblet 2011-05-24 13:45:36 EDT
PS I'm also in IRC #fedora-devel under the nick gnat42 if you want to 'speed it up' otherwise this is fine too ;)
Comment 80 Andrew Overholt 2011-05-24 15:43:30 EDT
Nathanael very patiently helped me go through common causes of these errors via IRC.  Unfortunately we were unable to figure out what had happened :(  My best recommendation at this point is that we move off of dropins ASAP.
Comment 81 Andreas Girgensohn 2011-07-09 14:16:40 EDT
A new Tomcat version is in testing and needs more karma (bug 677414).  Maybe somebody could check if it addresses any of the Eclipse problems.
Comment 82 Fabian Deutsch 2011-08-31 15:27:29 EDT
This issue did not occur to me for some time. 
Can we close this?
Comment 83 tuxor 2011-08-31 15:34:52 EDT
That's fine with me!

It works for me, too (for quite a long time now).
Comment 84 Andrew Overholt 2011-08-31 15:51:09 EDT
Okay, I'll close it WORKSFORME and we can open other bugs for specific issues.

FWIW Sami Wagiaalla is looking into stopping the use of the dropins reconciler at startup time and forcing the plugin installation (in the Eclipse sense) to occur at RPM installation time.  This should hopefully alleviate many of these issues.
Comment 85 Dominick Grift 2011-08-31 15:55:40 EDT
I also noticed this issue on rhel6s' eclipse suite when i tried it a while ago. But on Fedora it works for me now as well.
Comment 86 qbnronin 2011-11-10 11:51:45 EST
New to Fedora, having this issue. I have tried installing Indigo and Helios and they both behave the same way. Not sure why this bug is closed without a resolution. 

Also it seems that installing eclipse-pde has worked for some. Can someone please explain the best way to install eclipse-pde?
Comment 87 qbnronin 2011-11-10 11:58:25 EST
(In reply to comment #86)
> New to Fedora, having this issue. I have tried installing Indigo and Helios and
> they both behave the same way. Not sure why this bug is closed without a
> resolution. 
> 
> Also it seems that installing eclipse-pde has worked for some. Can someone
> please explain the best way to install eclipse-pde?

Sorry I forgot to add that, I don't see a list of software from the Available Software window. When I add http://download.eclipse.org/releases/helios/ I get the pending prompt but nothing else.
Comment 88 Andrew Overholt 2011-11-17 13:18:08 EST
(In reply to comment #86)
> New to Fedora, having this issue. I have tried installing Indigo and Helios and
> they both behave the same way.

Please provide more details.  Did you yum install or use a download from eclipse.org?

> Also it seems that installing eclipse-pde has worked for some. Can someone
> please explain the best way to install eclipse-pde?

yum install eclipse-pde

Note You need to log in before you can comment on or make changes to this bug.