Bug 704298 - Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/avalon/framework/configuration/ConfigurationException
Summary: Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/avalon/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fop
Version: 15
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Ruediger Landmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 494832
TreeView+ depends on / blocked
 
Reported: 2011-05-12 17:36 UTC by Frank Ch. Eigler
Modified: 2011-09-25 03:30 UTC (History)
10 users (show)

Fixed In Version: fop-1.0-17.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-25 03:30:50 UTC


Attachments (Terms of Use)
tarball containing stap docs (1.39 MB, application/x-gzip)
2011-05-12 17:36 UTC, Frank Ch. Eigler
no flags Details

Description Frank Ch. Eigler 2011-05-12 17:36:21 UTC
Created attachment 498596 [details]
tarball containing stap docs

While building systemtap docs on a rawhide instance, the following error results
while running publican/fop.  It aborts the pdf build process.

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/avalon/framework/configuration/ConfigurationException
	at org.apache.fop.apps.FopFactory.<init>(FopFactory.java:153)
	at org.apache.fop.apps.FopFactory.newInstance(FopFactory.java:177)
	at org.apache.fop.cli.CommandLineOptions.<init>(CommandLineOptions.java:121)
	at org.apache.fop.cli.Main.startFOP(Main.java:157)
	at org.apache.fop.cli.Main.main(Main.java:204)
Caused by: java.lang.ClassNotFoundException: org.apache.avalon.framework.configuration.ConfigurationException
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
	... 5 more
	Finished pdf

Run "publican build --formats=pdf --langs=en-US" in the attached tarball's
top level directory to reproduce.

There appear to be no missing rpm dependencies:
% rpm -qa publican\*  fop\* avalon\* java\* \*pdf\* docbook\* batik\* xalan\* xml\*  |sort

avalon-framework-4.3-3.fc16.noarch
avalon-logkit-2.1-5.fc16.noarch
batik-1.7-11.fc16.noarch
batik-ttf2svg-1.7-11.fc16.noarch
docbook-dtds-1.0-54.fc15.noarch
docbook-style-xsl-1.76.1-2.fc15.noarch
fop-1.0-14.fc16.noarch
java-1.6.0-openjdk-1.6.0.0-57.1.10.1.fc15.x86_64
java-1.6.0-openjdk-devel-1.6.0.0-57.1.10.1.fc15.x86_64
java_cup-0.11a-6.fc15.noarch
publican-2.5-2.fc16.noarch
publican-fedora-2.0-0.fc15.noarch
xalan-j2-2.7.1-3.fc15.noarch
xml-common-0.6.3-34.fc15.noarch
xml-commons-apis-1.4.01-4.fc16.noarch
xml-commons-resolver-1.2-7.fc15.noarch
xmlgraphics-commons-1.4-3.noarch
xmlrpc-c-1.26.0-1600.svn2188.fc16.x86_64
xmlrpc-c-client-1.26.0-1600.svn2188.fc16.x86_64
xmltex-20020625-17.fc15.noarch
xmlto-0.0.23-4.fc15.x86_64
xmlto-tex-0.0.23-4.fc15.noarch

Comment 1 David Le Sage 2011-05-13 01:37:40 UTC
Rudi, FWIW, I can produce this error too running fop-0.95-5.fc14.noarch.

Comment 2 Ruediger Landmann 2011-05-13 03:11:36 UTC
(In reply to comment #1)
> Rudi, FWIW, I can produce this error too running fop-0.95-5.fc14.noarch.

Strange; works fine for me with 0.95-5 and 1.0-13 on Fedora 14.

Frank, David, can you produce other PDFs with Publican? or is the problem confined to this particular book?

A simple test case if you have nothing else handy:
http://git.fedorahosted.org/git/?p=docs/readme-burning-isos.git

Comment 3 David Le Sage 2011-05-13 03:24:12 UTC
G'day Rudi,


Happens with PDFs of all books on Fed 15 (publican-2.5-2.fc15.noarch) but does not happen when attempted on the same books with Fed 14, so maybe it is something Jeff changed.  I will try to isolate it in one of my books if I have time later (but I am on a training course next week.)


Thanks,

Comment 4 Frank Ch. Eigler 2011-05-13 12:24:23 UTC
Interestingly, on another less up-to-date rawhide machine, i686 this time,
fop works on the same document sources:

% rpm -qa publican\*  fop\* avalon\* java\* \*pdf\* docbook\* batik\* xalan\* xml\*|sort

avalon-framework-4.1.4-7.fc15.noarch
batik-1.7-9.fc15.noarch
docbook-dtds-1.0-53.fc14.noarch
docbook-style-xsl-1.76.1-1.fc15.noarch
fop-0.95-5.fc14.noarch
java-1.5.0-gcj-1.5.0.0-35.fc15.i686
java-1.6.0-openjdk-1.6.0.0-49.1.9.3.fc15.i686
java_cup-0.11a-5.fc15.noarch
publican-2.5-2.fc16.noarch
publican-fedora-2.0-0.fc15.noarch
xalan-j2-2.7.1-2.fc15.noarch
xml-common-0.6.3-33.fc14.noarch
xml-commons-apis-1.4.01-2.fc15.noarch
xml-commons-resolver-1.2-6.fc15.noarch
xmlgraphics-commons-1.4-1.noarch
xmlrpc-c-1.25.1-1500.svn2077.fc15.i686
xmlrpc-c-client-1.25.1-1500.svn2077.fc15.i686
xmltex-20020625-17.fc15.noarch
xmlto-0.0.23-3.fc13.i686
xmlto-tex-0.0.23-3.fc13.noarch
xmlto-xhtml-0.0.23-3.fc13.noarch

Comment 5 Frank Ch. Eigler 2011-05-18 21:28:20 UTC
Please note that this bug is blocking f15/f16 systemtap rebuilds in koji:
http://koji.fedoraproject.org/koji/getfile?taskID=3080090&name=build.log
http://koji.fedoraproject.org/koji/getfile?taskID=3080115&name=build.log

Comment 6 Stefan Seefeld 2011-05-26 14:01:36 UTC
It seems like Fedora 15 was released with this bug still unresolved.
At least, I upgraded from Fedora 14, and now fop is entirely broken, i.e. no matter how I invoke it, I get the above "java.lang.NoClassDefFoundError" exception.
(Also, I notice a fop 1.0 version being in testing. When will that be ready ?)

Comment 7 Aleksandr Brezhnev 2011-05-30 17:58:02 UTC
fop-0.95-5.fc14 shipped with Fedora 15 is not compatible with avalon-framework-4.3.

Simple check:

$ fop
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/avalon/framework/configuration/ConfigurationException
	at org.apache.fop.apps.FopFactory.<init>(FopFactory.java:150)
	at org.apache.fop.apps.FopFactory.newInstance(FopFactory.java:166)
	at org.apache.fop.cli.CommandLineOptions.<init>(CommandLineOptions.java:102)
	at org.apache.fop.cli.Main.startFOP(Main.java:153)
	at org.apache.fop.cli.Main.main(Main.java:196)
Caused by: java.lang.ClassNotFoundException: org.apache.avalon.framework.configuration.ConfigurationException
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
	... 5 more

$ rpm -q fop
fop-0.95-5.fc14.noarch
$ rpm -q avalon-framework
avalon-framework-4.3-3.fc15.noarch

You can downgrade to avalon-framework-4.1.4 and this error will go away but publican still does not work.

Comment 8 Ruediger Landmann 2011-05-30 22:22:53 UTC
Yes, classes in avalon-framework have changed between 4.2 and 4.3

I'm currently focussing on getting fop 1.0 working for Fedora 15, since as comment #7 notes, there are other problems in 0.95 anyway. :(

Comment 9 Frank Ch. Eigler 2011-06-01 22:24:59 UTC
(In reply to comment #8)
> Yes, classes in avalon-framework have changed between 4.2 and 4.3

OK, if they lack backward compatibility, is the general Java/Fedora way
to patch all the users?  Or to keep shipping a avalon-4.1 rpm?

Comment 10 Ruediger Landmann 2011-06-06 02:05:10 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Yes, classes in avalon-framework have changed between 4.2 and 4.3
> 
> OK, if they lack backward compatibility, is the general Java/Fedora way
> to patch all the users?  Or to keep shipping a avalon-4.1 rpm?

Now fixed in fop-1.0-15.fc15, but which now exposes bug 681337 instead :( 

This particular issue, at any rate, is now fixed...

Comment 11 Ruediger Landmann 2011-06-06 02:06:49 UTC
Correction: it's now bug 689930 that's exposed

Comment 12 Tadashi Koike 2011-07-09 17:58:41 UTC
(In reply to comment #0)
> while running publican/fop.  It aborts the pdf build process.
  :
> org.apache.avalon.framework.configuration.ConfigurationException

I caught same message, when I build X.org modules.
I avoided this message to modify /usr/bin/fop script.

I found this missing class is in /usr/share/java/avalon-framework-api.jar .
So, I added that jar-file to classpath members in /usr/bin/fop as below:
---
[before]
set_classpath commons-io batik-all avalon-framework xmlgraphics-commons \
  commons-logging fop
[after]
set_classpath commons-io batik-all avalon-framework avalon-framework-api xmlgraphics-commons \
  commons-logging fop
---
I don't know whether this method is correct or not.

Thanks,

Comment 13 Aleksandr Brezhnev 2011-08-12 14:03:02 UTC
The update to fop-1.0-16.fc16 from rawhide has fixed the problem with publican on F15.

Comment 14 Daniel Berrangé 2011-08-22 12:34:19 UTC
Can we get the -16 build into Fedora 15 too asap. The -15 build currently submitted as an update for F15 is broken due to missing event-model.xml files.

Comment 15 Fedora Update System 2011-09-07 06:56:32 UTC
fop-1.0-17.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fop-1.0-17.fc15

Comment 16 Fedora Update System 2011-09-08 06:58:35 UTC
Package fop-1.0-17.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fop-1.0-17.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/fop-1.0-17.fc15
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-09-25 03:30:27 UTC
fop-1.0-17.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.