Bug 704651 - [abrt] kernel: BUG: sleeping function called from invalid context at mm/slub.c:795: TAINTED Proprietary Module
Summary: [abrt] kernel: BUG: sleeping function called from invalid context at mm/slub....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d3e3a78f7bd5501fedb6172ba91...
: 706780 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-13 20:43 UTC by Julian Sikorski
Modified: 2011-06-27 17:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-27 17:04:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 699112 None None None Never

Internal Links: 699112

Description Julian Sikorski 2011-05-13 20:43:14 UTC
abrt version: 2.0.1
architecture:   x86_64
cmdline:        ro root=/dev/mapper/vg_snowball2-lv_root rd_LVM_LV=vg_snowball2/lv_root rd_LVM_LV=vg_snowball2/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=pl_PL.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=pl2 rhgb quiet nouveau.modeset=0 rdblacklist=nouveau
comment:        It seems to occur every time I resume from suspend or hibernate.
component:      kernel
kernel:         2.6.38.5-24.fc15.x86_64
kernel_tainted: 1
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         BUG: sleeping function called from invalid context at mm/slub.c:795
time:           Fri May 13 22:41:59 2011

backtrace:
:BUG: sleeping function called from invalid context at mm/slub.c:795
:in_atomic(): 0, irqs_disabled(): 1, pid: 8811, name: pm-hibernate
:Pid: 8811, comm: pm-hibernate Tainted: P            2.6.38.5-24.fc15.x86_64 #1
:Call Trace:
: [<ffffffff81047d33>] __might_sleep+0xeb/0xf0
: [<ffffffff811113ff>] __kmalloc+0x79/0x10d
: [<ffffffff81023683>] ? alloc_ioapic_entries+0x27/0x87
: [<ffffffff81023683>] alloc_ioapic_entries+0x27/0x87
: [<ffffffff81021cc0>] lapic_resume+0x3a/0x24d
: [<ffffffff81396d86>] ? cpufreq_resume+0x2d/0xac
: [<ffffffff812e4981>] __sysdev_resume+0x22/0xc2
: [<ffffffff812e4ad4>] sysdev_resume+0xb3/0xf8
: [<ffffffff81087670>] hibernation_snapshot+0x182/0x23e
: [<ffffffff81087c83>] hibernate+0xc0/0x1b1
: [<ffffffff810866b7>] state_store+0x5c/0xc5
: [<ffffffff8122a4cb>] kobj_attr_store+0x17/0x19
: [<ffffffff811793bd>] sysfs_write_file+0x111/0x14d
: [<ffffffff81121815>] vfs_write+0xac/0xf3
: [<ffffffff81121a04>] sys_write+0x4a/0x6e
: [<ffffffff81009bc2>] system_call_fastpath+0x16/0x1b

Comment 1 Chuck Ebbert 2011-05-20 01:54:06 UTC
The fix will be in 2.6.40:

 http://lkml.org/lkml/2011/5/18/541

Comment 2 Julian Sikorski 2011-05-20 06:25:09 UTC
Cool. What are the chances of 2.6.40 making it to Fedora 15? Otherwise, is backport feasible?

Comment 3 Chuck Ebbert 2011-05-20 16:07:23 UTC
The fix will be in 2.6.38.8

Comment 4 Erik Berg 2011-05-23 12:17:08 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
1. Close laptop lid.
2. Wait.
3. Open laptop lid.

Comment 5 Dave Jones 2011-05-23 22:03:37 UTC
*** Bug 706780 has been marked as a duplicate of this bug. ***

Comment 6 pmodin 2011-05-26 00:13:38 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
close lid
open lid
wait

Comment 7 jeromyj 2011-06-01 03:05:56 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
closed my laptop, and this happened when it resumed.

Comment 8 Stefan Becker 2011-06-16 08:20:20 UTC
I have the same problem on my new Dell Latitude E6420 with kernel 2.6.38.7-30.fc15.x86_64 when resuming from suspend.

Comment 9 Stefan Becker 2011-06-17 13:03:07 UTC
Confirmed. After upgrading to kernel-2.6.38.8-32.fc15.x86_64 the problem disappears. Thanks!

Comment 10 Julian Sikorski 2011-06-18 08:37:00 UTC
Confirmed, seems to be fixed with 2.6.38.8-32.fc15.x86_64.


Note You need to log in before you can comment on or make changes to this bug.