Bug 706780 - [abrt] kernel: BUG: sleeping function called from invalid context at mm/slub.c:795
Summary: [abrt] kernel: BUG: sleeping function called from invalid context at mm/slub....
Keywords:
Status: CLOSED DUPLICATE of bug 704651
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7e820e01cfb0339d93bb6470f8c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-22 23:45 UTC by Erik Berg
Modified: 2011-05-23 22:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-23 22:03:37 UTC


Attachments (Terms of Use)

Description Erik Berg 2011-05-22 23:45:36 UTC
abrt version: 2.0.1
architecture:   x86_64
cmdline:        ro root=/dev/mapper/katie-root rd_LVM_LV=katie/root rd_LVM_LV=katie/swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=no rhgb quiet
component:      kernel
kernel:         2.6.38.6-27.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         BUG: sleeping function called from invalid context at mm/slub.c:795
reported_to:    kerneloops: URL=http://submit.kerneloops.org/submitoops.php
time:           Sat May 21 02:08:43 2011

backtrace:
:BUG: sleeping function called from invalid context at mm/slub.c:795
:in_atomic(): 0, irqs_disabled(): 1, pid: 13398, name: pm-suspend
:Pid: 13398, comm: pm-suspend Not tainted 2.6.38.6-27.fc15.x86_64 #1
:Call Trace:
: [<ffffffff81047d33>] __might_sleep+0xeb/0xf0
: [<ffffffff81111413>] __kmalloc+0x79/0x10d
: [<ffffffff81023683>] ? alloc_ioapic_entries+0x27/0x87
: [<ffffffff81023683>] alloc_ioapic_entries+0x27/0x87
: [<ffffffff81021cc0>] lapic_resume+0x3a/0x24d
: [<ffffffff81396db2>] ? cpufreq_resume+0x2d/0xac
: [<ffffffff812e49b1>] __sysdev_resume+0x22/0xc2
: [<ffffffff812e4b04>] sysdev_resume+0xb3/0xf8
: [<ffffffff81086f3b>] suspend_devices_and_enter+0x149/0x1d6
: [<ffffffff8108709f>] enter_state+0xd7/0x129
: [<ffffffff81086726>] state_store+0xaf/0xc5
: [<ffffffff8122a4d7>] kobj_attr_store+0x17/0x19
: [<ffffffff811793d1>] sysfs_write_file+0x111/0x14d
: [<ffffffff81121829>] vfs_write+0xac/0xf3
: [<ffffffff81121a18>] sys_write+0x4a/0x6e
: [<ffffffff81009bc2>] system_call_fastpath+0x16/0x1b

comment:
:1. Closed the lid on my laptop. (thinkpad x220)
:2. Went out for a kebab.
:3. Came back ~40 minutes later, opened the lid on my laptop.

event_log:
:2011-05-23-01:45:29> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-05-23-01:45:30  Kernel oops report was uploaded

Comment 1 Erik Berg 2011-05-23 12:18:33 UTC
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I have a feeling I can reproduce this every time i suspend my laptop now.

Comment 2 Dave Jones 2011-05-23 22:03:37 UTC

*** This bug has been marked as a duplicate of bug 704651 ***


Note You need to log in before you can comment on or make changes to this bug.