This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 704972 - rhel4.9 guest cannot find cdrom device after boot up (50% reproduce)
rhel4.9 guest cannot find cdrom device after boot up (50% reproduce)
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Markus Armbruster
Virtualization Bugs
:
: 707834 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier3
  Show dependency treegraph
 
Reported: 2011-05-16 04:28 EDT by Golita Yue
Modified: 2011-08-09 10:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-09 10:27:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot (20.48 KB, image/png)
2011-05-16 04:28 EDT, Golita Yue
no flags Details
dmesg (13.31 KB, text/plain)
2011-05-16 04:34 EDT, Golita Yue
no flags Details
messages (2.21 MB, text/plain)
2011-05-16 04:46 EDT, Golita Yue
no flags Details

  None (edit)
Description Golita Yue 2011-05-16 04:28:56 EDT
Created attachment 499096 [details]
screenshot

Description of problem:
rhel4.9 guest cannot find cdrom device after boot up(50% reproduce).

# dd if=/dev/cdrom of=/dev/null bs=1024 count=100
dd: opening `/dev/cdrom': No medium found

# ls -al /dev/cdrom 
lrwxrwxrwx  1 root root 3 May 16 03:53 /dev/cdrom -> hdc

Version-Release number of selected component (if applicable):
host:
kernel 2.6.18-259.el5
kvm-83-232.el5
guest:
kernel 2.6.9-100.ELsmp

How reproducible:
50%

Steps to Reproduce:
1. boot up rhel4.9 guest with cmd
* * * *  cmd * * * * *
# /usr/libexec/qemu-kvm -drive file='RHEL-4.9-32.raw',index=0,if=ide,media=disk,cache=none,format=raw -net nic,vlan=0,model=virtio,macaddr='9a:e3:8e:79:d8:33' -net tap,vlan=0,ifname='t0-174007-A8sb',script='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/scripts/qemu-ifup-switch',downscript='no' -m 4096 -smp 2,cores=1,threads=1,sockets=2 -drive file='/tmp/orig.iso',media=cdrom,index=1 -cpu qemu64,+sse2 -soundhw ac97 -spice port=8000,disable-ticketing -qxl 1 -rtc-td-hack -M rhel5.6.0 -boot c  -usbdevice tablet -no-kvm-pit-reinjection -monitor stdio
* * * * * * * * * * * *
2. run "dd if=/dev/cdrom of=/dev/null bs=1024 count=100"
  
Actual results:
return message: 
dd: opening `/dev/cdrom': No medium found

Expected results:
could find the cdrom device

Additional info:
Attached the dmesg & /var/log/messages log
Comment 1 Golita Yue 2011-05-16 04:34:02 EDT
Created attachment 499098 [details]
dmesg
Comment 2 Golita Yue 2011-05-16 04:46:58 EDT
Created attachment 499100 [details]
messages
Comment 3 Suqin Huang 2011-05-16 05:22:03 EDT
is the index consecutive or inconsecutive when you reproduce this bug, if it's inconsecutive, it should reproduce as bug 654170
Comment 4 Golita Yue 2011-05-16 05:24:21 EDT
reproduce steps:

1. boot up guest
2. reboot guest some times(about 3-10 times)

When boot up guest first time: 
   # file /dev/cdrom 
   /dev/cdrom: symbolic link to `hdb'

   # mkfs /dev/cdrom 
   mke2fs 1.35 (28-Feb-2004)
   /dev/cdrom is entire device, not just one partition!
   Proceed anyway? (y,n) y
   /dev/cdrom: Read-only file system while setting up superblock

But, after reboot some times:
   # file /dev/cdrom
   /dev/cdrom: symbolic link to `hdc'

   # mkfs /dev/cdrom
   mke2fs 1.35 (28-Feb-2004)
   mkfs.ext2: No medium found while trying to determine filesystem size

   # mkfs /dev/hdb
   mke2fs 1.35 (28-Feb-2004)
   /dev/hdb is entire device, not just one partition!
   Proceed anyway? (y,n) y
   /dev/hdb: Read-only file system while setting up superblock

So, the symbolic link point to /dev/hdc automatically after reboot some times.
Comment 8 Golita Yue 2011-05-29 23:23:47 EDT
*** Bug 707834 has been marked as a duplicate of this bug. ***
Comment 10 Markus Armbruster 2011-08-09 05:42:45 EDT
What about RHEL-5 and RHEL-6 guests?  Please try to reproduce and report findings.
Comment 11 Golita Yue 2011-08-09 07:42:32 EDT
Can reproduce this bug in RHEL-5.7 guest, but cannot reproduce it in RHEL-6 guest.

Note You need to log in before you can comment on or make changes to this bug.