Bug 705037 - dhcp-libs not updated
dhcp-libs not updated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-16 09:17 EDT by Steve Tyler
Modified: 2011-05-24 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version: dhcp-4.2.1-9.P1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-24 23:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Tyler 2011-05-16 09:17:56 EDT
Description of problem:
This didn't update dhcp-libs:
$ sudo yum update --enablerepo='updates-testing' dhclient

Version-Release number of selected component (if applicable):
dhclient-4.2.1-7.P1.fc15.x86_64
dhcp-common-4.2.1-7.P1.fc15.x86_64
dhcp-libs-4.2.1-4.P1.fc15.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve Tyler 2011-05-16 09:28:59 EDT
$ sudo yum deplist dhclient
...
  dependency: libomapi.so.0()(64bit)
   provider: dhcp-libs.x86_64 12:4.2.1-4.P1.fc15
...
Comment 2 Jiri Popelka 2011-05-16 10:18:27 EDT
Thank you for the report, however
dhcp-libs package doesn't need to be updated because the dependency on
libomapi.so.0()(64bit) is already satisfied by the installed
dhcp-libs-4.2.1-4.P1.fc15.x86_64


$ yum --enablerepo=updates-testing deplist dhclient
...
package: dhclient.x86_64 12:4.2.1-7.P1.fc15
...
  dependency: libomapi.so.0()(64bit)
   provider: dhcp-libs.x86_64 12:4.2.1-7.P1.fc15
   provider: dhcp-libs.x86_64 12:4.2.1-4.P1.fc15
...
package: dhclient.x86_64 12:4.2.1-4.P1.fc15
...
  dependency: libomapi.so.0()(64bit)
   provider: dhcp-libs.x86_64 12:4.2.1-7.P1.fc15
   provider: dhcp-libs.x86_64 12:4.2.1-4.P1.fc15
...
Comment 3 Jiri Popelka 2011-05-16 10:58:40 EDT
But adding explicit Requires should not do any harm. Reopening :-)
Comment 4 Steve Tyler 2011-05-16 11:50:25 EDT
(In reply to comment #3)
> But adding explicit Requires should not do any harm. Reopening :-)

OK, thanks. Bad things can happen with a version mismatch like that: Bug 700252, Comment 7. :-)
Comment 5 Fedora Update System 2011-05-16 12:10:45 EDT
dhcp-4.2.1-8.P1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dhcp-4.2.1-8.P1.fc15
Comment 6 Steve Tyler 2011-05-16 13:02:04 EDT
yum lets me do this:
$ sudo yum update dhcp-libs-4.2.1-8.P1.fc15.x86_64.rpm

yum does not let me do these:
$ sudo yum update dhcp-common-4.2.1-8.P1.fc15.x86_64.rpm
$ sudo yum update dhcp-common-4.2.1-8.P1.fc15.x86_64.rpm dhcp-libs-4.2.1-8.P1.fc15.x86_64.rpm
Comment 7 Jiri Popelka 2011-05-16 14:04:19 EDT
When you want to test this you either need to wait until the update populates updates-testing or create your own local yum repository (like this http://www.g-loaded.eu/2005/12/11/local-yum-repository/).
Comment 8 Steve Tyler 2011-05-16 14:14:31 EDT
(In reply to comment #7)
> When you want to test this you either need to wait until the update populates
> updates-testing or create your own local yum repository (like this
> http://www.g-loaded.eu/2005/12/11/local-yum-repository/).

OK, thanks. That is good to know.
Comment 9 Steve Tyler 2011-05-16 15:19:02 EDT
I created a local repo populated with build dhcp-4.2.1-8.P1.fc15 from koji.

$ sudo yum update --enablerepo=local-repo dhclient
Pulls in dhcp-common, dhcp-libs.

$ sudo yum update --enablerepo=local-repo dhcp-common
Pulls in dhclient, dhcp-libs.

$ sudo yum update --enablerepo=local-repo dhcp-libs
Does not pull in any other packages.
Comment 10 Fedora Update System 2011-05-17 01:36:01 EDT
Package dhcp-4.2.1-8.P1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.1-8.P1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/dhcp-4.2.1-8.P1.fc15
then log in and leave karma (feedback).
Comment 11 Jiri Popelka 2011-05-17 09:26:03 EDT
(In reply to comment #9)
> $ sudo yum update --enablerepo=local-repo dhcp-libs
> Does not pull in any other packages.

Yes, that's right, but it's actually OK, because:
The old (i.e. 4.2.1-4 or 4.2.1-7) dhclient/dhcp-common packages don't require the same version of dhcp-libs. So when you are updating only dhcp-libs the old dhclient/dhcp-common packages are not updated.
But don't worry, this will be automatically fixed with the next release.
So for example updating only dhcp-libs from 4.2.1-8 to 4.2.1-9 will also pull in dhclient/dhcp-common (I've tested it a moment ago).

Don't know how to explain it in a simpler way so I hope it makes sense :-)
Comment 12 Steve Tyler 2011-05-17 13:44:29 EDT
(In reply to comment #11)
> (In reply to comment #9)
> > $ sudo yum update --enablerepo=local-repo dhcp-libs
> > Does not pull in any other packages.
> 
> Yes, that's right, but it's actually OK, because:
> The old (i.e. 4.2.1-4 or 4.2.1-7) dhclient/dhcp-common packages don't require
> the same version of dhcp-libs. So when you are updating only dhcp-libs the old
> dhclient/dhcp-common packages are not updated.
> But don't worry, this will be automatically fixed with the next release.
> So for example updating only dhcp-libs from 4.2.1-8 to 4.2.1-9 will also pull
> in dhclient/dhcp-common (I've tested it a moment ago).
> 
> Don't know how to explain it in a simpler way so I hope it makes sense :-)

That makes sense ... so I tested with a local repo:
"-4" -> "-8": This behaves as reported in Comment 9.
"-8" -> "-9": Updating dhcp-libs pulls in dhclient, dhcp-common.
Comment 13 Fedora Update System 2011-05-18 14:42:20 EDT
Package dhcp-4.2.1-9.P1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.1-9.P1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/dhcp-4.2.1-9.P1.fc15
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2011-05-24 23:03:49 EDT
dhcp-4.2.1-9.P1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.