Bug 70563 - ps/2 mouse not detected when using USB keyboard
ps/2 mouse not detected when using USB keyboard
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-08-02 11:36 EDT by David Kvarnberg
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kvarnberg 2002-08-02 11:36:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
The ps/2 mouse is not detected during installation when using a USB keyboard.
Switching to a ps/2 keyboard (and restaring installer) resolves the issue.
Tried different mice, one Genius, one Logitech and one MS ps/2 mouse.
The mouse works fine with a USB keyboard after installation.

Version-Release number of selected component (if applicable):
limbo beta 2, limbo2

How reproducible:
Always

Steps to Reproduce:
1.Plug in ps/2 mouse and USB keyboard
2.Boot limbo2 CD
3.anaconda detects no mouse at all
	

Additional info:

May be a vendor specific problem. I only tried this on an A/Open motherboard.
Comment 1 Michael Fulbright 2002-08-02 12:28:56 EDT
Will investigate.
Comment 2 Michael Fulbright 2002-08-14 17:43:39 EDT
This is kernel or hw related - on my hw if I leave the PS/2 keyboard plugged in
until just before the kernel finishes booting and /sbin/linuxrc starts, the
mouse will show up.
Comment 3 Michael K. Johnson 2002-08-14 18:00:34 EDT
msf: *USB* keyboard
Comment 4 Michael Fulbright 2002-08-15 01:45:46 EDT
  I cannot get the PS/2 mouse to be detected at all unless I have the PS/2
keyboard also plugged long enough for the kernel to see it.  This is with the hw
I have available easily. 

Whether or not the USB keyboard is plugged in is not relevant. Apparently some
hw, or the kernel, or some combination of factors, does not register a PS/2
mouse  unless the PS/2 keyboard is also present.

Comment 5 Pete Zaitcev 2002-08-15 12:46:29 EDT
Dr. Mike, please try 2.4.18-11 when it finishes build.

<zaitcev> Why does it happen in BOOT kernel only?
<arjan> in the ps2-mouse-only case, the broken code would fail the very first
           open of /dev/psaux
<arjan> but succeed all later
<arjan> guess what, anaconda is the first
<arjan> while kudzu's probing opens it a few times
<arjan> so you only effectively see it during install
Comment 6 Michael Fulbright 2002-08-21 18:03:34 EDT
Seems to work now thanks.
Comment 7 Jay Turner 2002-08-30 13:54:39 EDT
I'm still seeing a failure with kernel-2.4.18-12.5.  If I have the PS/2 mouse
and the USB keyboard, then the installer doesn't see the mouse.  If I plug back
in the PS/2 keyboard (still leaving the USB keyboard attached) and rerun the
installer, then both keyboards and the mouse work.
Comment 8 Bugzilla owner 2004-09-30 11:39:48 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.