Bug 70648 - no place for wireless config parameters
no place for wireless config parameters
Status: CLOSED DEFERRED
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 75293 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 21:01 EDT by david d zuhn
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 11:47:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My /etc/sysconfig/wireless example (419 bytes, text/plain)
2002-08-02 21:02 EDT, david d zuhn
no flags Details

  None (edit)
Description david d zuhn 2002-08-02 21:01:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
There doesn't appear to be an obvious place to put wireless configuration
information (such as ESSID, mode, keys, etc).  This used
to be in /etc/pcmcia/wireless.opts, with a useful if perhaps cryptic method to
determine which card is in use, and make the right settings.

ifup-wireless (part of initscripts) has the right code to use iwconfig in order
to set the values, but I don't see an obvious
place that this information can be set.  There's no machine 
specific file that's used to provide this sort of info.

Nor have I found any GUIsh tools for supporting this information.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see ifup-wireless
2. look for a place to set ESSID or KEY
3.
	

Additional info:

I added a small chunk of code to ifup-wireless that should look
familiar.

[ -f /etc/sysconfig/wireless ] && . /etc/sysconfig/wireless

Now I can do whatever I need in a shell script to set the parameters
that need setting.  I do miss this being part of the pcmcia settings,
since I use a scheme where if it's in the bottom slot, I use the
values for home and in the top pc card slot, I use the values for
work.  

There should be a good way to manage multiple wireless profiles,
ideally based on information already obtained (like ESSID perhaps,
or MAC address of the AP).  I've hacked something within /etc/sysconfig/wireless
to check which slot I'm in via /var/lib/pcmcia/stab, which is really ugly but it
works.

I couldn't do this unless I made the requested change to ifup-wireless however.
Comment 1 david d zuhn 2002-08-02 21:02:52 EDT
Created attachment 68666 [details]
My /etc/sysconfig/wireless example
Comment 2 Bill Nottingham 2002-08-12 15:38:55 EDT
This is done in /etc/sysconfig/network-scripts/ifcfg-<whatever>
Comment 3 david d zuhn 2002-08-14 11:47:10 EDT
I think this is a serious regression in functionality.  Under the older system
(7.[0123]),
I had a mechanism that was independent of what the actual interface name was,
as it was based on the card type (in /etc/pcmcia/wireless.opts or whatever
the exact file name was).

The fact that ifup-wireless is a separate piece from the remainder of the ifup-
mechanisms is a clear sign that its possible for a wireless card to be on any
interface and separated from some of the basic networking infrastructure.  I
like the idea that this networking info is in /etc/sysconfig/network-scripts
now.  

The problem now is that my wireless interface changes from time to time,
because sometimes I'm using a wired connection at the same time.  If 
ifup-wireless would be interface independent by moving the wireless config
info out of ifcfg-*, I could easily be running with or without additional
interfaces, regardless of the order that I installed the network cards
into this machine.

Now if there were a simple non-code file to edit to place these wireless
config parameters into, I'd be interface independent.

Comment 4 Bill Nottingham 2002-10-07 15:17:36 EDT
This is probably best done by changing the association to something other than
ethX device names; this is a non-trivial change.
Comment 5 Bill Nottingham 2002-10-07 15:17:43 EDT
*** Bug 75293 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.