Bug 706703 - starting virtual network dnsmasq fails, but error message isn't explanatory
starting virtual network dnsmasq fails, but error message isn't explanatory
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-22 08:34 EDT by Reinhard
Modified: 2012-06-06 20:46 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 20:46:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
deplist virt-manager (1.93 KB, text/plain)
2011-05-22 08:34 EDT, Reinhard
no flags Details

  None (edit)
Description Reinhard 2011-05-22 08:34:56 EDT
Created attachment 500259 [details]
deplist virt-manager

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add new virtual machine, install from ISO
2. Assign ISO image (local): Ubuntu 11.04 x64
3. Assigne 2 GB of 4 GB memory, 2 of 4 CPUs
4. Assign 15 GB disk space
5. create and answer "yes" to start new network
  
Actual results:
Installations stops


Expected results:
Installation should continue

Additional info:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/uihelpers.py", line 518, in validate_network
    virnet.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 935, in create
    if ret == -1: raise libvirtError ('virNetworkCreate() failed', net=self)
libvirtError: Interner Fehler Child process (/usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/default.pid --conf-file=  --except-interface lo --listen-address 192.168.122.1 --dhcp-range 192.168.122.2,192.168.122.254 --dhcp-lease-max=253 --dhcp-no-override) exited with status 3.
Comment 1 Reinhard 2011-05-22 08:39:28 EDT
From /var/log/messages:

May 22 14:35:04 gandalf kernel: [16138.256037] [drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... blt ring idle [waiting on 2387544, at 2387544], missed IRQ?
May 22 14:35:05 gandalf libvirtd: 14:35:05.497: 1618: error : interfaceNumOfInterfaces:187 : Internal Error Retrieve number of interfaces of host failed (netcf: unspecified error - errors in loading some config files)
May 22 14:35:05 gandalf libvirtd: 14:35:05.530: 1616: error : interfaceNumOfDefinedInterfaces:229 : Internal Error Retrieve number of defined interfaces of host failed (netcf: unspecified error - errors in loading some config files)

(I tried to translate the german error messages to english)
Comment 2 Reinhard 2011-05-22 08:43:45 EDT
The kernel message might be unrelated. It pops up frequently and not always related to virt-manager issues.
Comment 3 Cole Robinson 2011-07-11 13:24:38 EDT
Hmm, it's tough to tell what the problem is here since we aren't reporting and stdout/stderr output from the failed dnsmasq process. Reassigning to libvirt
Comment 4 solanum 2011-09-01 11:34:56 EDT
I think this might be the same issue but in F16alpha. I was doing an import of an existing disk image. This is the first VM on the host. It initially said something akin to network not started, starting network.. 

Could not start virtual network 'default': internal error Child process (/usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/default.pid --conf-file= --except-interface lo --listen-address 192.168.122.1 --dhcp-range 192.168.122.2,192.168.122.254 --dhcp-leasefile=/var/lib/libvirt/dnsmasq/default.leases --dhcp-lease-max=253 --dhcp-no-override) status unexpected: exit status 2

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/uihelpers.py", line 631, in validate_network
    virnet.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 1452, in create
    if ret == -1: raise libvirtError ('virNetworkCreate() failed', net=self)
libvirtError: internal error Child process (/usr/sbin/dnsmasq --strict-order --bind-interfaces --pid-file=/var/run/libvirt/network/default.pid --conf-file= --except-interface lo --listen-address 192.168.122.1 --dhcp-range 192.168.122.2,192.168.122.254 --dhcp-leasefile=/var/lib/libvirt/dnsmasq/default.leases --dhcp-lease-max=253 --dhcp-no-override) status unexpected: exit status 2
Comment 5 Laine Stump 2011-09-01 13:41:07 EDT
(In reply to comment #4)
> I think this might be the same issue but in F16alpha. I was doing an import of
> an existing disk image. This is the first VM on the host. It initially said
> something akin to network not started, starting network.. 
> 
> [...] exit status 2

The problem in this BZ is with a dnsmasq exit code of 3, which has something to do with a bad file permission, or being unable to open a file for some other reason, so I'm fairly certain that's a different problem.

A dnsmasq exit status of 2 (as you've received) means that there was a problem setting up the socket to listen on the virbrX interface. This is usually caused by a system-wide instance of dnsmasq (configured from /etc/dnsmasq.conf") that is doing a global listen on all addresses/interfaces. I heard just yesterday that F16 is now mistakenly enabling dnsmasq by default, and am assuming a bug has been filed about that.

As far as the original bug report- this message:

> interfaceNumOfInterfaces:187 : Internal Error Retrieve number of interfaces
> of host failed (netcf: unspecified error - errors in loading some config files)

is something that was caused by non threadsafe code in the augeas library, and was fixed a few months ago. Can you verify whether the problem is still occurring on a fully updated F15 machine? If it is still occurring, please include the version of augeas, netcf, and libvirt on the system (output of "rpm -q" for each package) in your reply.

Also, if the problem still occurs, try running "ncftool -d list --all" (ncftool is part of the package "netcf") and attach any error message that may be output.
Comment 6 solanum 2011-09-01 14:18:34 EDT
Laine thanks!! 
systemctl stop dnsmasq.service
systemctl disable dnsmasq.service

Seems to work!!
Comment 7 Ricardo Arguello 2011-09-13 01:24:39 EDT
This is the Fedora 16 Alpha Bug:
https://bugzilla.redhat.com/show_bug.cgi?id=735414
Comment 8 Fedora Admin XMLRPC Client 2011-09-22 13:54:23 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2011-09-22 13:58:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Admin XMLRPC Client 2011-11-30 15:05:22 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Fedora Admin XMLRPC Client 2011-11-30 15:05:32 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Fedora Admin XMLRPC Client 2011-11-30 15:09:11 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Fedora Admin XMLRPC Client 2011-11-30 15:09:31 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 14 Cole Robinson 2012-06-06 20:46:42 EDT
Closing since the F16 bug basically covered this.

Note You need to log in before you can comment on or make changes to this bug.