Bug 706756 - gnome-control-center's Region and Language seems incapable of setting (or correctly reading) the system language
gnome-control-center's Region and Language seems incapable of setting (or cor...
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
RejectedBlocker RejectedNTH
: i18n, Translation
: 712981 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2011-05-22 15:16 EDT by Rolle
Modified: 2012-10-26 00:01 EDT (History)
18 users (show)

See Also:
Fixed In Version: initscripts-9.34-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 759202 (view as bug list)
Last Closed: 2011-11-04 21:19:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rolle 2011-05-22 15:16:39 EDT
Description of problem:
There is no translation on Login-Page of the reboot-menu.

Version-Release number of selected component (if applicable):
Fedora 15 Beta, Gnome 3

How reproducible:
Every time

Steps to Reproduce:
1. boot fedora
2. change the language to german
3. goto the login-page
4. select in the upper right corner the menu and see the entries
5. all entries are in english not in german
Actual results:
all entries are in english "shutdown", ...

Expected results:
all entries should be in german "ausschalten", ...

Additional info:
Comment 1 A S Alam 2011-05-22 22:46:11 EDT
current GDM version:
Comment 2 Rolle 2011-05-23 02:25:44 EDT
The clock on login-page is also not translated. It is presented in english.
Comment 3 Fedora Admin XMLRPC Client 2011-06-21 11:28:50 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-06-21 11:31:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-06-21 11:33:37 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-06-21 11:36:23 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-06-21 11:42:38 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2011-06-21 11:46:44 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2011-06-21 11:48:56 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Admin XMLRPC Client 2011-06-21 11:51:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Fedora Admin XMLRPC Client 2011-06-21 11:52:24 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Adam Williamson 2011-07-25 21:57:09 EDT
To help us in assessing the blocker status of this bug, please cite the release criterion - https://fedoraproject.org/wiki/Fedora_Release_Criteria - you think it infringes. Thanks!

Fedora Bugzappers volunteer triage team
Comment 13 Adam Williamson 2011-07-25 21:57:49 EDT

Fedora Bugzappers volunteer triage team
Comment 14 Akira TAGOH 2011-07-25 23:43:59 EDT
assuming that this should meets to """
All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work
""" in Beta Release Criteria. there are no way to see "that is it" if no translations. we shouldn't assume all of users can read English.
Comment 15 A S Alam 2011-08-09 22:18:58 EDT
it is 16blocker, so moving
Comment 16 Adam Williamson 2011-09-30 14:19:43 EDT
Discussed at 2011-09-30 blocker review meeting. We felt this merits blocker consideration, but we do not have criteria for translations at present. We decided to accept it as NTH and table blocker status until next week; we will aim to propose a criterion for translations this week.
Comment 17 Adam Williamson 2011-10-07 13:44:11 EDT
Discussed again at 2011-10-07 blocker review meeting. We didn't manage to propose the i18n criteria yet, so we're punting on this for another week. We'll definitely evaluate it next week.
Comment 18 Adam Williamson 2011-10-14 13:28:12 EDT
Discussed at 2011-10-14 blocker review meeting. Accepted as a blocker under newly minted criterion "The installer, bootup and login processes should correctly display all sufficiently complete translations available for use." (will be added to the criteria page soon).
Comment 19 Akira TAGOH 2011-10-20 02:02:39 EDT
I can see German on the menu with gdm-3.2.0-2.fc16.x86_64.
So what languages we should actually cover with that criterion?
I saw your mail on the list that says "popular languages". how can I measure which one is really popular?
Comment 20 Adam Williamson 2011-10-20 02:08:47 EDT
with a hand-wave and some IRC arguing - that's usually how we do it. ;)

but the initial report was about German, so maybe this is fixed now? Rolle, can you confirm?
Comment 21 Rolle 2011-10-21 03:53:00 EDT
It doesn't work for me. Sorry.
I downloaded the nightly build desktop-cd-image from 2011-10-19. Installed Fedora 16 Prerelease. Made all updates. Switched the language to german. After reboot and logout the Login-Screen is still presented in english.
Comment 22 Adam Williamson 2011-10-21 11:54:55 EDT
Ah - well that may actually be as intended. What did you 'switch language to German' with exactly? Did you use GNOME's 'Region and Language' or the Fedora 'system-config-language' tool?

If you use 'Region and Language' note that the setting on the Language tab is *your personal* setting. If you then go to the System tab you will see this:

"The login screen, system accounts and new user accounts use the system-wide Region and Language settings. You may change the system settings to match yours."

Can you run that tool, go to that tab, and see what it says your personal settings vs. the system settings are? If the system's still set to English, does using the 'Copy Settings...' button in that dialog help? Thanks!
Comment 23 Rolle 2011-10-22 08:09:43 EDT
I switched the language always with "Region and Language" of the system settings collection from the upper right menu. Then I go to the system tab (which is new in Gnome 3.2, In Fedora 15 Gnome 3.0 there isn't such a tab):
It shows that my personal settings are set to german and the system is set to english. The Button "Copy settings ..." doesn't change anything. Then I logout and the login screens remains in english. (Nightly Buid 2011-10-19: gdm-3.2.0-2.fc16.x86_64)
Now I tried your hint with "system-config-language" and switch the language to german, but the login-screen remains in english.
Comment 24 A S Alam 2011-10-22 13:16:52 EDT
I had a installed Fedora 16 system, tried for German (de_DE.UTF-8) locale. If selected Language German with System-config-language, then GDM shows all entries in non-English (I hope following is German):
1 - Bereitschaft
2 - Neu starten
3 - Ausschalten

Calendar has following:
Samstag, 22. Oktober

for system-config-language need to reboot to take effect, so may not work on live image.

Also I tried following command on fedora 16 (which shows translated message from installed system in selected langauge):
[aalam@yuri ~]$ LANG=de_DE.UTF-8 gettext -d gdm "Shut Down"
[aalam@yuri ~]$ LANG=de_DE.UTF-8 gettext -d gdm "Restart"
[aalam@yuri ~]$ LANG=de_DE.UTF-8 gettext -d gdm "Suspend"

Comment 25 Adam Williamson 2011-10-24 20:19:44 EDT
I can confirm Rolle's experience that the "Copy Configuration" button in the GNOME Control Center appears to do nothing. But I can also confirm A. S. Alam's report that system-config-language works, if you reboot.

Given this, I'm revising my vote to -1 blocker, -1 nth: it doesn't look like there's a bug in gdm preventing translations from being displayed, or anything, the problem if any is a problem in one specific mechanism for changing the system language, which is a less serious issue.

Any other vote changes?
Comment 26 Adam Williamson 2011-10-24 20:20:27 EDT
re-assigning to control-center, there does not appear to be a gdm bug here.
Comment 27 Adam Williamson 2011-10-24 20:21:12 EDT
hum, system-config-language changes gdm, but not the user's desktop. seems like you need to change both to get everything switched.
Comment 28 Kamil Páral 2011-10-25 07:58:06 EDT
Confirmed, system-config-language changes only GDM (translated text is displayed properly after reboot), and control center changes only user session, "copy settings" doesn't work.

-1 to blocker, -1 to nth
Comment 29 Jared Smith 2011-10-25 08:10:47 EDT
Sure, know that we know the full impact, I'm happy to go with -1 to blocker, 0 to NTH
Comment 30 Rolle 2011-10-25 09:56:04 EDT
You all are right. It worked for me.
This was my fault. A S Alam your comment 24 is correct: thats the german strings.
1. I didn't know that I must use "system-config-language".
2. After that I MUST reboot in F16. I understood "system-config-language" that a simple logout is enough (so I hadn't problems to check this with live cd).
In F15 was the logout enough to change the Login-translations.

And in my many tries I realized, that this language-switch is a complex thing. Is this really needed?
a: On a live cd or a fresh install I need Internet-connection to get the tool "system-config-language". But I don't have an internet-connection everywhere.
Then the language-portion which is loaded from internet depends from the installed applications. On that fresh install the switch to german is very quick done. But on my horsepower-PC with F15 installation is LibreOffice, GCompris, ... and I switched already to german. But the "system-config-language" told me that no german support is installed and then it loaded many files which took an era on my one pc that has a very very small and very very instable internet connection.
Some files are checked that these are already on my pc but I believe that some other files downloaded for a second time. Are there unneeded dependencies? But this is a subjective feeling. 

b: The tool "Region and Language" should give a hint that "system-config-language" is needed for the system-wide settings.

c: Is it possible to do on the loginscreen an easy language switcher for everyone? The menu could show all installed languages for the login-screen and should be presented like this: first the english name and in braces the native name) like many installers do.
german (deutsch)

Thanks for all which helped me. For me this bug is closed, because this was not really a bug. I didn't know it better.

All you guys which are envolved in the translation-system, thank you for all your hard work until now and keep your motivation for another long time.
Comment 31 Adam Williamson 2011-10-25 11:52:37 EDT
Rolle: in previous Fedoras, GDM had a little dialog which let you pick the language before you logged in.

In GNOME 3.2 that's been dropped on the basis that you can just pick the language after you log in, but that leads to this little problem. :/

It should be less of a problem if control-center is fixed so it can actually set the system-wide language.
Comment 32 Adam Williamson 2011-10-25 11:56:35 EDT
I confirmed that you can at least change the language for the desktop in the live image by using the GNOME tool and logging out / back in after you change it. Which is a bit clunky, but at least works.
Comment 33 Adam Williamson 2011-10-25 11:58:15 EDT
So, adjusting for the re-vote: now not a blocker or NTH, now we understand it better. But control-center needs fixing so it can set the system language.
Comment 34 Bill Nottingham 2011-10-25 15:21:45 EDT
There are two bugs here.

1) The assorted setup scripts (lang.sh, etc.) don't read /etc/locale.conf that is being written here. This is fixed in http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=d088bd27ef9fac2695c9769b4fbb230e32d93b31, which will go out shortly in an initscripts update.

2) The SELinux policy is squashing the communication between policykit and the assorted systemd mechanisms. I believe this can be fixed by:

diff --git a/policy-F16.patch b/policy-F16.patch
index 60b7398..61effe4 100644
--- a/policy-F16.patch
+++ b/policy-F16.patch
@@ -48354,6 +48354,7 @@ index 1e7169d..05409ab 100644
 +      dbus_system_domain(policykit_t, policykit_exec_t)
++      init_dbus_chat(policykit_t)
 +      optional_policy(`
 +              consolekit_dbus_chat(policykit_t)
 +      ')
Comment 35 Adam Williamson 2011-10-25 15:31:41 EDT
un-setting AcceptedBlocker, as we don't have votes on the revised problem, here.

i'm still not entirely sure this is a blocker, if s-c-language works, and you can set language during install on the DVD path...how is fixing this on the images significantly better than fixing it with an update? what criteria are we breaking?

if the fixes can make it work with just a log out / log in on the live image i guess i'd be +1 nth at least...
Comment 36 Adam Williamson 2011-10-25 15:37:36 EDT
notting's changes to the blocker status were apparently just a mistake, so reverting.
Comment 37 Fedora Update System 2011-10-25 15:56:22 EDT
initscripts-9.34-2.fc16 has been submitted as an update for Fedora 16.
Comment 38 Fedora Update System 2011-10-25 17:44:37 EDT
Package initscripts-9.34-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.34-2.fc16'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 39 Fedora Update System 2011-11-04 21:19:48 EDT
initscripts-9.34-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 40 Bill Nottingham 2012-10-26 00:01:23 EDT
*** Bug 712981 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.