Bug 712981 - Change /etc/sysconfig/i18n to /etc/locale.conf in lang.*
Change /etc/sysconfig/i18n to /etc/locale.conf in lang.*
Status: CLOSED DUPLICATE of bug 706756
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-13 15:37 EDT by Jochen Schmitt
Modified: 2014-03-16 23:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 00:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested Cnages as git patch (3.05 KB, patch)
2011-06-13 15:37 EDT, Jochen Schmitt
no flags Details | Diff

  None (edit)
Description Jochen Schmitt 2011-06-13 15:37:43 EDT
Created attachment 504527 [details]
Suggested Cnages as git patch

Because systemd introduced /etc/locale.conf as a configuration file for the locale I want to suggest to replace the reference to /etc/sysconfig/i18n to /etc/locale.conf in lang.*
Comment 1 Bill Nottingham 2011-06-13 16:08:33 EDT
NAK as posted... we need to support the old file as a fallback.
Comment 2 Jochen Schmitt 2011-06-16 13:59:13 EDT
O; from my point of view, we should have only one global configuration file. If we need the old file name as a failback solution, it should be a sym link to the primary configuration file.
Comment 3 Bill Nottingham 2011-06-16 14:39:07 EDT
That only works if they're the same format.
Comment 4 Jochen Schmitt 2011-06-16 14:54:36 EDT
Both files (/etc/locale.conf and /etc/sysconfig/i18n) are simple collections of assignements of shell variables.

For /etc/locale.conf please refer man 5 locale.conf for further information.
Comment 5 Bill Nottingham 2012-10-26 00:01:23 EDT
This got done a while ago.

*** This bug has been marked as a duplicate of bug 706756 ***

Note You need to log in before you can comment on or make changes to this bug.