Bug 70686 - cann't display locale file name coded with utf-8.
Summary: cann't display locale file name coded with utf-8.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
: 70228 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-04 01:08 UTC by Deng Guang
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-16 15:32:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Deng Guang 2002-08-04 01:08:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Edit a file with gedit and save it to your home directory with a Chinese name
2. type ls ~ in a gnme terminal
3. 
	

Expected Results:  The file name coded with utf-8 can also be listed in gnome
terminal crectly.

Additional info:

Comment 1 Havoc Pennington 2002-08-04 15:42:23 UTC
gedit probably needs a g_utf8_to_filename() call, it should be saving 
locale-encoded filenames in Chinese.

Comment 2 Owen Taylor 2002-08-04 16:04:31 UTC
This is just a dup of the 'should set G_BROKEN_FILENAMES' bug.


Comment 3 Havoc Pennington 2002-08-14 02:10:01 UTC
glib2 2.0.6-2 will set G_BROKEN_FILENAMES on login (from /etc/profile.d) 
which should cause gedit to save in locale encoding.

Comment 4 Owen Taylor 2002-08-14 02:45:23 UTC
*** Bug 70228 has been marked as a duplicate of this bug. ***

Comment 5 Jay Turner 2002-08-16 15:32:18 UTC
Would someone please confirm this is resolved, as I'm not 'up' on my Chinese
filenames :-)


Note You need to log in before you can comment on or make changes to this bug.