Bug 706868 - Guide references /tftpboot/ folder which is not present on rhel6
Guide references /tftpboot/ folder which is not present on rhel6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Reference Guide (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lana Brindley
ecs-bugs
:
: 707169 (view as bug list)
Depends On:
Blocks: sat54-docs
  Show dependency treegraph
 
Reported: 2011-05-23 05:57 EDT by Šimon Lukašík
Modified: 2013-10-23 19:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-02 16:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2011-05-23 05:57:10 EDT
Description of problem:
RHN Satellite 5.4.1 Reference Guide references /tftpboot/ folder which is
not present on rhel6. In the section: '11.1.4.1. SELinux Configuration'
there is:

    semanage fcontext -a -t public_content_t "/tftpboot/.*"

For Satellite on rhel6, documentation should mention the following instead:

    semanage fcontext -a -t public_content_t "/var/lib/tftpboot/.*"
    semanage fcontext -a -t public_content_t "/var/www/cobbler/images/.*"
Comment 1 Šimon Lukašík 2011-05-25 02:30:50 EDT
Correction: The last line, might not be listed in the documentation:

    semanage fcontext -a -t public_content_t "/var/www/cobbler/images/.*"

It is not essential for the Satellite use case. Additionally, it's
a same for rhel5. Where we have not mentioned it.
Comment 2 Šimon Lukašík 2011-05-25 06:44:12 EDT
This bug relies on a resolution of 707215 comment 6.
Comment 3 Jan Pazdziora 2011-05-25 08:43:54 EDT
Actually, the correct fix is to remove that semanage advice altogether. It is not needed nor useful.
Comment 5 Lana Brindley 2011-06-13 16:13:29 EDT
Slated for 5.4.2.

LKB
Comment 6 Jim Cromie 2011-06-13 16:39:27 EDT
its worth noting that syslinux-tftpboot puts its files in /tftpboot,
where theyre not reachable by tftp-server.

Is there any move towards using /srv/tftp ?
(an apparently emerging FHS standard loc)
Comment 7 Lana Brindley 2011-09-22 16:39:40 EDT
Commented out.

Revision 2-4 of the 5.4 Reference Guide.

This will be respun on docs.redhat.com following QA verification.

LKB
Comment 8 Lana Brindley 2011-09-22 16:40:50 EDT
*** Bug 707169 has been marked as a duplicate of this bug. ***
Comment 10 Lana Brindley 2011-10-02 16:13:21 EDT
The updated document is now publicly available on docs.redhat.com. For any further changes, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.