Bug 707169 - Advice 'restorecon', where the 'semanage fcontext' is mentioned
Advice 'restorecon', where the 'semanage fcontext' is mentioned
Status: CLOSED DUPLICATE of bug 706868
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Reference Guide (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lana Brindley
ecs-bugs
:
Depends On:
Blocks: sat54-docs
  Show dependency treegraph
 
Reported: 2011-05-24 06:04 EDT by Šimon Lukašík
Modified: 2013-10-23 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 16:40:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2011-05-24 06:04:52 EDT
Description of problem:
In the Satellite 5.4.1 Reference Guide, in the section

    11.1.4.1. SELinux Configuration

there is a written 

    semanage fcontext -a -t public_content_t "/tftpboot/.*"

command. Which is not enough for some cases, I am afraid. We better
explicitly mention 'restorecon' command on that directory. E.g.:

    restorecon -r "/tftpboot/"

Which, I hope, may save a time for a users, which are not selinux experts.
In an ideally world, each 'occurrence of semanage fcontext' would be
followed by an appropriate 'restorecon' command.



Version-Release number of selected component (if applicable):
Satellite 5.4.0
Comment 1 Jan Pazdziora 2011-05-25 10:06:53 EDT
In bug 706868 comment 3, I suggest to remove that semanage, which would make this bugzilla a NOOP.
Comment 3 Lana Brindley 2011-06-13 16:13:45 EDT
Slated for 5.4.2.

LKB
Comment 4 Lana Brindley 2011-09-22 16:40:50 EDT
Handled in BZ#706868.

LKB

*** This bug has been marked as a duplicate of bug 706868 ***

Note You need to log in before you can comment on or make changes to this bug.