This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 706879 - [abrt] python-twisted-core-10.2.0-2.fc15: _twistd_unix.py:79:checkPID:OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'
[abrt] python-twisted-core-10.2.0-2.fc15: _twistd_unix.py:79:checkPID:OSError...
Status: CLOSED DUPLICATE of bug 702841
Product: Fedora
Classification: Fedora
Component: python-twisted-core (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Vander Stichele
Fedora Extras Quality Assurance
abrt_hash:af606c1622b048954d758ab7a47...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-23 06:44 EDT by kalgecin
Modified: 2011-05-23 11:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 11:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kalgecin 2011-05-23 06:44:56 EDT
abrt version: 2.0.1
architecture:   i686
cmdline:        /usr/bin/python /usr/bin/twistd -r gtk2 --pidfile /tmp/vmc.pid -noy /usr/share/vodafone-mobile-connect/gtk-tap.py
component:      python-twisted-core
executable:     /usr/bin/twistd
kernel:         2.6.38.6-27.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        python-twisted-core-10.2.0-2.fc15
reason:         _twistd_unix.py:79:checkPID:OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'
time:           Sun May 22 17:40:17 2011
uid:            500
username:       kalgecin

backtrace:
:_twistd_unix.py:79:checkPID:OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'
:
:Traceback (most recent call last):
:  File "/usr/bin/twistd", line 19, in <module>
:    run()
:  File "/usr/lib/python2.7/site-packages/twisted/scripts/twistd.py", line 27, in run
:    app.run(runApp, ServerOptions)
:  File "/usr/lib/python2.7/site-packages/twisted/application/app.py", line 631, in run
:    runApp(config)
:  File "/usr/lib/python2.7/site-packages/twisted/scripts/twistd.py", line 23, in runApp
:    _SomeApplicationRunner(config).run()
:  File "/usr/lib/python2.7/site-packages/twisted/application/app.py", line 373, in run
:    self.preApplication()
:  File "/usr/lib/python2.7/site-packages/twisted/scripts/_twistd_unix.py", line 192, in preApplication
:    checkPID(self.config['pidfile'])
:  File "/usr/lib/python2.7/site-packages/twisted/scripts/_twistd_unix.py", line 79, in checkPID
:    os.remove(pidfile)
:OSError: [Errno 1] Operation not permitted: '/tmp/vmc.pid'
:
:Local variables in innermost frame:
:pid: 22185
:why: OSError(3, 'No such process')
:pidfile: '/tmp/vmc.pid'
Comment 1 Julian Sikorski 2011-05-23 10:54:11 EDT

*** This bug has been marked as a duplicate of bug 702481 ***
Comment 2 Julian Sikorski 2011-05-23 10:54:27 EDT

*** This bug has been marked as a duplicate of bug 702841 ***
Comment 3 Peter Robinson 2011-05-23 11:01:58 EDT
This isn't a dupe of the Sugar on a Stick blocker.
Comment 4 Julian Sikorski 2011-05-23 11:12:59 EDT
Yeah, I know. I just made the same typo again...

*** This bug has been marked as a duplicate of bug 702841 ***

Note You need to log in before you can comment on or make changes to this bug.